Update changed my date format

Post your update and upgrade related errors here
Forum rules
Before you post please read this

Update changed my date format

Postby rolandpish on Thu Apr 14, 2011 1:37 am

Hi there.
Yesterday I performed a dist-upgrade and after that, my date format changed. How did I notice that?
Well, before the upgrade, time marks in skype chat appeared like this: 11:22:54 PM and now they appear like this: 23:22:54 CST and I can't find where to change it back to where it was.

Any help is appreciated.

Cheers
rolandpish
Level 2
Level 2
 
Posts: 59
Joined: Sun Jul 25, 2010 4:33 pm

Linux Mint is funded by ads and donations.
 

Re: Update changed my date format

Postby viking777 on Thu Apr 14, 2011 7:51 am

I think the command

Code: Select all
date %r


Is what you want. but I haven't tested it because I don't want to change the way my clock displays.

BTW. If it complains about permissions just add sudo in front of it.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: Update changed my date format

Postby maxmir on Thu Apr 14, 2011 8:10 am

'date +%r' just prints out the date on the command line in the requested format, it doesn't change the date.

Plus, the question seemed to relate to the format used in skype. Perhaps either skype, tzdata or something locale related got updated. If skype doesn't allow you to change it back, I'd suggest looking at the locale settings.
User avatar
maxmir
Level 1
Level 1
 
Posts: 19
Joined: Thu Mar 24, 2011 1:41 pm

Re: Update changed my date format

Postby rolandpish on Thu Apr 14, 2011 10:06 am

Thanks for your input.

I'm in another LMDE box that I haven't updated, and skype is showing the "normal" time marks. I'm revising now the "updatable" packages to see if there's at least one related to locale.

I'll let you know what happens.

Cheers.
rolandpish
Level 2
Level 2
 
Posts: 59
Joined: Sun Jul 25, 2010 4:33 pm

Re: Update changed my date format

Postby rolandpish on Thu Apr 14, 2011 11:28 am

Well, no, haven't found an "updateable" package related to locale. I'll update this box anyway but any further help is really appreciated :)
rolandpish
Level 2
Level 2
 
Posts: 59
Joined: Sun Jul 25, 2010 4:33 pm

Re: Update changed my date format

Postby rolandpish on Fri Apr 15, 2011 11:31 am

Ok, in my 64bit box my LMDE 64 bit updated without problems and "time marks" are still normal. In my other box with LMDE 32 bit the "time marks" were converted to that 23:54:55 CST.
rolandpish
Level 2
Level 2
 
Posts: 59
Joined: Sun Jul 25, 2010 4:33 pm


Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 7 guests