Can not update

Post your update and upgrade related errors here
Forum rules
Before you post please read this

Can not update

Postby rommel1234 on Sat Apr 16, 2011 6:20 am

I have just installed LMDE and I try to use Update Manager to install Updates. But it just tell me that "Could not apply changes Fix broken packages first"
I have no idea about it. Can someone tell how to fix it? :D
rommel1234
Level 1
Level 1
 
Posts: 3
Joined: Sat Apr 16, 2011 6:11 am

Linux Mint is funded by ads and donations.
 

Re: Can not update

Postby xircon on Sat Apr 16, 2011 7:43 am

Launch synaptic, go to custom filters (bottom left) > broken (top left) work out what is broken.
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"
User avatar
xircon
Level 5
Level 5
 
Posts: 775
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: Can not update

Postby amina on Sat Apr 16, 2011 7:56 am

Most likely you do not have any broken packages just get the usual error we used to get with older verions of MintUpdate.
If you upgrade MintUpdate then re-launch it, the message will go away :)
amina
Level 3
Level 3
 
Posts: 140
Joined: Wed Mar 02, 2011 4:45 am

Re: Can not update

Postby zerozero on Sat Apr 16, 2011 8:00 am

the easiest fix: open a terminal and

Code: Select all
sudo apt-get update && sudo apt-get dist-upgrade
zerozero
Level 16
Level 16
 
Posts: 6467
Joined: Tue Jul 07, 2009 2:29 pm

Re: Can not update

Postby rommel1234 on Sat Apr 16, 2011 8:07 am

xircon wrote:Launch synaptic, go to custom filters (bottom left) > broken (top left) work out what is broken.

I found nonthing there... :x
rommel1234
Level 1
Level 1
 
Posts: 3
Joined: Sat Apr 16, 2011 6:11 am

Re: Can not update

Postby xircon on Sat Apr 16, 2011 8:08 am

Then follow the post above and run sudo apt-get update && sudo apt-get dist-upgrade from a terminal
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"
User avatar
xircon
Level 5
Level 5
 
Posts: 775
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: Can not update

Postby rommel1234 on Sat Apr 16, 2011 11:20 am

amina wrote:Most likely you do not have any broken packages just get the usual error we used to get with older verions of MintUpdate.
If you upgrade MintUpdate then re-launch it, the message will go away :)

Thanks for your advice! It works! :D
rommel1234
Level 1
Level 1
 
Posts: 3
Joined: Sat Apr 16, 2011 6:11 am

Linux Mint is funded by ads and donations.
 

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 3 guests