Broken after upgrade: mintmenu, gnome-screensaver & xmodmap

Post your update and upgrade related errors here
Forum rules
Before you post please read how to get help

Broken after upgrade: mintmenu, gnome-screensaver & xmodmap

Postby XeroXer on Tue Apr 19, 2011 7:08 am

First I made a comment in the LMDE BREAKAGES thread but was thinking that this might be better in a thread of it's own.

19/04-11 18:43 update: Tried booting into the old kernel 2.6.32-5-amd64 and still no success with any of the problems. They are all still there...

I made a dist-upgrade to my system between 2011-04-13 13:36:32 and 2011-04-13 13:40:03 which have caused a few annoyances in my system.

mintmenu:
The mintmenu stopped working and was removed from the panel, trying to add it will add what looks like a separator, the mintmenu process will go up to 100% and nothing else will happen. Killing it will trigger the message from the panel if I want to reload the applet, doing so will do the same thing over and over again. Trying to add the gnome menu will work but pressing it will freeze the whole computer.

gnome-screensaver:
Letting the computer go into screensaver mode is a bad idea, one of my screens goes black while the other freezes the last view I had. I can still move the mouse but not click or do anything, and the one screen is still black. Going into Ctrl+Alt+F1 and killing the gnome-screensaver and then going back will work. I can then use the computer as normal but without any screensaver or lock screen functionality.

xmodmap:
My ~/.bashrc file has these line in it:
Code: Select all
# xmodmap to disable caps lock functionality but still make it possible to use in mangler
xmodmap -e "remove lock = Caps_Lock"

I added this to be able to use Caps Lock as my Push-To-Talk key in Mangler without enabling and disabling the Caps Lock functionality all the time. This also worked fine up until the upgrade, now the Caps Lock is triggered and even if I do this command in the terminal it does nothing more.

/var/log/apt/history.log:
Code: Select all
Start-Date: 2011-04-13  13:36:32
Commandline: apt-get dist-upgrade
Install: libppl9:amd64 (0.11.2-3, automatic), linux-kbuild-2.6.38:amd64 (2.6.38-1, automatic), gcc-4.6-base:amd64 (4.6.0-2, automatic), libpwl5:amd64 (0.11.2-3, automatic), linux-headers-2.6.38-2-amd64:amd64 (2.6.38-3, automatic), linux-headers-2.6.38-2-common:amd64 (2.6.38-3, automatic), libquadmath0:amd64 (4.6.0-2, automatic), libppl-c4:amd64 (0.11.2-3, automatic), x11proto-xext-dev:amd64 (7.1.2-1, automatic), libxext-dev:amd64 (1.2.0-2, automatic), rpcbind:amd64 (0.2.0-6, automatic), linux-image-2.6.38-2-amd64:amd64 (2.6.38-3, automatic)
Upgrade: libkrb5-3:amd64 (1.9+dfsg-1, 1.9+dfsg-1+b1), libk5crypto3:amd64 (1.9+dfsg-1, 1.9+dfsg-1+b1), libpcsclite1:amd64 (1.6.6-2, 1.7.2-1), libxmlsec1:amd64 (1.2.14-1, 1.2.14-1.1), libstdc++6:amd64 (4.5.2-4, 4.6.0-2), xserver-xorg-video-i740:amd64 (1.3.2-2, 1.3.2-4), aptitude-doc-en:amd64 (0.6.3-3.2, 0.6.3-4), xserver-xorg-video-apm:amd64 (1.2.2-2, 1.2.3-2), xserver-xorg-video-ark:amd64 (0.7.2-2, 0.7.3-2), fakeroot:amd64 (1.14.5-1, 1.15.1-1), xserver-xorg-video-ati:amd64 (6.13.1-2+squeeze1, 6.14.0-1), libcupsppdc1:amd64 (1.4.6-3, 1.4.6-4), libcupsimage2:amd64 (1.4.6-3, 1.4.6-4), libcupscgi1:amd64 (1.4.6-3, 1.4.6-4), xserver-xorg-video-openchrome:amd64 (0.2.904+svn842-2, 0.2.904+svn918-1), libselinux1:amd64 (2.0.96-1, 2.0.98-1), libcupsdriver1:amd64 (1.4.6-3, 1.4.6-4), gdebi:amd64 (0.7.0, 0.7.1), libppl7:amd64 (0.10.2-8, 0.10.2-10), xserver-xorg-video-s3virge:amd64 (1.10.4-2, 1.10.4-4), xserver-xorg-video-mga:amd64 (1.4.11.dfsg-4+squeeze1, 1.4.13.dfsg-3), xserver-xorg-video-chips:amd64 (1.2.3-1, 1.2.4-1), libdrm-radeon1:amd64 (2.4.23-0.0, 2.4.23-3), g++-4.5:amd64 (4.5.2-4, 4.5.2-8), perl:amd64 (5.10.1-18, 5.10.1-19), libgl1-mesa-dev:amd64 (7.7.1-4, 7.10-4), xserver-xorg-core:amd64 (1.7.7-13, 1.9.5-1), xserver-xorg-video-mach64:amd64 (6.8.2-3, 6.8.2-5), libcrypt-ssleay-perl:amd64 (0.57-2, 0.57-2+b1), xserver-common:amd64 (1.7.7-13, 1.9.5-1), libgl1-mesa-dri:amd64 (7.7.1-4, 7.10-4), xserver-xorg-video-trident:amd64 (1.3.3-2, 1.3.4-2), libccid:amd64 (1.4.2-2, 1.4.3-1), cups-client:amd64 (1.4.6-3, 1.4.6-4), libgl1-mesa-glx:amd64 (7.7.1-4, 7.10-4), xserver-xorg-video-sis:amd64 (0.10.3-1, 0.10.3-3), libselinux1-dev:amd64 (2.0.96-1, 2.0.98-1), libjack-jackd2-0:amd64 (1.9.6~dfsg.1-2, 1.9.7~dfsg-1), strace:amd64 (4.5.20-2.2, 4.5.20-2.3), libstdc++6-4.5-dev:amd64 (4.5.2-4, 4.5.2-8), perl-base:amd64 (5.10.1-18, 5.10.1-19), aptitude:amd64 (0.6.3-3.2, 0.6.3-4), libgomp1:amd64 (4.5.2-4, 4.6.0-2), xserver-xorg-video-siliconmotion:amd64 (1.7.3-2, 1.7.5-1), gdebi-core:amd64 (0.7.0, 0.7.1), perl-modules:amd64 (5.10.1-18, 5.10.1-19), libkrb5-dev:amd64 (1.9+dfsg-1, 1.9+dfsg-1+b1), xserver-xorg-video-savage:amd64 (2.3.1-2, 2.3.2-3), mintsystem:amd64 (7.7.3, 7.7.5), xserver-xorg-video-tdfx:amd64 (1.4.3-2, 1.4.3-4), gcc-4.5:amd64 (4.5.2-4, 4.5.2-8), cups-ppdc:amd64 (1.4.6-3, 1.4.6-4), libgssrpc4:amd64 (1.9+dfsg-1, 1.9+dfsg-1+b1), mesa-common-dev:amd64 (7.7.1-4, 7.10-4), lib32gcc1:amd64 (4.5.2-4, 4.6.0-2), linux-image-2.6-amd64:amd64 (2.6.32+29, 2.6.38+33), conky-all:amd64 (1.8.0-1, 1.8.0-1.1), xserver-xorg-video-intel:amd64 (2.13.0-6, 2.14.0-4), libgcc1:amd64 (4.5.2-4, 4.6.0-2), xserver-xorg-input-all:amd64 (7.5+8, 7.6+6), libdrm2:amd64 (2.4.23-0.0, 2.4.23-3), cups-common:amd64 (1.4.6-3, 1.4.6-4), xserver-xorg-video-vmware:amd64 (11.0.1-2, 11.0.3-2), libppl-c2:amd64 (0.10.2-8, 0.10.2-10), xserver-xorg-video-r128:amd64 (6.8.1-3, 6.8.1-5), libcups2:amd64 (1.4.6-3, 1.4.6-4), xserver-xorg-input-evdev:amd64 (2.3.2-6, 2.6.0-2), libkrb5support0:amd64 (1.9+dfsg-1, 1.9+dfsg-1+b1), xserver-xorg-video-vesa:amd64 (2.3.0-3, 2.3.0-5), mint-x-theme:amd64 (1.0.1, 1.0.3), linux-base:amd64 (3, 3.2), libdrm-intel1:amd64 (2.4.23-0.0, 2.4.23-3), xserver-xorg-video-s3:amd64 (0.6.3-2, 0.6.3-4), xserver-xorg:amd64 (7.5+8, 7.6+6), gdm3:amd64 (2.30.5-8, 2.30.5-9), cups:amd64 (1.4.6-3, 1.4.6-4), xserver-xorg-video-voodoo:amd64 (1.2.3-2, 1.2.4-2), xserver-xorg-video-fbdev:amd64 (0.4.2-2, 0.4.2-4), xserver-xorg-input-wacom:amd64 (0.10.5+20100416-1, 0.10.10+20110203-1), libcloog-ppl0:amd64 (0.15.9-2, 0.15.9-3), xserver-xorg-video-neomagic:amd64 (1.2.4-3, 1.2.5-2), virtualbox-4.0:amd64 (4.0.4-70112~Debian~squeeze, 4.0.4-70112~Ubuntu~maverick), cups-bsd:amd64 (1.4.6-3, 1.4.6-4), libkadm5clnt-mit8:amd64 (1.9+dfsg-1, 1.9+dfsg-1+b1), libgeoip1:amd64 (1.4.7~beta12+dfsg-1, 1.4.7~beta13+dfsg-1), libperl5.10:amd64 (5.10.1-18, 5.10.1-19), liblircclient0:amd64 (0.8.3-5, 0.9.0~pre1-1), gcc-4.5-base:amd64 (4.5.2-4, 4.5.2-8), libkadm5srv-mit8:amd64 (1.9+dfsg-1, 1.9+dfsg-1+b1), x11-common:amd64 (7.5+8, 7.6+6), libgfortran3:amd64 (4.5.2-4, 4.6.0-2), xserver-xorg-video-sisusb:amd64 (0.9.3-2, 0.9.4-2), cpp-4.5:amd64 (4.5.2-4, 4.5.2-8), libkdb5-5:amd64 (1.9+dfsg-1, 1.9+dfsg-1+b1), lib32stdc++6:amd64 (4.5.2-4, 4.6.0-2), linux-libc-dev:amd64 (2.6.32-31, 2.6.38-3), xserver-xorg-video-tseng:amd64 (1.2.3-2, 1.2.4-2), xserver-xorg-video-radeon:amd64 (6.13.1-2+squeeze1, 6.14.0-1), krb5-multidev:amd64 (1.9+dfsg-1, 1.9+dfsg-1+b1), libglu1-mesa:amd64 (7.7.1-4, 7.10-4), libgssapi-krb5-2:amd64 (1.9+dfsg-1, 1.9+dfsg-1+b1), libcupsmime1:amd64 (1.4.6-3, 1.4.6-4), xserver-xorg-video-cirrus:amd64 (1.3.2-2+squeeze1, 1.3.2-4), binutils:amd64 (2.21.0.20110327-2, 2.21.0.20110327-3), linux-headers-2.6-amd64:amd64 (2.6.32+29, 2.6.38+33), nfs-common:amd64 (1.2.3-1, 1.2.3-2), xserver-xorg-input-synaptics:amd64 (1.2.2-2, 1.4.0-1), pcscd:amd64 (1.6.6-2, 1.7.2-1), xserver-xorg-video-rendition:amd64 (4.2.3-3, 4.2.4-2), xserver-xorg-video-i128:amd64 (1.3.3-2, 1.3.4-2)
Remove: portmap:amd64 (6.0.0-3)
End-Date: 2011-04-13  13:40:03


/etc/apt/sources.list:
Code: Select all
deb http://packages.linuxmint.com/ debian main upstream import
deb http://ftp.debian.org/debian testing main contrib non-free
deb http://security.debian.org/ testing/updates main contrib non-free
deb http://www.debian-multimedia.org testing main non-free
deb-src http://packages.linuxmint.com/ debian main upstream import
deb-src http://ftp.debian.org/debian testing main contrib non-free
deb-src http://security.debian.org/ testing/updates main contrib non-free
deb-src http://www.debian-multimedia.org testing main non-free

# http://wiki.debian.org/Backports
deb http://backports.debian.org/debian-backports squeeze-backports main
deb-src http://backports.debian.org/debian-backports squeeze-backports main

# http://wiki.debian.org/DebianUnstable
deb http://ftp.debian.org/debian unstable main contrib non-free
deb-src http://ftp.debian.org/debian unstable main contrib non-free
# http://wiki.debian.org/DebianExperimental
deb http://ftp.debian.org/debian experimental main contrib non-free
deb-src http://ftp.debian.org/debian experimental main contrib non-free


/etc/apt/sources.list.d/lamaresh.net.list:
Code: Select all
# http://www.winehq.org/download/deblenny
deb http://www.lamaresh.net/apt sid main


/etc/apt/sources.list.d/spotify-previews.list:
Code: Select all
deb http://repository.spotify.com stable non-free


/etc/apt/sources.list.d/virtualbox.org.list:
Code: Select all
# http://www.virtualbox.org/wiki/Linux_Downloads
deb http://download.virtualbox.org/virtualbox/debian squeeze contrib


/etc/apt/preferences:
Code: Select all
Package: *
Pin: release o=linuxmint
Pin-Priority: 700

Package: *
Pin: origin packages.linuxmint.com
Pin-Priority: 700

Package: *
Pin: release a=testing
Pin-Priority: 500


/etc/apt/preferences.d/backports:
Code: Select all
Package: *
Pin: release a=squeeze-backports
Pin-Priority: 50


/etc/apt/preferences.d/experimental:
Code: Select all
Package: *
Pin: release a=experimental
Pin-Priority: 100


/etc/apt/preferences.d/unstable:
Code: Select all
Package: *
Pin: release a=unstable
Pin-Priority: 150
From the Gates of Hell
User avatar
XeroXer
Level 1
Level 1
 
Posts: 24
Joined: Sat Feb 20, 2010 4:54 am
Location: Västerås, Sweden

Linux Mint is funded by ads and donations.
 

Re: Broken after upgrade: mintmenu, gnome-screensaver & xmod

Postby richyrich on Thu Apr 21, 2011 3:47 pm

Stable, Squeeze, Testing, Unstable, Sid, Experimental . . .


Not LMDE anymore is it ?

I'll try a few guesses;
. . a dependent library file from Sid overwrote the needed Testing version? and it didn't notify or warn you ! :shock:
. . that needed stuff from Unstable stopped working after some updates, updates that were intended for the Testing version? or was that the Squeeze version?

apologies for the sarcasm . . :P

good luck to you just the same, and let us know if you find a solution . .

richy
User avatar
richyrich
Level 13
Level 13
 
Posts: 4777
Joined: Mon May 04, 2009 8:31 pm
Location: Pirating somewhere along the North Saskatchewan River, Canada

Re: Broken after upgrade: mintmenu, gnome-screensaver & xmod

Postby XeroXer on Wed Apr 27, 2011 5:48 am

richyrich wrote:
Stable, Squeeze, Testing, Unstable, Sid, Experimental . . .


Not LMDE anymore is it ?

I'll try a few guesses;
. . a dependent library file from Sid overwrote the needed Testing version? and it didn't notify or warn you ! :shock:
. . that needed stuff from Unstable stopped working after some updates, updates that were intended for the Testing version? or was that the Squeeze version?

apologies for the sarcasm . . :P

good luck to you just the same, and let us know if you find a solution . .

richy


I only have the experimental, sid and unstable for a very small selection of applications that I want.
From the sid I only have wine and wine-gecko-1.0.0.
From unstable I have chromium, chromium-browser, chromium-browser-l10n, chromium-inspector and chromium-l10n.

From experimental I have nvidia-xconfig and some gcj libraries, maybe that could be causing the problems.
I will have to look into that and see if that might be causing some errors, but something from sid or unstable does not seem to be the case.
Thanks for the suggestion.
From the Gates of Hell
User avatar
XeroXer
Level 1
Level 1
 
Posts: 24
Joined: Sat Feb 20, 2010 4:54 am
Location: Västerås, Sweden

Re: Broken after upgrade: mintmenu, gnome-screensaver & xmod

Postby richyrich on Sat May 07, 2011 9:52 am

Here's a great resource (by one of our members) for Mint's Debian editions :

https://sites.google.com/site/mydebiansourceslist/
User avatar
richyrich
Level 13
Level 13
 
Posts: 4777
Joined: Mon May 04, 2009 8:31 pm
Location: Pirating somewhere along the North Saskatchewan River, Canada

Re: Broken after upgrade: mintmenu, gnome-screensaver & xmod

Postby Telecaster72 on Sat May 07, 2011 10:49 pm

richyrich wrote:Here's a great resource (by one of our members) for Mint's Debian editions :

https://sites.google.com/site/mydebiansourceslist/



:shock: :shock: :shock:

Wow, this list will be my downfall from stability, thank you very much ;)


Seriously, this is great stuff, if handled properly.
Telecaster72
Level 1
Level 1
 
Posts: 37
Joined: Fri Nov 30, 2007 10:59 am

Re: Broken after upgrade: mintmenu, gnome-screensaver & xmod

Postby richyrich on Sat May 07, 2011 11:01 pm

@Telecaster72 . . please note this at the end of the official repositories . . please take this seriously :
Disclaimer: This is experimental software. Use at your own risk.
As with ANY software you download from a public server, you should be extremely careful with what you install.
craigevil cannot be held liable under any circumstances for damage to hardware or software, lost data, or other direct or indirect damage resulting from the use of this list. Packages may not be compatible with official Debian packages or may even be severely broken and cause damage to your system!
You have been warned.


I have not ever had any problems with the proper use of these repositories, please research and do your homework beforehand !
User avatar
richyrich
Level 13
Level 13
 
Posts: 4777
Joined: Mon May 04, 2009 8:31 pm
Location: Pirating somewhere along the North Saskatchewan River, Canada


Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 3 guests