LMDE 32/64 samba breakage after update [solved]

Post your update and upgrade related errors here
Forum rules
Before you post please read this

LMDE 32/64 samba breakage after update [solved]

Postby colossus75 on Wed Apr 20, 2011 8:19 pm

Hello,

Was wondering if anyone else ran into this. During the last batch or 2 of updates..my samba networking broke.

I do have a clonezilla image from 2 weeks ago. I normally create a new image prior to installing new updates...just in case. I can fall back to it if I need to. Tho, I'd get hit with over 200 or so updates. Under synaptic, most of the updates are priority 3, is it okay to leave some of them behind..or is it better practice to upgrade what shows up? I had an issue with gstreamer and xorg-common from a few updates back..so I have been holding off on those.

Except now..since my LMDE 32/64 box is my file-sharing/print server/2nd workstation. The samba related side, file/print sharing..has been knocked out within the last round or so of updates. My mint helena run laptop can no longer access the network printer and the samba share I had. I actually get stuck at the login. I double checked the samba user I had set up and saved a fresh samba password..to no avail. Still can not access.

From my Windows XP machine, I can see the LMDE box on the windows workgroup..but when I try to click on it or access it, windows comes back telling me that I don't have admin rights.

Any thoughts on this appreciated. Thanks.

07-20-2011 Update :
well after getting my ibm laptop up to speed running Mint Isadora 32bit LTS, and setting the printer up as windows shared printer from isadora to my LMDE box, everything seems to be working again, the printer and the shared directory. Thanks for those who replied.
Last edited by colossus75 on Wed Jul 20, 2011 7:38 pm, edited 1 time in total.
Gigabyte GA-M78SM-S2H
AMD Athlon 64 x2 5000 2.6GHz
4GB OCZ DDR2 800Mhz
500GB Seagate SATA 3.5" 7200.11 [OS/data]
400GB x2 1st (main data drive xfs) 2nd(rsync'd data drive xfs)
400GB (virtual machine drive xfs)
OS : Mint Lisa/Maya/Qiana 64bit
User avatar
colossus75
Level 1
Level 1
 
Posts: 42
Joined: Tue Jun 09, 2009 12:59 pm

Linux Mint is funded by ads and donations.
 

Re: LMDE 32/64 samba breakage after update

Postby altair4 on Thu Apr 21, 2011 7:30 am

First make sure these services have started in this exact order and see if you can connect:
Code: Select all
sudo service cups restart
sudo service samba restart


Second, run this diagnostic to see if there are any errors:
Code: Select all
smbtree
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 16
Level 16
 
Posts: 6055
Joined: Tue Feb 03, 2009 10:27 am

Re: LMDE 32/64 samba breakage after update

Postby colossus75 on Thu Jun 02, 2011 3:13 pm

altair4 wrote:First make sure these services have started in this exact order and see if you can connect:
Code: Select all
sudo service cups restart
sudo service samba restart


Second, run this diagnostic to see if there are any errors:
Code: Select all
smbtree


It did not reveal any errors.

Since Mint Helena expired and I am now on Mint Isadora 32bit on my laptop. I did notice when trying to add the printer (Samsung ML-1210), when it auto-finds it..and adds..it as dnssd rather than samba. any thoughts on that?
Last edited by colossus75 on Thu Jun 02, 2011 6:46 pm, edited 1 time in total.
Gigabyte GA-M78SM-S2H
AMD Athlon 64 x2 5000 2.6GHz
4GB OCZ DDR2 800Mhz
500GB Seagate SATA 3.5" 7200.11 [OS/data]
400GB x2 1st (main data drive xfs) 2nd(rsync'd data drive xfs)
400GB (virtual machine drive xfs)
OS : Mint Lisa/Maya/Qiana 64bit
User avatar
colossus75
Level 1
Level 1
 
Posts: 42
Joined: Tue Jun 09, 2009 12:59 pm

Re: LMDE 32/64 samba breakage after update

Postby altair4 on Thu Jun 02, 2011 4:03 pm

Do you mean dnssd? That's avahi which is rather curious.

You didn't install Samb4 on that box by any chance, did you?

I haven't noticed any changes from the updates - well not with Samba anyway.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 16
Level 16
 
Posts: 6055
Joined: Tue Feb 03, 2009 10:27 am

Re: LMDE 32/64 samba breakage after update

Postby colossus75 on Thu Jun 02, 2011 6:45 pm

altair4 wrote:Do you mean dnssd? That's avahi which is rather curious.

You didn't install Samb4 on that box by any chance, did you?

I haven't noticed any changes from the updates - well not with Samba anyway.


Yes, dnssd is correct, that's what shows when trying to auto-add the printer when I am on 32bit Isadora.

I don't believe I installed Samb4 on my LMDE 32bit or 64 bit.
Gigabyte GA-M78SM-S2H
AMD Athlon 64 x2 5000 2.6GHz
4GB OCZ DDR2 800Mhz
500GB Seagate SATA 3.5" 7200.11 [OS/data]
400GB x2 1st (main data drive xfs) 2nd(rsync'd data drive xfs)
400GB (virtual machine drive xfs)
OS : Mint Lisa/Maya/Qiana 64bit
User avatar
colossus75
Level 1
Level 1
 
Posts: 42
Joined: Tue Jun 09, 2009 12:59 pm

Re: LMDE 32/64 samba breakage after update

Postby asermax on Mon Jun 27, 2011 9:36 pm

I have a similar problem with my LMDE, some time ago the samba server started acting oddly.
The only way i could find to make the network function so other PC's can access to my printer, is restarting samba through "sudo /etc/init.d/samba restart"; it's a bother to do it everytime someone needs to use the printer, but oh well, i got used to it. Anyway, hope someone finds how to solve this issue u_u
asermax
Level 1
Level 1
 
Posts: 14
Joined: Mon Jun 27, 2011 9:31 pm
Location: Córdoba, Argentina


Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 1 guest