Mintupdate error (solved)

Post your update and upgrade related errors here
Forum rules
Before you post please read this

Mintupdate error (solved)

Postby inp3dance on Thu Apr 28, 2011 4:28 pm

Hi,

I'm a new LMDE user, I just installed it today. And the first thing I do with every live install is to remove unneeded packages and after that, update the system, as I did with LMDE today.
But I can't update my system because mintupdate gives me the following error: "Could not apply changes! Fix broken packages first."

Now I don't think I have any broken packages because apt-get install -f returns no error, and I could update my system with apt-get upgrade, but I don't know if it is safe or not ( as I sad, this is the first time when I use Linux Mint )

If I try to just update mintupdate, apt pulls in a lot of packages, almost all the upgradeable ones.

Here is a list of the packages I removed:
    at-spi
    gnome-user-guide
    libbrlapi0.5
    liblouis-data
    python-brlapi
    python-pyatspi
    aptitude-doc-en
    atmel-firmware
    bogofilter
    bogofilter-bdb
    bogofilter-common
    brasero
    brasero-common
    eog
    espeak
    espeak-data
    exim4-config
    f-spot
    firmware-atheros
    firmware-bnx2
    firmware-bnx2x
    firmware-intelwimax
    firmware-ipw2x00
    firmware-ivtv
    firmware-qlogic
    firmware-ralink
    firmware-realtek
    fortunes-min
    libertas-firmware
    mousetweaks
    procmail
    rhythmbox
    thunderbird
    thunderbird-l10n-en-us
    ttf-sazanami-gothic
    ttf-sazanami-mincho
    ttf-wqy-microhei
    vim-common
    vim-tiny
    vino
    zd1211-firmware
    gnome-core
    libbrasero-media0
    libespeak1
    libgnome-speech7
    rhythmbox-plugins
    gwibber

So I'd like some help in two questions:
1. Did I break mintupdate ? And if I did so, how can I fix it?
2. Can I update my system with apt-get or synaptic, or the safe way is with mintupdate?
Last edited by rich_roast on Sat Apr 30, 2011 7:18 am, edited 1 time in total.
Reason: If you're happy and your problem's been solved, please edit your original post and add (solved) to the end of the subject line. Thanks!
inp3dance
Level 1
Level 1
 
Posts: 21
Joined: Thu Apr 28, 2011 4:10 pm

Linux Mint is funded by ads and donations.
 

Re: Mintupdate error

Postby MaddogF16 on Thu Apr 28, 2011 4:52 pm

I did the first part of my upgrade to fresh installs just a week ago and had to use apt for the first round and after that the updater works fine.
MaddogF16
Level 5
Level 5
 
Posts: 762
Joined: Tue Jun 16, 2009 10:47 am

Re: Mintupdate error

Postby ukbrian on Thu Apr 28, 2011 7:20 pm

Broken packages are fixed by doing the Mint updates first, they're all at the top and then rebooting or log off/on before installing the others and I would humbly suggest you stick to levels 1-3 only unless you have hardware problems as you will have a much better experience using the stable default or vanilla LMDE.
User avatar
ukbrian
Level 4
Level 4
 
Posts: 276
Joined: Thu Jul 29, 2010 6:03 am
Location: Cheltenham, UK

Re: Mintupdate error

Postby aljoriz on Thu Apr 28, 2011 7:44 pm

MaddogF16 wrote:I did the first part of my upgrade to fresh installs just a week ago and had to use apt for the first round and after that the updater works fine.


did the same too most the breakages like the busted mint fortunes, the mark all upgrades in synaptic were fixed quickly .. man, I love this community!
aljoriz
Level 4
Level 4
 
Posts: 269
Joined: Wed Dec 23, 2009 12:50 pm
Location: Cebu City, Philippines

Re: Mintupdate error

Postby inp3dance on Fri Apr 29, 2011 3:29 pm

Thank you, I did an update with apt which fixed the issue. Mint Debian is great!
inp3dance
Level 1
Level 1
 
Posts: 21
Joined: Thu Apr 28, 2011 4:10 pm


Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 1 guest

cron