apt-get dist-upgrade gone wrong

Post your update and upgrade related errors here
Forum rules
Before you post please read this

apt-get dist-upgrade gone wrong

Postby phollox on Thu Jun 30, 2011 6:30 pm

In the last couple of weeks, I ran the command
Code: Select all
sudo apt-get update
sudo apt-get dist-upgrade

twice on my LMDE installation. In the past, it worked without problems, upgrading my kernel to the 2.6.38 version. I ran this command because I read an interview with clem in which he recommends this update method.

Anyway, the first time it worked fine. The 2nd, another kernel update, to the 2.6.39-2-pae version. The PAE (Physical Address Extension) is actually not important for me, because I'm running on a netbook. But the update didn't install the headers associated to this kernel, and gave a warning about possible unsupported devices and drivers. I manually install the headers, but the USB controllers end up with some problems, being unable to recognize my digital camera when I plug it through the USB cable, or recognize the SD memory when I insert it into the SD reader slot. These features were working fine in the previous kernel. The good thing is that I got Firefox 4.

I run the dist-upgrade today, with the hope that it will install missing files so I can plug my camera again. However, it just install updates to gcc, CUPS, imagemagick and the gnome-terminal. Now, I am receiving this message every time I open a terminal
Code: Select all
*** VTE ***: Failed to load terminal capabilities from '/etc/termcap'

and my terminal does not work anymore. It opens, show the error message, then the "fortune | cowsay" output, and then the prompt. I can type, but I cannot press ENTER, so it does not do anything

I think I will try a more stable linux. Maybe the regular Mint instead of the LMDE, or maybe Fedora 15. But in the meanwhile, I need my terminal. Any advices? Everything else seems to work, and I have an old instance of the terminal opened previous to the update that still works

Thanks
"...and God said:
Code: Select all
sudo su

and then there was light..."
Image
Gateway LT27. Intel Atom N450, 1GB RAM
LMDE. Kernel: 2.6.38-2-686
User avatar
phollox
Level 1
Level 1
 
Posts: 19
Joined: Mon Nov 01, 2010 12:37 pm

Linux Mint is funded by ads and donations.
 

Re: apt-get dist-upgrade gone wrong

Postby BTUx9 on Sun Jul 10, 2011 4:04 am

2 workarounds and 1 solution: (you may need a workaround to apply the solution)

-- without termcap loaded, ^m works even though enter doesn't
-- it appears that my issue (and probably yours) is due to the fact that my quick link for terminal (next to the menu button) is linking to an old version of gnome terminal (2.30.2). If you use nautilus to start the terminal (right-click a directory), or start it from the menu entry, you should be running v3.x, and that version knows the new location of termcap

A solution that will allow both 2.x and 3.x versions find termcap is to delete /usr/share/vte/termcap and make it a symlink to /usr/share/vte/termcap-0.0
BTUx9
Level 1
Level 1
 
Posts: 2
Joined: Sun Jul 10, 2011 3:42 am


Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 1 guest