package breakage in aptitude but not apt-get

Post your update and upgrade related errors here
Forum rules
Before you post please read how to get help

package breakage in aptitude but not apt-get

Postby TomRoche on Sun Aug 21, 2011 12:53 pm

summary: I prefer to use `aptitude` for package management. I have a very new LMDE install (details in this thread) that appears functionally OK. However

Code: Select all
me@it:~$ sudo apt-get check | wc -l
> 3
me@it:~$ sudo apt-get check
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
me@it:~$ aptitude search ?broken
> iB  acl             - Access control list utilities
> iB  coreutils       - GNU core utilities
> iB  cups            - Common UNIX Printing System(tm) - server
> iB  libacl1-dev     - Access control list static libraries and headers
> iB  libarchive1     - Single library to read/write tar, cpio, pax, zip, iso9660, etc.
> iB  libgnomevfs2-0  - GNOME Virtual File System (runtime libraries)
> iB  libisofs6       - library to create ISO9660 images
> iB  ntfs-3g         - read-write NTFS driver for FUSE
> iB  rsync           - fast remote file copy program (like rcp)
> iB  samba           - SMB/CIFS file, print, and login server for Unix

How to fix?


I prefer to use `aptitude` (esp the CLI) for daily package management, having used that for a few years without problems on several ubuntu boxes. However the `aptitude` on my new LMDE box appears (to me--ICBW) to be not working properly, based on the following 3 facts:

F1) My LMDE box is not broken functionally (aside from audio, which I'm assuming is unrelated to the above): only some packages are, and only in aptitude (more on that below). Specifically, none of the functionality that I would expect to be broken from the above appears to be broken. Not that I've done exhaustive testing, but certainly all the coreutils that I've used appear to work.

F2) My `apt-get` shows no breakage, but my `aptitude` does. See summary: am I interpreting that correctly?

F3) While setting up this box, I first used `apt-get` then `aptitude`. FWIW I've been doing this since I started using Ubuntu (few years/ releases), based on my RTFM

Code: Select all
> The apt-get and apt-cache commands are the most basic package management tool.


> * apt-get is most suitable for the major system upgrade between releases, etc.


> The aptitude command is the most versatile package management tool.

> * aptitude offers the fullscreen interactive text user interface.

> * aptitude offers the commandline user interface, too.

> * aptitude is most suitable for the daily interactive package
>   management such as inspecting installed packages and searching
>   available packages.

So I did for the LMDE install what I usually do with ubuntu installs:

  • Immediately before install, copy my sources.list and sources.list.d/ to some ${PACKAGE_BACKUP_DIR}, and `dpkg --get-selections > ${PACKAGE_BACKUP_FILE}` (in that dir).
  • Immediately after install, use apt-get for the initial `update` and `dist-upgrade`.
  • Try to restore my previous packages with (while sudo)
    Code: Select all
    dpkg --set-selections < ${PACKAGE_BACKUP_FILE}
    apt-get install -y dselect
    dselect update
    apt-get dselect-upgrade

    After that's cleaned up,
  • `aptitude update`
  • Until the next upgrade (using LMDE, I'm hoping will be awhile :-) "for the daily interactive package management," I use aptitude.

This approach has worked well for me ... until, I suspect, now. From those 3 facts, I'm drawing 2 conclusions:

C1) My `aptitude` db is corrupt, while my `apt-get` db is not. This seems pretty clear from F2, no?

C2) This was caused by my using `aptitude` and `apt-get` "together." I'm less sure of this conclusion, since I've used the approach detailed in F3 several times without difficulty. However, I've read in several places (including this post and this thread) that one should not use `aptitude` and `apt-get` together.

Am I missing something? If not, my main question is,

Q1) How to fix my `aptitude`? Because I still prefer to use it for daily interactive package management.

My initial impulse was

Q2) Can I fix it by purging and re-installing `aptitude`? I'm guessing that would remove its currently-bad database and re-generate it. Am I missing something?

Presuming Q2 is correct (and feel free to deny that, and to propose better alternatives), and presuming one doesn't want to try that with `aptitude` itself, I tried

Code: Select all
me@it:~$ sudo apt-get -s purge aptitude
> The following packages will be REMOVED:
>   aptitude* mintsystem* tasksel* tasksel-data* wajig*
> 0 upgraded, 0 newly installed, 5 to remove and 1 not upgraded.
> Purg wajig [2.2]
> Purg tasksel [2.89] [tasksel-data:amd64 ]
> Purg tasksel-data [2.89]
> Purg mintsystem [7.7.9]
> Purg aptitude [0.6.3-4]
me@it:~$ aptitude -F "%p" search "?depends(aptitude)"
> aptitude-dbg
> aptitude-gtk
> mintsystem
> pkgsync
> tasksel
> wajig

raises a third question:

Q3) How to purge and re-install only `aptitude`?
Level 3
Level 3
Posts: 199
Joined: Thu Jan 13, 2011 2:52 pm

Linux Mint is funded by ads and donations.

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 8 guests