Firefox no longer starts after using mintupdate-debian

Post your update and upgrade related errors here
Forum rules
Before you post please read this

Firefox no longer starts after using mintupdate-debian

Postby ausmuso on Sun Sep 04, 2011 1:45 am

I am running LMDE with its software repositories set to "squeeze".
Firefox ran well after installation. Having done a few updates with mintupdate-debian Firefox suddenly won't start anymore. I get an error message:
Code: Select all
/opt/firefox/firefox-bin: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /opt/firefox/libxul.so)


I have exactly the same problem with another machine which also runs LMDE but with software repositories set to "testing"
I can't find glibcXX_3. . . . . in any repository.

I miss firefox. Iceweasel often runs OK but sometimes it freezes. Epiphany works OK but it's not as versatile as Firefox. What can I do to get Firefox going again?
With Linux from 1997 (Slackware, Caldera, Red Hat, Mandrake, (Open)SuSE, Poppy, Ubuntu, CentOS) currently Mint LMDE & 13 Cinnamon w. LXDE desktops
Image
User avatar
ausmuso
Level 2
Level 2
 
Posts: 56
Joined: Sun May 15, 2011 2:08 am
Location: Blue Mountains, NSW, Australia

Linux Mint is funded by ads and donations.
 

Re: Firefox no longer starts after using mintupdate-debian

Postby zerozero on Sun Sep 04, 2011 5:49 am

as for the problem with firefox in your lmde-stable box, is a well-known problem
viewtopic.php?f=141&t=79665&p=462720&hilit=firefox#p462720
viewtopic.php?f=141&p=439502

in the other box, pointing to testing, that error should appear, are you sure the system is fully updated? when did you ran dist-upgrade there last time?
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6485
Joined: Tue Jul 07, 2009 2:29 pm

Re: Firefox no longer starts after using mintupdate-debian

Postby ausmuso on Sun Sep 04, 2011 6:33 pm

zerozero wrote:as for the problem with firefox in your lmde-stable box, is a well-known problem
viewtopic.php?f=141&t=79665&p=462720&hilit=firefox#p462720
viewtopic.php?f=141&p=439502

in the other box, pointing to testing, that error should appear, are you sure the system is fully updated? when did you ran dist-upgrade there last time?



Thanks, Zerozero! I'll complete the system update on the "testing" box.
Cheers
With Linux from 1997 (Slackware, Caldera, Red Hat, Mandrake, (Open)SuSE, Poppy, Ubuntu, CentOS) currently Mint LMDE & 13 Cinnamon w. LXDE desktops
Image
User avatar
ausmuso
Level 2
Level 2
 
Posts: 56
Joined: Sun May 15, 2011 2:08 am
Location: Blue Mountains, NSW, Australia

Re: Firefox no longer starts after using mintupdate-debian

Postby zerozero on Sun Sep 04, 2011 7:37 pm

well :oops: i'm glad you could understand what i was trying to say, even with a mistake like this:
in the other box, pointing to testing, that error should appear

should be
in the other box, pointing to testing, that error shouldn't appear
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6485
Joined: Tue Jul 07, 2009 2:29 pm


Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 4 guests