(SOLVED) Update not completed - errors...

Post your update and upgrade related errors here
Forum rules
Before you post please read this

(SOLVED) Update not completed - errors...

Postby tenfoot on Tue Sep 13, 2011 10:18 pm

LMDE

Icon indicated updates available. Got to Install Updates, then box appeared:

Code: Select all
Additional changes
libgraphic2-2.0.0
libnetfilter-conntrack3


Clicked O.K.

Error box

Code: Select all
Update is complete

Not all changes and updates succeeded.  For further details of the failure, please expand the 'Details' panel below


Details gave:

Code: Select all
/usr/share/themes/Shiki-Wise/gtk-2.0/gtkrc:126: Murrine configuration option "gradients" is no longer supported and will be ignored.
/usr/share/themes/Shiki-Wise/gtk-2.0/gtkrc:126: Murrine configuration option "gradients" is no longer supported and will be ignored.
Extracting templates from packages: 100%
Preconfiguring packages ...
dpkg: warning: 'ldconfig' not found in PATH or not executable.
dpkg: warning: 'start-stop-daemon' not found in PATH or not executable.
dpkg: error: 2 expected programs not found in PATH or not executable.
Note: root's PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin.
E: Sub-process /usr/bin/dpkg returned an error code (2)
A package failed to install.  Trying to recover:
dpkg: warning: 'ldconfig' not found in PATH or not executable.
dpkg: warning: 'start-stop-daemon' not found in PATH or not executable.
dpkg: error: 2 expected programs not found in PATH or not executable.
Note: root's PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin.


Once again, help is requested, please?
Last edited by tenfoot on Thu Sep 15, 2011 4:00 pm, edited 1 time in total.
User avatar
tenfoot
Level 5
Level 5
 
Posts: 571
Joined: Sun Jun 03, 2007 4:12 am
Location: Waipapa, Bay of Islands, New Zealand

Linux Mint is funded by ads and donations.
 

Re: Update not completed - errors...

Postby tdockery97 on Tue Sep 13, 2011 11:21 pm

If you haven't tried already, run in terminal:
Code: Select all
sudo dpkg --configure -a

Then try your update again.
Image

HP Pavilion 17 Notebook, 8GB DDR3, 2.5GHZ A10-APU, Radeon HD 8650G
Registered Linux User #520972
User avatar
tdockery97
Level 13
Level 13
 
Posts: 4847
Joined: Sun Jan 10, 2010 8:54 am
Location: Salem, Oregon

Re: Update not completed - errors...

Postby zerozero on Wed Sep 14, 2011 1:19 pm

zerozero
Level 16
Level 16
 
Posts: 6467
Joined: Tue Jul 07, 2009 2:29 pm

Re: Update not completed - errors...

Postby tenfoot on Wed Sep 14, 2011 5:26 pm

tdockery97 wrote:If you haven't tried already, run in terminal:
Code: Select all
sudo dpkg --configure -a

Then try your update again.


That gave me:

Code: Select all
zed@systemproductname-desktop ~ $ sudo dpkg --configure -a
[sudo] password for zed:
dpkg: warning: 'ldconfig' not found in PATH or not executable.
dpkg: warning: 'start-stop-daemon' not found in PATH or not executable.
dpkg: error: 2 expected programs not found in PATH or not executable.
Note: root's PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin.
zed@systemproductname-desktop ~ $


Then I read your second post and my heart sank to my boots :(
User avatar
tenfoot
Level 5
Level 5
 
Posts: 571
Joined: Sun Jun 03, 2007 4:12 am
Location: Waipapa, Bay of Islands, New Zealand

Re: Update not completed - errors...

Postby tenfoot on Wed Sep 14, 2011 5:30 pm

zerozero wrote:tenfoot your sudo is broken


Will plough through those messages and try to fathom out what I should do but this "ancient bear of little brain" is not altogether confident that he is capable of resolving the issue :(
User avatar
tenfoot
Level 5
Level 5
 
Posts: 571
Joined: Sun Jun 03, 2007 4:12 am
Location: Waipapa, Bay of Islands, New Zealand

Re: Update not completed - errors...

Postby kaptainkarl on Wed Sep 14, 2011 11:37 pm

A workaround for this problem if you're still having trouble is to run anything that needs superuser privileges with "sudo -i" instead of just "sudo". So you can run (either from a terminal or from the 'alt-f2' run-command dialog) 'sudo -i mintupdate' and the update program will be able to install without freaking out. Or you can run su'd as root instead of using sudo. I haven't tried it, but adding /sbin and /usr/sbin to your path before sudo'ing might also work...
kaptainkarl
Level 1
Level 1
 
Posts: 1
Joined: Wed May 04, 2011 9:29 pm

Re: Update not completed - errors...

Postby Gerd50 on Thu Sep 15, 2011 5:01 am

I fixed it this way:

Code: Select all
gksu gedit etc/sudoers

in sudoers is a line

Code: Select all
Defaults   env_reset

under this line i added the new line

Code: Select all
Defaults secure_path="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin"
I believe in everything, except humans.

LM9, Debian Testing Xfce, Debian Sid Xfce - CPU/Amd64 2,6Ghz, Graphics/Nvidia 9600 GT, Sound/SB Audigy4 emu10K1
User avatar
Gerd50
Level 5
Level 5
 
Posts: 738
Joined: Wed Jul 22, 2009 3:42 pm
Location: Fishtown, Germany

Re: Update not completed - errors...

Postby tenfoot on Thu Sep 15, 2011 3:59 pm

Thank you Gerd50 Your fix also fixed my problem and i am now up-to date with upgrades.
User avatar
tenfoot
Level 5
Level 5
 
Posts: 571
Joined: Sun Jun 03, 2007 4:12 am
Location: Waipapa, Bay of Islands, New Zealand

Re: (SOLVED) Update not completed - errors...

Postby Jorox on Fri Nov 04, 2011 12:51 pm

I am a newbie to the Linux enviroment.
But I must say the Mint disrtribution is proving to be a lovely way to start my way.
Eventhough I've faced alot of problems at first, the community here is excellent.

This is my first post, and I hope it wont be my last.
Thank you for posting this fix, it sure brightened my day after a long depression.

:D
Jorox
Level 1
Level 1
 
Posts: 1
Joined: Fri Nov 04, 2011 12:46 pm

Linux Mint is funded by ads and donations.
 

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: bithir and 8 guests