Update Error/Unmet dependencies/held packages

Post your update and upgrade related errors here
Forum rules
Before you post please read how to get help

Update Error/Unmet dependencies/held packages

Postby Sorceror on Sat Sep 17, 2011 7:16 pm

I'm currently trying to update my 201104 32 bit installation to bring it up to date as my 201108 installation dies not long after it starts. I've tried a number of versions of Mint and April's is the only one that would actually install on my laptop so this is my only option.
After having problems with the update manager, I tried using the terminal to run 'sudo apt-get update && sudo apt-get upgrade && sudo apt-get distro-upgrade' and I got a failure followed by
The following packages have unmet dependencies:
libasound2 : Breaks: libasound2-plugins (< 1.0.24) but 1.0.23-1+b1 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Is there anyway past this to finish upgrading?
Sorceror
Level 1
Level 1
 
Posts: 28
Joined: Sun Aug 28, 2011 5:56 am

Linux Mint is funded by ads and donations.
 

Re: Update Error/Unmet dependencies/held packages

Postby proxima_centauri on Sat Sep 17, 2011 7:28 pm

* Moved to LMDE (Linux Mint Debian) subforum from xfce subforum

I would recommended reading this thread over -> viewtopic.php?f=141&t=79533
Double checking what repositories you are using may help isolate the problem.
User avatar
proxima_centauri
Level 11
Level 11
 
Posts: 3976
Joined: Tue Dec 25, 2007 3:24 pm
Location: NB, Canada


Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 2 guests