Error Updating Grub

Post your update and upgrade related errors here
Forum rules
Before you post please read how to get help

Error Updating Grub

Postby yarcsi on Wed Sep 21, 2011 2:26 pm

Hi. I recently got an error in apt-get updating grub.
Code: Select all
Setting up grub-pc (1.99-12) ...
grub-mkdevicemap: error: cannot open /boot/grub/device.map.
dpkg: error processing grub-pc (--configure):
 subprocess installed post-installation script returned error exit status 1


Grub still works so I'm not terribly worried about but it's an agrivating error. I update Mint Debian roughly weekly and this hit me yesterday, Tuesday, Sept 20th. device.map is there and contains only one device by id and I only have one disk:

Code: Select all
(hd0)   /dev/disk/by-id/ata-ST9160310AS_5SV4V23V


I have an old Asus EeePC 1000HE with an atom, but I'm not sure which one. lspci:

Code: Select all
00:00.0 Host bridge: Intel Corporation Mobile 945GME Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 2 (rev 02)
00:1c.3 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 4 (rev 02)
00:1d.0 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE Controller (rev 02)
01:00.0 Network controller: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) (rev 01)
03:00.0 Ethernet controller: Atheros Communications AR8121/AR8113/AR8114 Gigabit or Fast Ethernet (rev b0)


Everything else still works and updates, but I always get this error now. Not a linux guru, but I have cursory knowledge of linux.

Thanks,
Michael
yarcsi
Level 1
Level 1
 
Posts: 1
Joined: Wed Sep 21, 2011 2:06 pm

Linux Mint is funded by ads and donations.
 

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 5 guests