Update Pack 3 not in use

Post your update and upgrade related errors here
Forum rules
Before you post please read this

Update Pack 3 not in use

Postby nobby on Thu Sep 29, 2011 5:49 am

I changed my sources list per the update pack 3 blog post and updated my system using update manager. However, update manager now reports that the current available pack is 3, but the latest pack used by my system is 2. I've restarted update manager & rebooted my computer but it keeps reporting same thing. There are no other updates available to install. Am I missing something?

Prior to this I was running the 201108-RC version with no updates applied since the install.

Also I can't boot using kernel 3, just get a black screen with blinking cursor, but I suspect this is graphics card related.
nobby
Level 1
Level 1
 
Posts: 4
Joined: Fri Jul 08, 2011 5:57 pm

Linux Mint is funded by ads and donations.
 

Re: Update Pack 3 not in use

Postby zerozero on Thu Sep 29, 2011 6:50 am

just a wild guess, but i would say that not all the updates were installed;
try with
Code: Select all
sudo apt-get update && sudo apt-get dist-upgrade
and see if you have more updates pending.
zerozero
Level 16
Level 16
 
Posts: 6472
Joined: Tue Jul 07, 2009 2:29 pm

Re: Update Pack 3 not in use

Postby ausminter on Thu Sep 29, 2011 7:12 am

It sounds like the new kernel is installed so I'd say the updates have been carried out.
What happens during the boot process for the new kernel, does it load anything or just go straight to blinking cursor ?

edited to remove misinformation
User avatar
ausminter
Level 2
Level 2
 
Posts: 50
Joined: Mon Sep 26, 2011 2:04 am

Re: Update Pack 3 not in use

Postby nobby on Thu Sep 29, 2011 3:09 pm

Running apt-get update & dist-upgrade gives me the following:

The following packages have been kept back:
foomatic-db-engine
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

As someone else has pointed out in another recent post, trying to install that foomatic results in some other packages being removed, namely: cups, cups-driver-gutenprint, cups-pdf, mint-meta-common, mint-meta-debian. So I didn't think it was a good idea to forge ahead with that.

Funny thing is, prior to updating, update manager never reported that update pack 3 was available. This was after I had updated mintupdate to 1.04 and done several apt refreshes (& reboot). After I updated the 440 odd packages, update manager still didn't report pack 3 has being available. It was only after I left update manager open for a while did it start saying pack 3 was available (but not in use)

As for kernel 3, things happen during boot, as in lots of text going down the screen, and then it goes to the blinking cursor. Attached is my kern log if that gives any clues. Actually I can't seem to attach it, so below is last few lines:

Code: Select all
VIA 82xx Modem 0000:00:11.6: PCI INT C -> Link[ALKC] -> GSI 22 (level, low) -> IRQ 22
VIA 82xx Modem 0000:00:11.6: setting latency timer to 64
VIA 82xx Modem 0000:00:11.6: PCI INT C disabled
VIA 82xx Modem: probe of 0000:00:11.6 failed with error -13
VIA 82xx Audio 0000:00:11.5: PCI INT C -> Link[ALKC] -> GSI 22 (level, low) -> IRQ 22
VIA 82xx Audio 0000:00:11.5: setting latency timer to 64
Adding 2093052k swap on /dev/sdb8.  Priority:-1 extents:1 across:2093052k
EXT4-fs (sdb5): warning: maximal mount count reached, running e2fsck is recommended
EXT4-fs (sdb5): re-mounted. Opts: errors=remount-ro
device-mapper: uevent: version 1.0.3
device-mapper: ioctl: 4.20.0-ioctl (2011-02-02) initialised: dm-devel@redhat.com
loop: module loaded
w83627hf: w83627hf: Found W83697HF chip at 0x290
EXT4-fs (sdb2): warning: maximal mount count reached, running e2fsck is recommended
EXT4-fs (sdb2): mounted filesystem with ordered data mode. Opts: errors=remount-ro
EXT4-fs (sda7): warning: maximal mount count reached, running e2fsck is recommended
EXT4-fs (sda7): mounted filesystem with ordered data mode. Opts: errors=remount-ro
fuse init (API version 7.16)
via-rhine 0000:00:12.0: eth1: link up, 100Mbps, full-duplex, lpa 0x45E1
lp0: using parport0 (interrupt-driven).
ppdev: user-space parallel port driver
eth1: no IPv6 routers present
fuse exit
Kernel logging (proc) stopped.
nobby
Level 1
Level 1
 
Posts: 4
Joined: Fri Jul 08, 2011 5:57 pm

Re: Update Pack 3 not in use

Postby nobby on Fri Sep 30, 2011 6:44 pm

I'm able to boot into kernel 3 now. I installed nvidia drivers following this post http://forums.linuxmint.com/viewtopic.php?f=191&t=82424, but substituting 96xx versions instead as I have an old graphics card. I had run sgfxi after the initial update but I guess there's some incompatibility at the moment.

However, mint update still reports that update pack 3 is available but not in use.
Screenshot-Update Pack Info - Update Manager.png
Screenshot-Update Pack Info - Update Manager.png (55.6 KiB) Viewed 610 times
nobby
Level 1
Level 1
 
Posts: 4
Joined: Fri Jul 08, 2011 5:57 pm


Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 4 guests