Cant update to update pack 3 because of gstreamer problem

Post your update and upgrade related errors here
Forum rules
Before you post please read this

Cant update to update pack 3 because of gstreamer problem

Postby Endogen on Sat Oct 01, 2011 7:54 pm

Hi all,

I installed Linux Mint Debian 201109 with GNOME and after the installation, i updated mintUpdate, changed the sources.list (like stated in the blog post - works fine) and then saw 419 updates (which is update pack 3 i guess). Then i tried to install the updates and got this error message:
Code: Select all
E: /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_amd64.deb: Versuch, »/usr/lib/gstreamer-0.10/libgstxvid.so« zu überschreiben, welches auch in Paket gstreamer0.10-plugins-really-bad 0.10.22-0.1 ist


It's in german and says that gstreamer0.10-plugins-bad_0.10.22-3_amd64.deb tries to override /usr/lib/gstreamer-0.10/libgstxvid.so, which is also in gstreamer0.10-plugins-really-bad 0.10.22-0.1. What can i do to solve this issue? Now the half of the updates is installed and 293 are remaining.

Thanks in advance :)
Endogen
Level 1
Level 1
 
Posts: 25
Joined: Sat Oct 01, 2011 7:37 pm

Linux Mint is funded by ads and donations.
 

Re: Cant update to update pack 3 because of gstreamer proble

Postby Dave W. on Sat Oct 01, 2011 8:00 pm

Endogen,
Here is what it says to do in the update manager.


The package mint-meta-codecs features an update which should prevent you from experiencing this issue. For information, and in case you are faced with a conflict between gstreamer0.10-plugins-bad and gstreamer0.10-plugins-really-bad, simply remove the gstreamer0.10-plugins-really-bad package. It is maintained by debian-multimedia.org and currently conflicts with the Gstreamer packages maintained by Debian.

I hope this helps.

Dave
LMDE cinnamon 64 bit
Manjaro 0.8.8 Ascella Gnome amd64
Dave W.
Level 2
Level 2
 
Posts: 64
Joined: Wed Apr 07, 2010 9:15 pm
Location: Pennsylvania, USA


Re: Cant update to update pack 3 because of gstreamer proble

Postby Endogen on Sat Oct 01, 2011 8:31 pm

Thank you for the help! I fixed this right now by installing everything else then gstreamer0.10-plugins-bad_0.10.22-3_amd64.deb and then installing it. Works. :)

Thanks again!
Endogen
Level 1
Level 1
 
Posts: 25
Joined: Sat Oct 01, 2011 7:37 pm

Re: Cant update to update pack 3 because of gstreamer proble

Postby vandamme on Mon Oct 03, 2011 10:35 pm

Huh, I just fixed the same thing. Scary that a n00b like me figured out how to remove a package. Am I....turning into a nerd??
vandamme
Level 1
Level 1
 
Posts: 22
Joined: Wed Apr 14, 2010 9:17 pm
Location: Rome, NY


Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 2 guests