LMDE 201109 Bad Signature

Post your update and upgrade related errors here
Forum rules
Before you post please read this

LMDE 201109 Bad Signature

Postby seatex on Wed Oct 05, 2011 9:58 pm

Hello everyone,

I am a long time Mint user, but new here to the forums. I recently switched to LMDE last month. I installed the 201109 release and did not install any updates until Update Pack 3. I am only using the three Mint Debian update sources (as instructed in Update 3 docs).

Today was the first time I received an update since UP3. The file updated was debian-system-adjustments. I received no errors when the update installed, but now when I check for updates, I receive a bad signature error:

Code: Select all
W: GPG error: http://debian.linuxmint.com testing Release: The following signatures were invalid: BADSIG 07DC563D1F41B907 Christian Marillat <marillat@debian.org>


What should I do about this? I appreciate your help.
seatex
Level 1
Level 1
 
Posts: 8
Joined: Wed Oct 05, 2011 9:42 pm

Linux Mint is funded by ads and donations.
 

Re: LMDE 201109 Bad Signature

Postby zerozero on Wed Oct 05, 2011 10:22 pm

can you please check
Code: Select all
cat /var/log/apt/history.log
and look if debian-multimedia-keyring is among the removed pkgs in the last entries (it shouldn't, but your error shows apt is not reading the key)

anyway you can, in synaptic, do a search for it and mark it for install (or reinstall) and see if the error still persists
zerozero
Level 16
Level 16
 
Posts: 6472
Joined: Tue Jul 07, 2009 2:29 pm

Re: LMDE 201109 Bad Signature

Postby seatex on Wed Oct 05, 2011 10:49 pm

zerozero - I tried that. Here is the output...
Code: Select all
Start-Date: 2011-10-05  11:07:22
Commandline: /usr/sbin/synaptic --hide-main-window --non-interactive --parent-window-id 52428836 -o Synaptic::closeZvt=true --progress-str Please wait, this can take some time --finish-str Update is complete --set-selections-file /tmp/tmp9NEA78
Upgrade: debian-system-adjustments:amd64 (2011.07.30, 2011.10.05)
End-Date: 2011-10-05  11:07:36

Start-Date: 2011-10-05  21:35:14
Commandline: /usr/sbin/synaptic
Reinstall: debian-multimedia-keyring:amd64 (2010.12.26)
End-Date: 2011-10-05  21:35:16


After reinstalling debian-multimedia-keyring, I checked for updates again. I am still getting the same bad signature error.
seatex
Level 1
Level 1
 
Posts: 8
Joined: Wed Oct 05, 2011 9:42 pm

Re: LMDE 201109 Bad Signature

Postby zerozero on Wed Oct 05, 2011 11:06 pm

can you please post the out put of
Code: Select all
inxi -r
zerozero
Level 16
Level 16
 
Posts: 6472
Joined: Tue Jul 07, 2009 2:29 pm

Re: LMDE 201109 Bad Signature

Postby seatex on Wed Oct 05, 2011 11:12 pm

zerozero wrote:can you please post the out put of
Code: Select all
inxi -r


Code: Select all
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://packages.linuxmint.com/ debian main upstream import
           deb http://debian.linuxmint.com/latest testing main contrib non-free
           deb http://debian.linuxmint.com/latest/security testing/updates main contrib non-free
           deb http://debian.linuxmint.com/latest/multimedia testing main non-free
seatex
Level 1
Level 1
 
Posts: 8
Joined: Wed Oct 05, 2011 9:42 pm

Re: LMDE 201109 Bad Signature

Postby zerozero on Thu Oct 06, 2011 11:57 am

seatex,
there's no problem with your sources.list, if you are still getting that error (sometimes those things go as they come :shock: ) the only thing i can remember is purge it and install again
Code: Select all
sudo apt-get purge debian-multimedia-keyring

Code: Select all
sudo apt-get autoremove

Code: Select all
sudo apt-get install debian-multimedia-keyring

following this instructions
The first package to install is debian-multimedia-keyring.
Since Squeeze you can install this package with apt-get but you need to presse Y when the package ask what to do and do not press return.

hope this helps
zerozero
Level 16
Level 16
 
Posts: 6472
Joined: Tue Jul 07, 2009 2:29 pm

Re: LMDE 201109 Bad Signature

Postby seatex on Thu Oct 06, 2011 2:09 pm

I appreciate your assistance effort zerozero. Unfortunately I am still receiving the bad signature error. The system did have me enter 'Y' to confirm removal of the multimedia keyring file, but it did not ask for 'Y' confirmation to reinstall it. This error is annoying to me, and I don't understand why it is something that can "just happen". I'm never satisfied with that. I want to know why it is happening or might be happening and fix it. I'm hoping Clem will read this thread and chime in with his thoughts.

Thanks for helping me try to solve this.
seatex
Level 1
Level 1
 
Posts: 8
Joined: Wed Oct 05, 2011 9:42 pm

Re: LMDE 201109 Bad Signature

Postby seatex on Fri Oct 07, 2011 9:01 am

I'm still waiting and hoping someone can help me resolve this error. Even clearing the apt cache hasn't helped. Has anyone else had this type of bad signature error with Mint Update in LMDE? It is really annoying, and I would greatly appreciate a solution.
seatex
Level 1
Level 1
 
Posts: 8
Joined: Wed Oct 05, 2011 9:42 pm

Re: LMDE 201109 Bad Signature

Postby seatex on Fri Oct 07, 2011 11:15 am

Well, I finally found a solution, in case anyone else has this problem.

(Run as sudo)

apt-get clean
cd /var/lib/apt
mv lists lists.old
mkdir -p lists/partial
apt-get clean
apt-get update
seatex
Level 1
Level 1
 
Posts: 8
Joined: Wed Oct 05, 2011 9:42 pm

Re: LMDE 201109 Bad Signature

Postby zerozero on Fri Oct 07, 2011 7:05 pm

i'm glad you have that sorted out
zerozero
Level 16
Level 16
 
Posts: 6472
Joined: Tue Jul 07, 2009 2:29 pm

Re: LMDE 201109 Bad Signature

Postby rhodry on Fri Oct 07, 2011 8:36 pm

Sorry, I could have helped but I got to see this a bit late.

I see you found

"This can be some sort of proxy your ISP may have in place (doesn't have to be your proxy) or anywhere else on the route between you and the repositories."


That (slight) variation on the workaround should see you ok. It is a known Debian/Ubuntu bug that only manifests in certain situations. Lucky you?! :)

Glad you got it sorted.

rhodry.
Life isn't about waiting for the storm to pass...
it's about learning to dance in the rain.
rhodry
Level 4
Level 4
 
Posts: 347
Joined: Mon Jun 04, 2007 7:32 am

Re: LMDE 201109 Bad Signature

Postby themonkeymixer on Tue Oct 18, 2011 1:10 pm

just to throw in my 2 cents

i had already tried apt-get purge
then apt-get clean

it was moving the list file that fixed it for me

thanks for the info
themonkeymixer
Level 1
Level 1
 
Posts: 17
Joined: Thu Jun 23, 2011 11:37 pm

Re: LMDE 201109 Bad Signature

Postby mclavey on Mon Aug 27, 2012 11:51 am

that fixed the problem ...for me .
mclavey
Level 1
Level 1
 
Posts: 2
Joined: Mon May 07, 2012 8:50 pm

Linux Mint is funded by ads and donations.
 

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: Google Feedfetcher and 6 guests