[solved: Partial w/work around] Printer problem after UP3

Post your update and upgrade related errors here
Forum rules
Before you post please read this

[solved: Partial w/work around] Printer problem after UP3

Postby Matt267 on Mon Apr 09, 2012 2:34 pm

I'm running LMDE-XFCE tracking latest on a Dell Mini 1018 Netbook, my printer is a Brother 5370DW. I just upgraded to update pack 3 last night. Prior to the UP3 I had no problems printing. However, after UP3 I cannot print PDF files that contain images. When I print this type of file, the page prints with the following error: "ERROR NAME; typecheck COMMAND; image OPERAND STACK;" I am able to print other files before I try and print the PDF. After I try to print the PDF I can no longer print anything (there are no errors, everything seems to work but there is no output at the printer) until I restart.

I used to get the typecheck error when I tried PDF files with images under Ubuntu. With LMDE, the foomatic drivers worked perfect. Now after UP3 it's not.

Is this related to this: viewtopic.php?f=198&t=82402&start=0&hilit=foomatic?

Should I be patient until UP4 comes along? Or is there a fix.

Thanks,

Matt

Edit: I think it has to do with PDFs created from .doc files using open/libre office. I was just able to print a pdf with an image that wasn't created in open/libre office. I suspect I'm the only one having this type of issue as I can't find info online. I'm not sure if it's a print driver issue, a printer setting issue, or a .doc to pdf conversion issue. Hopfully UP4 will fix it.

Edit: After UP4, I can't print at all now. I haven't had time to play around with it yet. I'll likely start a new topic specific to my current issues.
Matt267
Level 3
Level 3
 
Posts: 150
Joined: Sat May 07, 2011 7:53 am
Location: Rhode Island, USA

Linux Mint is funded by ads and donations.
 

Re: [solved: Partial w/work around] Printer problem after UP

Postby Matt267 on Wed May 02, 2012 7:34 pm

Although UP4 rendered LMDE unable to print at all, I had the above problem with both LMDE (post UP3) and all ubuntu based operating systems. The following work around worked in Mint 10 for me.

Problem: can't print pdf files, that contain pictures, created in libre/open office with "export to PDF."

Solution: I used the PDF printer provided by cups-pdf and not the "export to PFD" feture provided by libre/open office to create the needed pdf. I can even print previously converted pdf files by first printing them with the PDF printer then with my laser printer. I'm not sure why I didn't try this sooner.

Cause: Don't know.

Matt
Matt267
Level 3
Level 3
 
Posts: 150
Joined: Sat May 07, 2011 7:53 am
Location: Rhode Island, USA

Re: [solved: Partial w/work around] Printer problem after UP

Postby Lanser on Wed May 02, 2012 10:35 pm

Hi Matt267. Just as a heads up. I am seeing some pdf's ( bank statements etc ) produced by the latest adobe sw, not wanting to print on a number of Linux based OS's.
But the same pdf's print OK on Win OS's. I haven't dug into this yet, but my firewall logs indicate attempted "adobe phone home" traffic when these new pdf's are printed.
Only a guess,.. but could be an embedded "tracker" that is not playing nice with Linux print systems.

Lanser
Earth :{"Mostly Harmless"} revised to {"Mostly Useless"} since the Smart Phones became the dominant sentient life form.
Lanser
Level 3
Level 3
 
Posts: 187
Joined: Mon Mar 08, 2010 5:12 am
Location: Perth Australia

Re: [solved: Partial w/work around] Printer problem after UP

Postby Matt267 on Thu May 03, 2012 5:38 am

Lanser,

Thanks for the heads up. Nothing stresses me out more the "protected" files (i.e. DRM protected e-books).

Matt
Matt267
Level 3
Level 3
 
Posts: 150
Joined: Sat May 07, 2011 7:53 am
Location: Rhode Island, USA


Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 5 guests