Problems with booting after installing Update pack

Post your update and upgrade related errors here
Forum rules
Before you post please read this

Problems with booting after installing Update pack

Postby Own on Tue Oct 11, 2011 1:40 pm

Greetings!

Today I've forced with t problem.


I've installed Linux Debian Mint, installed some work programs and after this also i've updated my OS via update manager.

During updating I've obtained error messages that some libraries could not been installed.

After this I've reeboted my PC. Now Linux doesn't boot. Its only black screen.

But I have access to the terminal via Alt+Cntrl+F1 and I can boot via Live CD. So it seems that some vidio drivers or desctop might be broken :)

Could you tell me possible ways of solving this problems ? I would like to reinstalling my OS

thank you
Own
Level 1
Level 1
 
Posts: 15
Joined: Tue Oct 11, 2011 1:32 pm

Linux Mint is funded by ads and donations.
 

Re: Problems with booting after installing Update pack

Postby proxima_centauri on Tue Oct 11, 2011 1:44 pm

* Moved to LMDE Update / Upgrade Issues forum

What is your graphics card? If it is ATI or NVIDIA, try the following.

Log on to console.
Code: Select all
sudo nano /etc/X11/xorg.conf

For NVIDIA: Change Device "nvidia" to Device "nouveau".
For ATI: Change "fxglx" to "radeon".

Save and exit and reboot.

If this doesn't work - you can try logging in console again, and list any errors from
Code: Select all
apt update && apt dist-upgrade
User avatar
proxima_centauri
Level 11
Level 11
 
Posts: 3969
Joined: Tue Dec 25, 2007 3:24 pm
Location: NB, Canada

Re: Problems with booting after installing Update pack

Postby Own on Tue Oct 11, 2011 2:01 pm

Thank you for your help

I've tried this sollution tomorow because now I'm at home and the problem on my work desktop.


Could you also provide me with the command for repair the damaged upgrade packages? Is this possible way to restore old packages before updating ?

proxima_centauri wrote:* Moved to LMDE Update / Upgrade Issues forum

What is your graphics card? If it is ATI or NVIDIA, try the following.

Log on to console.
Code: Select all
sudo nano /etc/X11/xorg.conf

For NVIDIA: Change Device "nvidia" to Device "nouveau".
For ATI: Change "fxglx" to "radeon".

Save and exit and reboot.

If this doesn't work - you can try logging in console again, and list any errors from
Code: Select all
apt update && apt dist-upgrade
Own
Level 1
Level 1
 
Posts: 15
Joined: Tue Oct 11, 2011 1:32 pm

Re: Problems with booting after installing Update pack

Postby proxima_centauri on Tue Oct 11, 2011 2:02 pm

Code: Select all
apt install --fix-broken
User avatar
proxima_centauri
Level 11
Level 11
 
Posts: 3969
Joined: Tue Dec 25, 2007 3:24 pm
Location: NB, Canada


Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 2 guests