Python 2.7, gnome 3 too new for mintmenu

Post your update and upgrade related errors here
Forum rules
Before you post please read this

Python 2.7, gnome 3 too new for mintmenu

Postby pyite on Fri Nov 11, 2011 2:10 pm

I finally got my apt sources fixed, but now I am getting this error:

The following packages have unmet dependencies:
mint-meta-debian : Depends: mint-meta-common but it is not going to be installed
Depends: mint-artwork-debian but it is not going to be installed
Depends: nautilus-sendto but it is not going to be installed
Depends: nautilus-share but it is not going to be installed
Depends: network-manager-gnome but it is not going to be installed


I tracked down the dependency problems and it looks like I got Gnome 3 and Python 2.7, but some of these packages still want the older versions. I'm trying to figure out where things are going wrong here, for example:

...
The following packages have unmet dependencies:
mint-meta-common : Depends: mintinstall but it is not going to be installed
Depends: mintmenu but it is not going to be installed

....

The following packages have unmet dependencies:
mintmenu : Depends: deskbar-applet but it is not going to be installed


...

The following packages have unmet dependencies:
deskbar-applet : Depends: python (< 2.7) but 2.7.2-9 is to be installed
Recommends: gnome-dictionary but it is not going to be installed





Is this a problem from staying on Debian's testing for too long, or do I have a bad repo or something?

Thanks,
Mark
pyite
Level 1
Level 1
 
Posts: 13
Joined: Thu Dec 14, 2006 1:04 pm

Linux Mint is funded by ads and donations.
 

Re: Python 2.7, gnome 3 too new for mintmenu

Postby proxima_centauri on Fri Nov 11, 2011 2:25 pm

Are you using the official Debian testing repo
Code: Select all
deb http://ftp.debian.org/debian testing main contrib non-free


or Linux Mint's testing repo
Code: Select all
deb http://debian.linuxmint.com/latest testing main contrib non-free


Stuff like the mintMenu are not compatible with GNOME3, so for the time being, it's probably best to remove the mint-meta-* packages and anything that does not meet dependencies.

I thought that the Linux Mint Debian repo would have held the update to GNOME3 until it was ready, so perhaps you are on official Debian testing.
User avatar
proxima_centauri
Level 11
Level 11
 
Posts: 3976
Joined: Tue Dec 25, 2007 3:24 pm
Location: NB, Canada

Re: Python 2.7, gnome 3 too new for mintmenu

Postby pyite on Sat Nov 12, 2011 3:53 am

OK I think I have things sorted out for now. Looks like I got the Debian version, so it looks like I am testing the upgrade process. My main problem was an Xorg bug that made almost everything unbearable... so I had to do this step:

apt-get install xserver-xorg-core -t experimental
apt-get install --reinstall nvidia-glx -t experimental

and then i had to uninstall the older nvidia packages.

Now my desktop is 1000x more pleasant to use.

Next, i'll see what I can do about these other dependency problems.
pyite
Level 1
Level 1
 
Posts: 13
Joined: Thu Dec 14, 2006 1:04 pm


Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 3 guests