Solution for the libc6 looping issue

Post your update and upgrade related errors here
Forum rules
Before you post please read this

Solution for the libc6 looping issue

Postby enyx on Mon Nov 14, 2011 2:31 am

Hi

I was recently istalled LMDE gnome, when i try to update i got the following
Code: Select all
Use of uninitialized value $text in concatenation (.) or string at /usr/share/perl5/Text/WrapI18N.pm line 101, <GEN1> line 5. substr outside of string at /usr/share/perl5/Text/WrapI18N.pm line 130, <GEN1> line 5.


That was always looping... i search in the forums but nothing... so i googled a bit and found the solution:
http://www.facepunch.com/threads/111692 ... st-upgrade

On line 130 of /usr/share/perl5/Text/WrapI18N.pm you can find:

Code: Select all
 $r = substr($string, $l);


By replacing this line with the following code, the dist-upgrade works.

Code: Select all
if (length($text) < $l) {
            $r = '';
        } else {
            $r = substr($string, $l);
        }


Hope it helps!
enyx
Level 1
Level 1
 
Posts: 1
Joined: Sun Nov 13, 2011 7:11 pm

Linux Mint is funded by ads and donations.
 

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 5 guests