Following packages have been kept back error?

Post your update and upgrade related errors here
Forum rules
Before you post please read this

Following packages have been kept back error?

Postby crazypenguin2011 on Fri Dec 23, 2011 6:14 pm

Hi everybody! I have LMDE Gnome with tha latest update pack. It has been a long time that the tray icon show that my system is up to date.. but the last time i installed updates was some 2-3 weaks ago. I tried to update via terminal so i ran "apt-get update" and that is what i get:

$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages have been kept back:
foomatic-db-engine
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

my sources.list:
deb http://packages.linuxmint.com/ debian main upstream import
deb http://debian.linuxmint.com/latest testing main contrib non-free
# deb http://security.debian.org/ testing/updates main contrib non-free
# deb http://www.debian-multimedia.org testing main non-free
deb http://debian.linuxmint.com/latest/security testing/updates main contrib no$
deb http://debian.linuxmint.com/latest/multimedia testing main non-free

PLEASE, ANY ONE? HOW TO SOLVE THE PROBLEM?
crazypenguin2011
Level 1
Level 1
 
Posts: 5
Joined: Fri Dec 23, 2011 5:50 pm

Linux Mint is funded by ads and donations.
 

Re: Following packages have been kept back error?

Postby cecar on Fri Dec 23, 2011 6:26 pm

Its not a problem. The package is being held back for a reason and it will get sorted out sooner or later.
cecar
Level 4
Level 4
 
Posts: 364
Joined: Tue Aug 24, 2010 2:47 am
Location: Stenungsund, Sweden

Re: Following packages have been kept back error?

Postby crazypenguin2011 on Fri Dec 23, 2011 6:45 pm

cecar wrote:Its not a problem. The package is being held back for a reason and it will get sorted out sooner or later.


i have a feeling that it is similar to really-bad plugins issue that kept my system from receiving updates.... can it be something similar?
crazypenguin2011
Level 1
Level 1
 
Posts: 5
Joined: Fri Dec 23, 2011 5:50 pm

Re: Following packages have been kept back error?

Postby cecar on Fri Dec 23, 2011 7:39 pm

No its not the same. This is not a error message. Its just telling you that one package is being held back. For me its two packages being held back.
foomatic-db-engine and mint-flashplugin. If your system is working ok i would not worry. Nothing is being updated in LMDE right now because Clem is waiting for Gnome 3.2 to hit testing.
cecar
Level 4
Level 4
 
Posts: 364
Joined: Tue Aug 24, 2010 2:47 am
Location: Stenungsund, Sweden

Re: Following packages have been kept back error?

Postby crazypenguin2011 on Sat Dec 24, 2011 8:52 am

man, god bless you and clem! sorry for the panic and thank you for patience and info
crazypenguin2011
Level 1
Level 1
 
Posts: 5
Joined: Fri Dec 23, 2011 5:50 pm


Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 5 guests