Cannot remove Mozilla based browser(s)

Post your update and upgrade related errors here
Forum rules
Before you post please read this

Cannot remove Mozilla based browser(s)

Postby Elderwuss on Tue Jan 24, 2012 8:47 pm

I cannot remove a chain of Mozilla based browsers. When I remove Firefox, synaptic insists on installing IceWeasel; When removing IceWeasel, synaptic insists on installing IceApe; When removing IceApe, Synaptic insists on installing Firefox. An endless loop that leaves some unwanted browser taking up space. I now use Chromium. How can I get Firefox uninstalled?
Elderwuss
Level 1
Level 1
 
Posts: 37
Joined: Sun Mar 27, 2011 8:27 pm

Linux Mint is funded by ads and donations.
 

Re: Cannot remove Mozilla based browser(s)

Postby doktornotor on Tue Jan 24, 2012 9:10 pm

You need to remove the package that depends on these, or leave the Mozilla browsers alone. You can easily view what needs FF etc. in Synaptic.
doktornotor
Level 4
Level 4
 
Posts: 212
Joined: Mon Jan 23, 2012 6:28 pm

Re: Cannot remove Mozilla based browser(s)

Postby craigevil on Tue Jan 24, 2012 9:55 pm

If I remember correctly it is a java package that relies on a Mozilla package being installed. Try using Synaptic.

No issues here:
Code: Select all
 $ apt-get remove iceweasel -s
NOTE: This is only a simulation!
      apt-get needs root privileges for real execution.
      Keep also in mind that locking is deactivated,
      so don't depend on the relevance to the real current situation!
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  iceweasel xul-ext-debianbuttons
0 upgraded, 0 newly installed, 2 to remove and 0 not upgraded.
Remv xul-ext-debianbuttons [1.7-1]
Remv iceweasel [9.0.1-1]
Debian Sid KDE4.8.4 Kernel 3.4 Thinkpad R40 CPU Pentium M 1.3MHz RAM 2GB ATI Mobility 7500
Debian - "If you can't apt-get something, it isn't useful or doesn't exist"
Giant Debian sources.list | Debian upgrade script smxi | sysinfo script inxi
craigevil
Level 5
Level 5
 
Posts: 559
Joined: Wed Sep 15, 2010 6:10 am
Location: down the rabbit hole

Re: Cannot remove Mozilla based browser(s)

Postby secipolla on Wed Jan 25, 2012 10:20 am

Also some packages require a web browser. If it's the case, install another web browser before removing Firefox.
secipolla
Level 4
Level 4
 
Posts: 356
Joined: Sun Sep 05, 2010 5:19 pm

Re: Cannot remove Mozilla based browser(s)

Postby craigevil on Wed Jan 25, 2012 4:39 pm

From the Iceweasel description:
Provides: gnome-www-browser, www-browser

from the Chromium description:
Provides: chromium-testsuite, gnome-www-browser, www-browser

flashplugin-nonfree
Suggests: iceweasel, konqueror-nsplugins, x-ttcidfont-conf, msttcorefonts, ttf-dejavu, ttf-xfree86-nonfree, flashplugin-nonfree-extrasound

Crunchbang has a package called fakeiceweasel that should take care of any depends that rely on Iceweasel/Mozilla browser.
Debian Sid KDE4.8.4 Kernel 3.4 Thinkpad R40 CPU Pentium M 1.3MHz RAM 2GB ATI Mobility 7500
Debian - "If you can't apt-get something, it isn't useful or doesn't exist"
Giant Debian sources.list | Debian upgrade script smxi | sysinfo script inxi
craigevil
Level 5
Level 5
 
Posts: 559
Joined: Wed Sep 15, 2010 6:10 am
Location: down the rabbit hole

Re: Cannot remove Mozilla based browser(s)

Postby Elderwuss on Thu Jan 26, 2012 1:35 pm

doktornotor:
I know how to find what FF depends on; But, I must confess I don't know how in Synaptic to find what depends on FF.

craigevil:
Code: Select all
elder albert # apt-get remove iceweasel
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  firefox
The following packages will be REMOVED:
  iceweasel
The following NEW packages will be installed:
  firefox
0 upgraded, 1 newly installed, 1 to remove and 1 not upgraded.
Need to get 0 B/12.8 MB of archives.
After this operation, 23.4 MB of additional disk space will be used.
Do you want to continue [Y/n]? n
Abort.

Apparently reality is different from a simulation.

secipolla:
I had chromium installed.

Thanks, all. I have to assume that one of the three Mozilla based browsers is required for something; Although that strikes me as extremely odd.
Elderwuss
Level 1
Level 1
 
Posts: 37
Joined: Sun Mar 27, 2011 8:27 pm

Re: Cannot remove Mozilla based browser(s)

Postby Elderwuss on Thu Jan 26, 2012 1:53 pm

Wow. After years of using Synaptic, I never noticed that Dependencies was only one entry in a dropdown.
Elderwuss
Level 1
Level 1
 
Posts: 37
Joined: Sun Mar 27, 2011 8:27 pm

Re: Cannot remove Mozilla based browser(s)

Postby Elderwuss on Thu Jan 26, 2012 2:16 pm

craigevil: You seem to be right about sun-java6-plugin. That plugin seems to be needed by mint-meta-codecs, which would indicate that Mint is responsible. But I don't really know. My mind ties itself in knots in complex dependency relationships.
Elderwuss
Level 1
Level 1
 
Posts: 37
Joined: Sun Mar 27, 2011 8:27 pm

Re: Cannot remove Mozilla based browser(s)

Postby doktornotor on Thu Jan 26, 2012 3:13 pm

Remove the (outdated anyway) sun-java6-plugin and use this instead if you need Oracle Java: viewtopic.php?p=532241#p532241

(Firefox & Co. NOT required.)
doktornotor
Level 4
Level 4
 
Posts: 212
Joined: Mon Jan 23, 2012 6:28 pm

Linux Mint is funded by ads and donations.
 

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 2 guests