[Solved] Fresh Install, Update ... No X at boot, nvidia

Post your update and upgrade related errors here
Forum rules
Before you post please read this

[Solved] Fresh Install, Update ... No X at boot, nvidia

Postby timber on Fri Feb 17, 2012 10:04 pm

Boot problem, not able to get to X ...

Fresh instal of LMDE 64 bit (201109)
Install went smooth.

Did update using Update Manager (kernel upgraded to 3.?.?) followed instructions regarding Package 3 issues including note regarding changing to nvidia-glx and getting rid of gstreamer very bad.

nvidia-glx was installed using package manager.
Upon reboot I get black screen with cursor upper left only. (no X)
Recovery mode I get (EE) error note regarding Xconf. nvidia no nv etc.

In hindsite, I probably should have installed nvidia-xconfig but did not.
Since I'm not online at the boot prompt, how can I do an apt-get install?
(Can I do this using the Live-CD, if so, how do I do this)?

Was hoping to do the following to try to recover:

apt-get update

apt-get install nvidia-kernel-dkms nvidia-settings nvidia-xconfig

nvidia-xconfig


Any help to recover and get to X would be greatly appreciated!
Last edited by timber on Mon Feb 20, 2012 5:19 pm, edited 1 time in total.
Dave:

Samsung R580 laptop
Geforce 310M w/ nvidia-glx driver
8 gig RAM
LMDE Cinnamon - Kernel 3.2.0-4-amd64 x86_64 (64 bit) Distro LinuxMint 1 debian
User avatar
timber
Level 3
Level 3
 
Posts: 104
Joined: Sat Jan 02, 2010 11:24 pm
Location: Pacific Northwest

Linux Mint is funded by ads and donations.
 

Re: Fresh Install, Update ... No X at boot, nvidia

Postby LifeInTheGrey on Fri Feb 17, 2012 11:48 pm

timber wrote:Boot problem, not able to get to X ...

Fresh instal of LMDE 64 bit (201109)
Install went smooth.

Did update using Update Manager (kernel upgraded to 3.?.?) followed instructions regarding Package 3 issues including note regarding changing to nvidia-glx and getting rid of gstreamer very bad.

nvidia-glx was installed using package manager.
Upon reboot I get black screen with cursor upper left only. (no X)
Recovery mode I get (EE) error note regarding Xconf. nvidia no nv etc.

In hindsite, I probably should have installed nvidia-xconfig but did not.
Since I'm not online at the boot prompt, how can I do an apt-get install?
(Can I do this using the Live-CD, if so, how do I do this)?

Was hoping to do the following to try to recover:

apt-get update

apt-get install nvidia-kernel-dkms nvidia-settings nvidia-xconfig

nvidia-xconfig


Any help to recover and get to X would be greatly appreciated!


The nVidia drivers in LMDE's repo are the old version, and do not support the new kernel architecture of 3.0+. You need to boot into the 2.6.39 kernel, then temporarily modify your sources to Debian Testing so that you can update your nVidia drivers. Run sudo nvidia-xconfig, then sudo update-initramfs -u && sudo update-grub2, then reboot. You should then be good to go. :)

Just make sure to change your sources back to LMDE, else you wish to upgrade to convoluted version of GNOME 3.
the beauty of linux is that the rabbit hole goes as deep as you want it to go.
LifeInTheGrey
Level 3
Level 3
 
Posts: 145
Joined: Thu Apr 28, 2011 4:38 pm
Location: Seattle

Re: Fresh Install, Update ... No X at boot, nvidia

Postby timber on Sat Feb 18, 2012 12:30 am

Thanks much for the reply LifeInTheGrey.

At least now I know what's causing my problem and your explanation makes perfect sense to me except for the issue of how to run the command(s) since my connection to the internet isn't connected at the boot prompt.

Can I run the command(s) ... sudo nvidia-xconfig, then sudo update-initramfs -u && sudo update-grub2 ... from the Live-CD?
Also, I don't have nvidia-xconfig installed yet ... so can I install it from the Live-CD first?

Sorry, I'm not very good at the command line yet, even though I've had one form of Linux or another on my machine for the past few years.
I can boot via the LiveCD and get to the sources.list file fine to modify my sources to Debian Testing ... just don't know how to download the packages from the Live-CD and have them end up on the partition where they belong.

Thank you very much for the help ... it IS appreciated!
Dave:

Samsung R580 laptop
Geforce 310M w/ nvidia-glx driver
8 gig RAM
LMDE Cinnamon - Kernel 3.2.0-4-amd64 x86_64 (64 bit) Distro LinuxMint 1 debian
User avatar
timber
Level 3
Level 3
 
Posts: 104
Joined: Sat Jan 02, 2010 11:24 pm
Location: Pacific Northwest

Re: Re: Fresh Install, Update ... No X at boot, nvidia

Postby LifeInTheGrey on Sat Feb 18, 2012 3:23 am

timber wrote:Thanks much for the reply LifeInTheGrey.

At least now I know what's causing my problem and your explanation makes perfect sense to me except for the issue of how to run the command(s) since my connection to the internet isn't connected at the boot prompt.

Can I run the command(s) ... sudo nvidia-xconfig, then sudo update-initramfs -u && sudo update-grub2 ... from the Live-CD?
Also, I don't have nvidia-xconfig installed yet ... so can I install it from the Live-CD first?

Sorry, I'm not very good at the command line yet, even though I've had one form of Linux or another on my machine for the past few years.
I can boot via the LiveCD and get to the sources.list file fine to modify my sources to Debian Testing ... just don't know how to download the packages from the Live-CD and have them end up on the partition where they belong.

Thank you very much for the help ... it IS appreciated!


My pleasure. Unless you uninstalled the .39 kernel, you can just select it from the GRUB menu and it will boot to a graphic environment (the drivers are only broken for the 3.0 kernel). Once in there you should be able to take care of everything.

Tappa tappa
the beauty of linux is that the rabbit hole goes as deep as you want it to go.
LifeInTheGrey
Level 3
Level 3
 
Posts: 145
Joined: Thu Apr 28, 2011 4:38 pm
Location: Seattle

Re: Fresh Install, Update ... No X at boot, nvidia

Postby timber on Sat Feb 18, 2012 3:27 am

I couldn't get X working with the current driver (after kernel update to 3.0.0.1) since I had no way to install nvidia-xconfig via the later kernel or the earlier kernel at the boot manager (no internet connection from root at boot prompt).
(I suspect that there is a way to disable the video driver installed but I couldn't find the right command to edit into the boot line to disable the nvidia glx driver).

So, I had an extra partition on my drive and I reinstalled LMDE (once again).
Before I edited the repositories from Debian to linuxmint (per Pack 3 instructions) at the update manager, I did the following:

Code: Select all
sudo apt-get update
sudo apt-get install nvidia-kernel-dkms nvidia-settings nvidia-xconfig


Then I did the following:

Code: Select all
sudo nvidia-xconfig
sudo update-initramfs -u && sudo update-grub2


Next I got rid of gstreamer very bad (per Pack 3 instructions)
Then edited the repositories from Debian to linuxmint (per Pack 3 instructions)
Ran a refresh on the update manager, did the first single update then
Ran install updates on the update manager.

I'll let it update while I sleep ... and keep you posted here as to how it went.
Thanks again, under normal circumstances I'm sure I could have done as you said and use the earlier kernel to get the job done. For some reason (beyond my comprehension) the earlier kernel wouldn't work either. (Must have been something else I did before updating, don't know).
Dave:

Samsung R580 laptop
Geforce 310M w/ nvidia-glx driver
8 gig RAM
LMDE Cinnamon - Kernel 3.2.0-4-amd64 x86_64 (64 bit) Distro LinuxMint 1 debian
User avatar
timber
Level 3
Level 3
 
Posts: 104
Joined: Sat Jan 02, 2010 11:24 pm
Location: Pacific Northwest

Re: Fresh Install, Update ... No X at boot, nvidia

Postby timber on Sat Feb 18, 2012 12:12 pm

Well, they say that "practice makes perfect" ... well I don't think "perfect" is quite the case here but I am determined to "get 'er done" so I persevere.

As you may have guessed by my comments regarding the changes I made to my sources.list above (thinking that I was changing my sources to Debian Testing), I screwed it up again and am once again locked out of a freshly updated LMDE.

When LifeInTheGrey indicated that I should "temporarily modify my sources to Debian Testing" I now believe he meant that my sources list should temporarily be as follows:
(Please correct me if I'm wrong).


I'll try again, using the above sources to run only the following:


Code: Select all
sudo nvidia-xconfig
sudo update-initramfs -u && sudo update-grub2


Then reboot (and hope that I did this correctly this time).

Once this is working I will change my sources back as advised (by the instructions per Pack 3 update).

Wish me luck! (I seem to be making this very difficult ... it's tough being a newbie sometimes ... ha!)
Dave:

Samsung R580 laptop
Geforce 310M w/ nvidia-glx driver
8 gig RAM
LMDE Cinnamon - Kernel 3.2.0-4-amd64 x86_64 (64 bit) Distro LinuxMint 1 debian
User avatar
timber
Level 3
Level 3
 
Posts: 104
Joined: Sat Jan 02, 2010 11:24 pm
Location: Pacific Northwest

Re: Fresh Install, Update ... No X at boot, nvidia

Postby twa on Sat Feb 18, 2012 4:18 pm

timber,
I'll suggest U install smxi:
http://smxi.org/
read the tutorial for the first setup and let the script take care of your NVidia.
am using it since my first install on sep-2010 and NEVER had problems with new kernels and NVidia drivers.
hv kernel 3.0.0.1 and NVidia 290.10 and X11.10.4
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread.
User avatar
twa
Level 4
Level 4
 
Posts: 231
Joined: Fri Sep 17, 2010 8:11 am
Location: Somewhere in the sky

Re: Fresh Install, Update ... No X at boot, nvidia

Postby timber on Sat Feb 18, 2012 7:54 pm

Hi TWA,
This is probably the best way to get me up and running on kernel 3.0+.
So far, I've tried the Pack 3 instructions and that didn't work.
Tried changing Sources to Debian only and updating grub2

Currently I'm in via the older kernel but if I go out of here I think I will get a black screen again.
I'll give smxi a try.
Thanks
Dave:

Samsung R580 laptop
Geforce 310M w/ nvidia-glx driver
8 gig RAM
LMDE Cinnamon - Kernel 3.2.0-4-amd64 x86_64 (64 bit) Distro LinuxMint 1 debian
User avatar
timber
Level 3
Level 3
 
Posts: 104
Joined: Sat Jan 02, 2010 11:24 pm
Location: Pacific Northwest

Re: Fresh Install, Update ... No X at boot, nvidia

Postby zerozero on Sat Feb 18, 2012 11:09 pm

timber,
twa's suggestion might be the easiest way (once you understand how smxi works) to get you up&running;

anyway i just want to share here my experience with a 201109 lmde respin i installed a couple weeks ago:
- after changing the repos (according to the instructions regarding UP3) and dealing with the dreadful gstreamer error again
all the relevant info here
- i went to install the nvidia driver, my card is a gts250
Code: Select all
inxi -Gx
Graphics:  Card nVidia G92 [GeForce GTS 250] X.Org 1.10.4 Res: 1440x900@50.0hz
           GLX Renderer GeForce GTS 250/PCI/SSE2 GLX Version 3.3.0 NVIDIA 280.13 Direct Rendering Yes

- what i did was
Code: Select all
apt install nvidia-kernel-dkms nvidia-glx build-essential nvidia-settings nvidia-xconfig

and
Code: Select all
nvidia-xconfig
after the actual installation (but before rebooting)
this brought the necessary pkgs within
Code: Select all
Start-Date: 2012-02-01  12:49:31
Commandline: apt-get install nvidia-kernel-dkms nvidia-glx build-essential nvidia-settings nvidia-xconfig
Install: nvidia-vdpau-driver:amd64 (280.13-1, automatic), nvidia-kernel-dkms:amd64 (280.13-1), nvidia-kernel-common:amd64 (20110729+1, automatic), xserver-xorg-video-nvidia:amd64 (280.13-1, automatic), libgl1-nvidia-glx:amd64 (280.13-1, automatic), libgl1-nvidia-alternatives:amd64 (280.13-1, automatic), glx-alternative-mesa:amd64 (0.1.91, automatic), nvidia-installer-cleanup:amd64 (20110729+1, automatic), glx-alternative-nvidia:amd64 (0.1.91, automatic), nvidia-xconfig:amd64 (280.13-1), nvidia-alternative:amd64 (280.13-1, automatic), nvidia-support:amd64 (20110729+1, automatic), glx-diversions:amd64 (0.1.91, automatic), nvidia-glx:amd64 (280.13-1), nvidia-settings:amd64 (280.13-1), libglx-nvidia-alternatives:amd64 (280.13-1, automatic)
End-Date: 2012-02-01  12:51:05

as you can see it installed the 280.13 driver (with support for my card) and as you can also above from the inxi -Gx output i have now direct rendering;
Last edited by zerozero on Sun Feb 19, 2012 7:38 pm, edited 1 time in total.
Reason: link rectified
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm

Re: Fresh Install, Update ... No X at boot, nvidia

Postby LifeInTheGrey on Sat Feb 18, 2012 11:30 pm

zerozero wrote:timber,
twa's suggestion might be the easiest way (once you understand how smxi works) to get you up&running;

anyway i just want to share here my experience with a 201109 lmde respin i installed a couple weeks ago:
- after changing the repos (according to the instructions regarding UP3) and dealing with the dreadful gstreamer error again [url=forums.linuxmint.com/viewtopic.php?f=185&t=82346]all the relevant info here[/url]
- i went to install the nvidia driver, my card is a gts250
Code: Select all
inxi -Gx
Graphics:  Card nVidia G92 [GeForce GTS 250] X.Org 1.10.4 Res: 1440x900@50.0hz
           GLX Renderer GeForce GTS 250/PCI/SSE2 GLX Version 3.3.0 NVIDIA 280.13 Direct Rendering Yes

- what i did was
Code: Select all
apt install nvidia-kernel-dkms nvidia-glx build-essential nvidia-settings nvidia-xconfig

and
Code: Select all
nvidia-xconfig
after the actual installation (but before rebooting)
this brought the necessary pkgs within
Code: Select all
Start-Date: 2012-02-01  12:49:31
Commandline: apt-get install nvidia-kernel-dkms nvidia-glx build-essential nvidia-settings nvidia-xconfig
Install: nvidia-vdpau-driver:amd64 (280.13-1, automatic), nvidia-kernel-dkms:amd64 (280.13-1), nvidia-kernel-common:amd64 (20110729+1, automatic), xserver-xorg-video-nvidia:amd64 (280.13-1, automatic), libgl1-nvidia-glx:amd64 (280.13-1, automatic), libgl1-nvidia-alternatives:amd64 (280.13-1, automatic), glx-alternative-mesa:amd64 (0.1.91, automatic), nvidia-installer-cleanup:amd64 (20110729+1, automatic), glx-alternative-nvidia:amd64 (0.1.91, automatic), nvidia-xconfig:amd64 (280.13-1), nvidia-alternative:amd64 (280.13-1, automatic), nvidia-support:amd64 (20110729+1, automatic), glx-diversions:amd64 (0.1.91, automatic), nvidia-glx:amd64 (280.13-1), nvidia-settings:amd64 (280.13-1), libglx-nvidia-alternatives:amd64 (280.13-1, automatic)
End-Date: 2012-02-01  12:51:05

as you can see it installed the 280.13 driver (with support for my card) and as you can also above from the inxi -Gx output i have now direct rendering;


If you get the newer proprietary nVidia drivers, make sure to blacklist nouveau as well. Removing the files will remove xorg, which is ... not so good, so in root terminal enter:

gedit /etc/modprobe.d/blacklist-nouveau.conf

and simply write:

blacklist nouveau

and reboot. This is a very simple, but KEY, component, otherwise you'll be stuck in blinking cursor land.
the beauty of linux is that the rabbit hole goes as deep as you want it to go.
LifeInTheGrey
Level 3
Level 3
 
Posts: 145
Joined: Thu Apr 28, 2011 4:38 pm
Location: Seattle

Re: Fresh Install, Update ... No X at boot, nvidia

Postby timber on Sun Feb 19, 2012 6:00 pm

twa's suggestion might be the easiest way (once you understand how smxi works)

Yes, smxi presents a pretty steep learning curve ... I tried and failed miserably to get it to work for me at all.
I think the biggest problem I have there is connecting to the internet when not in X ... (I have WEP so it makes it a bit of a hassle).
I also find that smxi may be easy once you know it but is totally overwhelming to a new user.
I got the script loaded but the instructions are so long and complex and not set up in a way that I know what I need to do. (Perhaps I'm the only one who can't figure it out but with multiple scripts and multiple instructions all in a row, I think the writer assumes I know much more than I do),
I'm going to try to get the nvidia drivers working without smxi for now.

LifeInTheGrey,

Re: "stuck in blinking cursor land", I've been there for a while now and I'm getting quite used to it ... I'm thinking it's the new "norm" for me. :lol:
The deal is, I simply like LMDE very much, for me it's the perfect combination of stability yet latest tools with the fine polish of mint.
So, I'm determined to get this to work.

Currently, I'm a tad overwhelmed from trying so many things and I'm "stuck in blinking cursor land" again.
I think adding smxi to the mix is not making any easier for me right now.
As you might imagine, I don't really care about the latest or greatest nvidia drivers, I simply want LMDE to be able to update to Pack 3 and work.
I have no doubt that it's possible, I've just not found the right way to do it yet. I appreciate your hanging in there with me to get this working.

If you get the newer proprietary nVidia drivers, make sure to blacklist nouveau as well. Removing the files will remove xorg, which is ... not so good


This corresponds exactly to what I am seeing when I try to boot (then end up at the blinking cursor), so I think it may be the answer.
I'm going to install LMDE again and give it a try.

Thanks to all,
Dave:

Samsung R580 laptop
Geforce 310M w/ nvidia-glx driver
8 gig RAM
LMDE Cinnamon - Kernel 3.2.0-4-amd64 x86_64 (64 bit) Distro LinuxMint 1 debian
User avatar
timber
Level 3
Level 3
 
Posts: 104
Joined: Sat Jan 02, 2010 11:24 pm
Location: Pacific Northwest

Re: Fresh Install, Update ... No X at boot, nvidia

Postby zerozero on Sun Feb 19, 2012 7:48 pm

timber,
1- i edited my last post because the link to the relevant topic with the info concerning UP3 was displaying incorrectly, the right link is this viewtopic.php?f=185&t=82346
2- first you have to make sure that you update successfully to UP3 and only after that you can think about installing the nvidia drivers (and doesn't matter here which method you choose)
3- i wouldn't be in a big hurry to install now the drivers, in a few days with UP4 they are most certainly going to break viewtopic.php?f=198&t=67502&start=1600#p539934
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm

Re: Fresh Install, Update ... No X at boot, nvidia

Postby timber on Sun Feb 19, 2012 8:25 pm

Thanks for the update and information Zerozero, it's appreciated!
I think you're right, I should just let the dust settle until Pack 4 is out.
I still don't have Pack 3 working with nvidia M310 but Pack 2 is working and I'm willing to use Pack 2 for now.

I get to a point after so many attempts at making nvidia play well with others that I realize that I just don't have to update right now to be happy.

I do appreciate everyone's attempts at helping here, not sure what I'm doing wrong other than not being smart enough (linux wise) to figure it out.

So thanks ... here's to letting the dust settle before another attempt. :D
Dave:

Samsung R580 laptop
Geforce 310M w/ nvidia-glx driver
8 gig RAM
LMDE Cinnamon - Kernel 3.2.0-4-amd64 x86_64 (64 bit) Distro LinuxMint 1 debian
User avatar
timber
Level 3
Level 3
 
Posts: 104
Joined: Sat Jan 02, 2010 11:24 pm
Location: Pacific Northwest

[Solved] Re: Fresh Install, Update ... No X at boot, nvidia

Postby timber on Mon Feb 20, 2012 5:19 pm

Hi Zerozero,

1- i edited my last post because the link to the relevant topic with the info concerning UP3 was displaying incorrectly, the right link is this viewtopic.php?f=185&t=82346


This pointed me in the right direction.
Although when I tried to reinstall nvidia common kernel it said it couldn't find it even though it was installed according to the package manager.
I did a complete uninstall from package manager then reinstalled making sure to also get dkms and source.

That did it. (I had Debian as my source and made sure to refresh when I did this),
All working from the new 3.0.0.1 kernel now ... at least I'll have a clue how to fix this if it breakes for the next (Pack 4) update.

Thanks to all for the suggestions and links ... with your help, the problem is solved.

Gotta love this forum and the Mint Team ... ya'll do a wonderful job ... Thank You!

FYI, I made my (LMDE) sources.list as follows for easy changes:


Update: Added Incoming sources and will be using these.
Last edited by timber on Tue Feb 21, 2012 4:22 am, edited 1 time in total.
Dave:

Samsung R580 laptop
Geforce 310M w/ nvidia-glx driver
8 gig RAM
LMDE Cinnamon - Kernel 3.2.0-4-amd64 x86_64 (64 bit) Distro LinuxMint 1 debian
User avatar
timber
Level 3
Level 3
 
Posts: 104
Joined: Sat Jan 02, 2010 11:24 pm
Location: Pacific Northwest

Re: [Solved] Fresh Install, Update ... No X at boot, nvidia

Postby zerozero on Mon Feb 20, 2012 8:53 pm

Dave,
i'm glad you have sorted that out and can now enjoy lmde fully 8)

have fun
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm

Re: [Solved] Fresh Install, Update ... No X at boot, nvidia

Postby timber on Tue Feb 21, 2012 7:43 pm

In summary ...

Just a note to those with Nvidia chipsets installing LMDE 201109 for the first time.
(Performing the update in the following order worked well for me with no loss of X desktop, when moving to kernel 3.0+).

1) Leave the nouveau drivers in place until the update is complete.

2) Before update to Pack 3, change your /etc/apt/sources.list as noted in "Update Pack Info".

3) Use Package Manager to completely uninstall "gstreamer0.10-plugins-really-bad" as noted in "Update Pack Info".

4) After refreshing the Update Manager ... Install Updates.

5) Change your /etc/apt/sources.list to Debian Testing, as follows:

6) Install nvidia drivers (this can be done via the Package Manager but command line may be easier in this case):
Code: Select all
sudo apt-get update
sudo apt-get install nvidia-kernel-dkms nvidia-settings nvidia-xconfig

Now configure and update nvidia drivers and update grub2 as follows:
Code: Select all
sudo nvidia-xconfig
sudo update-initramfs -u && sudo update-grub2


7) And now change your /etc/apt/sources.list back to Multimedia and Security repositories, as follows:

8) Now blacklist nouveau:
Code: Select all
sudo gedit /etc/modprobe.d/blacklist-nouveau.conf

and simply write:
blacklist nouveau

9) Reboot and enjoy!

Newbie Disclaimer: I just did a reinstall using the methods listed above and it went very smoothly. YMMV but my hopes are that this will keep you out of the dark.
Thanks to the folks above who rescued me from the land of the "dreaded blinking cursor" during the move to the 3.0 kernel.
Dave:

Samsung R580 laptop
Geforce 310M w/ nvidia-glx driver
8 gig RAM
LMDE Cinnamon - Kernel 3.2.0-4-amd64 x86_64 (64 bit) Distro LinuxMint 1 debian
User avatar
timber
Level 3
Level 3
 
Posts: 104
Joined: Sat Jan 02, 2010 11:24 pm
Location: Pacific Northwest

Linux Mint is funded by ads and donations.
 

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 3 guests