Fresh install, updated repos, foomatic being held back

Post your update and upgrade related errors here
Forum rules
Before you post please read this

Fresh install, updated repos, foomatic being held back

Postby afzalarsalan on Mon Feb 20, 2012 3:28 pm

After running a fresh install, I looked to see I would need to do anything before updating and saw that there was a change of repos. After changing the repos to this:
Code: Select all
deb http://packages.linuxmint.com/ debian main upstream import backport romeo
deb-src http://packages.linuxmint.com/ debian main upstream import backport romeo
deb http://debian.linuxmint.com/latest testing main contrib non-free
deb http://debian.linuxmint.com/latest/security testing/updates main contrib non-free
deb http://debian.linuxmint.com/latest/multimedia testing main non-free

I ran mint-update and refreshed the packages. After trying to update I would constantly get an error
Image

I would click okay but mint update would just close and when I opened it, it would just show my list of updates. If I tried to update again I would get the same error.

I tried using aptitude, which looked like it would work, but in the end I got an error about foomatic being held back.

Code: Select all
sudo aptitude full-upgrade
The following NEW packages will be installed:
  cpp-4.5{a} freepats{a} gcc-4.5{a} gcc-4.5-base{a} gcj-4.6-base{a}
  gcj-4.6-jre-lib{a} gir1.2-json-1.0{ab} gir1.2-peas-1.0{a}
  gnome-desktop3-data{a} libelfg0{a} libevince3{a} libgail-3-0{a}
  libgcj-bc{a} libgcj-common{a} libgcj12{a} libgdata1.8-cil{a}
  libglew1.6{a} libgnome-desktop-3-0{a} libgtk-3-bin{a} libjaxp1.3-java{a}
  libjaxp1.3-java-gcj{a} liblockfile-bin{a} libmhash2{a}
  libmission-control-plugins0{a} libmount1{a} libmtp-runtime{a} libmtp9{a}
  libnotify4{a} libpeas-1.0-0{a} libpeas-common{a} libpoppler-glib6{a}
  libpoppler13{a} libseed-gtk3-0{a} libsigsegv2{a}
  libtracker-client-0.10-0{a} libtracker-sparql-0.10-0{a} libunistring0{a}
  libwebkitgtk-3.0-0{a} libwebkitgtk-3.0-common{a} libwildmidi-config{a}
  libxalan2-java{a} libxalan2-java-gcj{a} libxerces2-java{a}
  libxerces2-java-gcj{a} linux-headers-3.0.0-1-amd64{a}
  linux-headers-3.0.0-1-common{a} linux-headers-amd64{a}
  linux-image-3.0.0-1-amd64{a} linux-image-amd64{a} linux-kbuild-3.0.0{a}
  poppler-data{a} zenity-common{a}
The following packages will be upgraded:
  acpid alsa-utils apt apt-file apt-utils aspell aspell-en banshee
  base-files base-passwd bc binfmt-support bluez brasero brasero-common
  bsdutils busybox cpp-4.4 cpufrequtils cron cups cups-client cups-common
  cups-driver-gutenprint cups-ppdc curl dbus dbus-x11 dc
  debian-system-adjustments dkms dmsetup eog evince evince-common fakeroot
  firefox firefox-l10n-en-us firmware-atheros firmware-bnx2 firmware-bnx2x
  firmware-intelwimax firmware-ipw2x00 firmware-ivtv firmware-iwlwifi
  firmware-linux firmware-linux-nonfree firmware-qlogic firmware-ralink
  firmware-realtek foomatic-db foomatic-db-engine{b} foomatic-filters
  fortunes-husse fuse fuse-utils g++-4.4 gawk gcc-4.4 gcc-4.4-base
  gconf-editor gecko-mediaplayer genisoimage gettext-base gimp
  gir1.2-clutter-1.0 gir1.2-gdkpixbuf-2.0 gir1.2-gtk-3.0 gnome-applets
  gnome-applets-data gnome-bluetooth gnome-disk-utility gnome-icon-theme
  gnome-mplayer gnome-nettool gnome-power-manager gnome-settings-daemon
  gnome-user-share grep grub-common grub-pc grub-pc-bin grub2-common
  gstreamer0.10-plugins-bad gstreamer0.10-plugins-really-bad
  gstreamer0.10-plugins-ugly{b} gzip hal hwdata initscripts iptables
  iso-codes jfsutils kbd klibc-utils libalgorithm-diff-xs-perl
  libapache2-mod-dnssd libarchive1 libart2.0-cil libasound2
  libasound2-plugins libaspell15 libasyncns0 libaudio2 libaudit0
  libavcodec53 libavutil51 libblas3gf libblkid1 libbluetooth3
  libbrasero-media0 libbs2b0 libburn4 libc-bin libc-dev-bin libc6 libc6-dev
  libcap2 libcap2-bin libclutter-1.0-0 libcpufreq0 libcups2 libcupscgi1
  libcupsdriver1 libcupsimage2 libcupsmime1 libcupsppdc1 libcurl3
  libcurl3-gnutls libdbus-1-3 libdevmapper1.02.1 libedit2 libenchant1c2a
  libencode-locale-perl libevolution libfaad2 libflac8 libfreetype6
  libfuse2 libgconf2.0-cil libgcrypt11 libgdiplus libgdk-pixbuf2.0-0
  libgdu-gtk0 libgdu0 libgimp2.0 libgl1-mesa-dev libgl1-mesa-dri
  libgl1-mesa-glx libglade2.0-cil libglib-perl libglib2.0-cil libglu1-mesa
  libgnome-bluetooth7 libgnome-vfs2.0-cil libgnome2.24-cil
  libgnomecanvas2-0 libgnomecanvas2-common libgnomepanel2.24-cil
  libgnomeui-0 libgnomeui-common libgnutls26 libgstfarsight0.10-0
  libgtk-3-0 libgtk-3-common libgtk2.0-cil libgtkmm-2.4-1c2a libgudev-1.0-0
  libgutenprint2 libhal-storage1 libhal1 libhtml-format-perl
  libhtml-template-perl libidn11 libieee1284-3 libijs-0.35 libisofs6
  libjasper1 libjpeg62 libjs-jquery libjson-glib-1.0-0 libkarma0 libklibc
  libkpathsea5 liblapack3gf liblcms1 libldap-2.4-2 liblist-moreutils-perl
  liblocale-gettext-perl liblockfile1 libltdl7 liblua5.1-0 liblvm2app2.2
  liblzma2 liblzo2-2 libmng1 libmono-addins-gui0.2-cil
  libmono-addins0.2-cil libmp3lame0 libmpfr4 libmtp-common libnotify-bin
  libnspr4-0d libnss3-1d liboobs-1-4 libparted0debian1 libpci3 libpcre3
  libpcsclite1 libperl5.12 libplist1 libpng12-0 libpolkit-agent-1-0
  libpolkit-backend-1-0 libpolkit-gobject-1-0 libpolkit-gtk-1-0
  libportaudio2 libpostproc51 libpulse-browse0 libpulse-mainloop-glib0
  libpulse0 libpurple-bin libpurple0 libpython2.6 libraptor2-0 librasqal3
  librecode0 libreoffice libreoffice-base libreoffice-base-core
  libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw
  libreoffice-emailmerge libreoffice-filter-mobiledev libreoffice-gnome
  libreoffice-gtk libreoffice-impress libreoffice-java-common
  libreoffice-math libreoffice-report-builder-bin libreoffice-style-galaxy
  libreoffice-style-tango libreoffice-writer librtmp0 libruby1.8
  libsamplerate0 libsane libsane-common libsgutils2-2 libsmbclient
  libsndfile1 libsoundtouch0 libsoup-gnome2.4-1 libsoup2.4-1 libsqlite0
  libssh2-1 libstdc++6-4.4-dev libswscale2 libtalloc2 libtasn1-3 libtdb1
  libtelepathy-glib0 libtext-charwidth-perl libtext-iconv-perl libudev0
  liburi-perl libusb-0.1-4 libusb-1.0-0 libuuid1 libv4l-0 libvlc5
  libvlccore4 libvpx0 libwbclient0 libwildmidi1 libwmf0.2-7 libx11-6
  libx11-data libx11-dev libx11-xcb1 libx264-116 libxapian22 libxfont1
  libxklavier16 libxml2 libxml2-utils libxslt1.1 libxss1 libxtst6 libxv1
  libxvidcore4 libyajl1 linux-headers-2.6-amd64 linux-image-2.6-amd64
  linux-libc-dev locales m4 man-db manpages manpages-dev mesa-common-dev
  mesa-utils mint-meta-codecs{b} mintbackup mintmenu mintwelcome
  mobile-broadband-provider-info modemmanager mount mplayer
  multiarch-support nautilus-share net-tools network-manager-gnome
  notification-daemon ntfs-3g{b} ntp openssh-client p7zip p7zip-full
  pciutils perl perl-base perl-modules pidgin pidgin-data policykit-1
  policykit-1-gnome poppler-utils procps pulseaudio
  pulseaudio-esound-compat pulseaudio-module-gconf pulseaudio-module-x11
  pulseaudio-module-zeroconf pulseaudio-utils python python-bugbuddy
  python-chardet python-dbus python-debian python-evolution
  python-gnomeapplet python-gnomedesktop python-gnomekeyring python-gobject
  python-gtkspell python-libxml2 python-mako python-markupsafe
  python-minimal python-notify python-openssl python-parted python-uno
  python-wnck python-xapian python2.6 python2.6-minimal python2.7
  python2.7-minimal rsyslog ruby1.8 samba samba-common samba-common-bin
  sane-utils simple-scan system-tools-backends sysv-rc sysvinit
  sysvinit-utils telepathy-gabble telepathy-mission-control-5 thunderbird
  thunderbird-l10n-en-us totem totem-common totem-mozilla totem-plugins
  transmission-common transmission-gtk ttf-dejavu ttf-dejavu-core
  ttf-dejavu-extra ttf-opensymbol udev ufraw-batch ufw uno-libs3
  update-inetd ure usb-modeswitch usb-modeswitch-data usbutils util-linux
  uuid-runtime vim-common vim-tiny vino vlc vlc-data vlc-nox
  vlc-plugin-notify vlc-plugin-pulse w3m wget wvdial x11-common
  xdg-user-dirs xinit xnest xserver-common xserver-xorg xserver-xorg-core
  xserver-xorg-input-all xserver-xorg-video-all xsltproc xz-utils zenity
The following packages are RECOMMENDED but will NOT be installed:
  cdrdao citadel-mta courier-mta dma esmtp-run exim4 exim4-daemon-heavy
  exim4-daemon-light libclass-isa-perl libclutter-1.0-common
  libpod-plainer-perl libreoffice-filter-binfilter libswitch-perl masqmail
  msmtp-mta nullmailer openssh-blacklist openssh-blacklist-extra postfix
  python-gobject-cairo sendmail-bin smbclient ssmtp tdb-tools
  totem-coherence ttf-liberation ttf-mscorefonts-installer xmail
422 packages upgraded, 52 newly installed, 0 to remove and 0 not upgraded.
Need to get 589 MB of archives. After unpacking 383 MB will be used.
The following packages have unmet dependencies:
  foomatic-db-engine: Breaks: cups (< 1.5.0-3~) but 1.4.8-2 is to be installed.
  gstreamer0.10-plugins-ugly: Conflicts: gstreamer0.10-lame but 0.10.18-0.1 is installed.
  gir1.2-json-1.0: Conflicts: gir1.2-json-glib-1.0 but 0.12.0-3 is installed.
  mint-meta-codecs: Conflicts: gstreamer0.10-plugins-really-bad but 0.10.22-0.2 is to be installed.
  ntfs-3g: Conflicts: libntfs-3g75 but 1:2010.3.6-1 is installed.
           Conflicts: libntfs-3g804 but 1:2011.1.15AR.4+2011.4.12-2 is installed.
The following actions will resolve these dependencies:

      Remove the following packages:                           
1)      foomatic-db-engine                                     
2)      foomatic-filters-ppds                                 
3)      gir1.2-json-glib-1.0                                   
4)      gstreamer0.10-lame                                     
5)      gstreamer0.10-plugins-really-bad                       
6)      ntfs-3g                                               

      Leave the following dependencies unresolved:             
7)      foomatic-db recommends foomatic-db-engine             
8)      foomatic-filters recommends foomatic-db-engine (>= 4.0)
9)      udisks recommends ntfs-3g                             
10)     udisks recommends ntfsprogs                           


Accept this solution? [Y/n/q/?]

It has been I while since I have been on debian but I am required to have debian for my laptop to work for some reason. :(
afzalarsalan
Level 1
Level 1
 
Posts: 3
Joined: Thu Jun 24, 2010 2:07 am

Linux Mint is funded by ads and donations.
 

Re: Fresh install, updated repos, foomatic being held back

Postby zerozero on Mon Feb 20, 2012 9:17 pm

can i give you an advice? use apt, is not so drastic and in this situation you will want simple solutions, first because foomatic-db-engine really has unmet deps (so there's no point in trying to find alternate scenarios to install it and in the way break something else- as i see in that output), second because gstreamer0.10-plugins-bad has a conflict with really-bad viewtopic.php?f=185&t=82346
zerozero
Level 16
Level 16
 
Posts: 6470
Joined: Tue Jul 07, 2009 2:29 pm

Re: Fresh install, updated repos, foomatic being held back

Postby afzalarsalan on Tue Feb 21, 2012 12:11 am

But what about libntfs? Is it safe to remove as apt-get suggests?
Code: Select all
The following packages will be REMOVED:
  gir1.2-json-glib-1.0 gstreamer0.10-lame gstreamer0.10-plugins-really-bad
  libntfs-3g75 libntfs-3g804

Is it true that mint-meta-codecs is replacing gstreamer really bad as it says in the aptitude output. Does gstreamer ugly replace gstreamer lame?
So many questions. :?
afzalarsalan
Level 1
Level 1
 
Posts: 3
Joined: Thu Jun 24, 2010 2:07 am

Re: Fresh install, updated repos, foomatic being held back

Postby zerozero on Tue Feb 21, 2012 10:39 am

afzalarsalan wrote:So many questions. :?

:lol: yeahh one of the issues with UP's is that: you get a bunch of updates at once and all the issues at the same time, let's see if i can explain this (it's not easy because some goes as far as last july/august and my memory :P )
gstreamer-bad really-bad and lame

mint-meta-codecs is just a meta-pkg, useful to install a set of software but once its job done it's basically useless (well not really, if in the future the mint team decides to add new features to the release, these meta-pkg are one way to easily give give those new features to the already installed systems); but in here i think aptitude is seeing it wrong, mint-meta-codecs is not to be removed, is just caught in the gstreamer mess and once that one sorted out, it will be fine.

if you feel like reading a bit (and getting some answers for those questions) here and here are the original topics when UP3 came out (lots of useful info in there)
zerozero
Level 16
Level 16
 
Posts: 6470
Joined: Tue Jul 07, 2009 2:29 pm

Re: Fresh install, updated repos, foomatic being held back

Postby afzalarsalan on Tue Feb 21, 2012 9:17 pm

Okay I did the dist-upgrade, but now I get this result:
Code: Select all
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  mint-meta-codecs mint-meta-debian
The following NEW packages will be installed:
  gstreamer0.10-plugins-really-bad
0 upgraded, 1 newly installed, 2 to remove and 1 not upgraded.
Need to get 690 kB of archives.
After this operation, 897 kB of additional disk space will be used.
Do you want to continue [Y/n]? n
Abort.


I skimed through the forum you linked and it said that gstreamer-lame is now intergrated in gstreamer-ugly.
Is it safe to remove the meta packages since they are virtually simlinks?
afzalarsalan
Level 1
Level 1
 
Posts: 3
Joined: Thu Jun 24, 2010 2:07 am

Re: Fresh install, updated repos, foomatic being held back

Postby zerozero on Wed Feb 22, 2012 3:09 pm

i would say "yes", you already have the functionalities they provided anyway.
zerozero
Level 16
Level 16
 
Posts: 6470
Joined: Tue Jul 07, 2009 2:29 pm

Re: Fresh install, updated repos, foomatic being held back

Postby rdonnelly on Fri Feb 24, 2012 8:34 pm

I had to do a search, download foomatic.deb from a download site, and install it after the update. You pretty much have a choice of Cups with no foomatic support for GDI printers, or foomatic with no Cups.
The OS: Linux Mint Debian 64 KDE Plasma 4.10.5
The Hardware: Dell 17R Special Edition, Intel Quad Core, i7 - 3.40 GHz, 8 GB Ram, HD 1TB
Video NVIDIA GeForce GT 650M 2GB
The Name: Bob
User avatar
rdonnelly
Level 4
Level 4
 
Posts: 409
Joined: Thu Nov 27, 2008 9:38 pm

Linux Mint is funded by ads and donations.
 

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 4 guests