gdm3 and synaptics touchpad modified after update.

Post your update and upgrade related errors here
Forum rules
Before you post please read this

gdm3 and synaptics touchpad modified after update.

Postby fransje on Wed Feb 22, 2012 12:15 pm

Dear all,

While trying to install cmus, cdcd and some rhythmbox plugin my system decided that, on top of the installation of the libraries I didn't have, some system libraries needed updating. So far so good.

But to my dismay the upgrades also changed some LMDE settings... :evil: So now when I login, the sleek LM window theme has disappeared, to be replaced by a much uglier font and icon set (the background image didn't change).. Similarly, the amazing grey Linux Mint window decoration I used to have when opening Chromium has disappeared.. :x
So I have a feeling this points towards changes around gtk3? (I recall that during the update rhythmbox 0.12 was updated to 2.5, including some update of libgtk3-something.. And after that rhythmbox got all ugly too, so I downgraded back to 0.12)

In parallel, my synaptics touchpad settings have somehow changed, and I can't get it to work as I want (with two finger scrolling..)

I tried modifying the /usr/share/gdm/greeter-config/20_debian to see if that had an effect on my login window, but unfortunately it didnt... :-C
Similarly, I trying modifying the /usr/share/X11/xorg.conf.d/50-synaptics.conf file, but to no avail...

Would anybody know how I can retrieve my original Mint-X theme as well as my touchpad functionality?

Kind regards,

Francois.
fransje
Level 1
Level 1
 
Posts: 12
Joined: Tue Sep 20, 2011 8:23 am

Linux Mint is funded by ads and donations.
 

Re: gdm3 and synaptics touchpad modified after update.

Postby zerozero on Wed Feb 22, 2012 1:23 pm

hi,
can you show us the output of
Code: Select all
inxi -r

and
Code: Select all
cat /var/log/apt/history.log
this one look for the output that includes that cmus and cdcd install
zerozero
Level 16
Level 16
 
Posts: 6474
Joined: Tue Jul 07, 2009 2:29 pm

Re: gdm3 and synaptics touchpad modified after update.

Postby fransje on Wed Feb 22, 2012 1:43 pm

Thanks for you reply!

Let's see..
Code: Select all
inix -r
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://packages.linuxmint.com/ debian main upstream import
           deb http://ftp.debian.org/debian testing main contrib non-free
           deb http://security.debian.org/ testing/updates main contrib non-free
           deb http://www.debian-multimedia.org testing main non-free
           Active apt sources in file: /etc/apt/sources.list.d/google-chrome.list
           deb http://dl.google.com/linux/chrome/deb/ stable main


And, in /var/log/apt/history.log I could find, for cmus:
Code: Select all
Start-Date: 2012-02-21  12:23:56
Commandline: apt-get install cmus
Install: dnet-common:amd64 (2.57, automatic), libao-common:amd64 (1.1.0-1+b1, automatic), libtinfo5:amd64 (5.9-4, automatic), libroar1:amd64 (0.4-5, automatic), libdnet:amd64 (2.57, automatic), libjson0:amd64 (0.9-1, automatic), cmus:amd64 (2.4.3-1), libao4:amd64 (1.1.0-1+b1, automatic), cmus-plugin-ffmpeg:amd64 (2.4.3-1, automatic)
Upgrade: pulseaudio:amd64 (0.9.23-1, 1.0-4), pulseaudio-module-x11:amd64 (0.9.23-1, 1.0-4), pulseaudio-module-gconf:amd64 (0.9.23-1, 1.0-4), pulseaudio-esound-compat:amd64 (0.9.23-1, 1.0-4), libpulse-mainloop-glib0:amd64 (0.9.23-1, 1.0-4), libpulse0:amd64 (0.9.23-1, 1.0-4), pulseaudio-module-zeroconf:amd64 (0.9.23-1, 1.0-4), pulseaudio-utils:amd64 (0.9.23-1, 1.0-4)
Remove: libpulse-browse0:amd64 (0.9.23-1)
End-Date: 2012-02-21  12:24:39


for cdcd:
Code: Select all
Start-Date: 2012-02-21  12:30:40
Commandline: apt-get install cdcd
Install: cdcd:amd64 (0.6.6-13.1)
End-Date: 2012-02-21  12:30:46


And last but not least, for the rhythmbox plugin
Code: Select all
Start-Date: 2012-02-21  13:46:42
Commandline: apt-get install rhythmbox-plugins
Install: libgupnp-av-1.0-2:amd64 (0.10.1-2, automatic), libcogl5:amd64 (1.8.2-1, automatic), libjavascriptcoregtk-3.0-0:amd64 (1.6.1-5+b1, automatic), gir1.2-rb-3.0:amd64 (2.95-1, automatic), libcogl-pango0:amd64 (1.8.2-1, automatic), libdmapsharing-3.0-2:amd64 (2.9.14-1, automatic), rhythmbox-data:amd64 (2.95-1, automatic), accountsservice:amd64 (0.6.15-3, automatic), libgupnp-1.0-4:amd64 (0.18.1-2, automatic), gvfs-libs:amd64 (1.10.1-2, automatic), librhythmbox-core5:amd64 (2.95-1, automatic), gvfs-common:amd64 (1.10.1-2, automatic), libaccountsservice0:amd64 (0.6.15-3, automatic), gir1.2-soup-2.4:amd64 (2.34.3-1, automatic), gir1.2-gconf-2.0:amd64 (2.32.4-1, automatic), libgdata13:amd64 (0.10.1-2, automatic), libcluttergesture-0.0.2-0:amd64 (0.0.2.1-5, automatic), libcurl3-nss:amd64 (7.24.0-1, automatic), libclutter-imcontext-0.1-0:amd64 (0.1.4-2, automatic), gir1.2-gst-plugins-base-0.10:amd64 (0.10.35-1, automatic), libglib2.0-bin:amd64 (2.30.2-6, automatic), librest-0.7-0:amd64 (0.7.12-1, automatic), libmx-1.0-2:amd64 (1.4.1-1, automatic), grilo-plugins-0.1:amd64 (0.1.18-1+b1, automatic), zeitgeist-core:amd64 (0.8.2-1, automatic), krb5-locales:amd64 (1.10+dfsg~beta1-2, automatic), libclutter-gst-1.0-0:amd64 (1.4.6-1, automatic), gir1.2-webkit-3.0:amd64 (1.6.1-5+b1, automatic), libtracker-sparql-0.12-0:amd64 (0.12.9-1+b1, automatic), libgrilo-0.1-0:amd64 (0.1.18-1, automatic), libcogl-common:amd64 (1.8.2-1, automatic), liboauth0:amd64 (0.9.4-3+b1, automatic), libgssdp-1.0-3:amd64 (0.12.1-2, automatic), gir1.2-javascriptcoregtk-3.0:amd64 (1.6.1-5+b1, automatic), libclutter-gtk-1.0-0:amd64 (1.0.4-1, automatic), gvfs-daemons:amd64 (1.10.1-2, automatic)
Upgrade: libsmbclient:amd64 (3.5.11~dfsg-1, 3.6.3-1), libkrb5-3:amd64 (1.9.1+dfsg-1+b1, 1.10+dfsg~beta1-2), gvfs-backends:amd64 (1.6.4-4, 1.10.1-2), rhythmbox:amd64 (0.12.8-5+b1, 2.95-1), libwbclient0:amd64 (3.5.11~dfsg-1, 3.6.3-1), gvfs-bin:amd64 (1.6.4-4, 1.10.1-2), libwebkitgtk-3.0-0:amd64 (1.4.2-2, 1.6.1-5+b1), libglib2.0-0:amd64 (2.28.6-1, 2.30.2-6), libgtk-3-bin:amd64 (3.0.12-2, 3.2.3-1), libkrb5support0:amd64 (1.9.1+dfsg-1+b1, 1.10+dfsg~beta1-2), libgtk-3-0:amd64 (3.0.12-2, 3.2.3-1), libclutter-1.0-0:amd64 (1.6.16-1, 1.8.4-1), libgail-3-0:amd64 (3.0.12-2, 3.2.3-1), gdm3:amd64 (2.30.5-11, 3.0.4-4), gvfs:amd64 (1.6.4-4, 1.10.1-2), libgssapi-krb5-2:amd64 (1.9.1+dfsg-1+b1, 1.10+dfsg~beta1-2), rhythmbox-plugins:amd64 (0.12.8-5+b1, 2.95-1), libgtk-3-common:amd64 (3.0.12-2, 3.2.3-1)
Remove: samba:amd64 (3.5.11~dfsg-1)
End-Date: 2012-02-21  13:48:56
fransje
Level 1
Level 1
 
Posts: 12
Joined: Tue Sep 20, 2011 8:23 am

Re: gdm3 and synaptics touchpad modified after update.

Postby zerozero on Wed Feb 22, 2012 1:59 pm

well, it's easy :shock: you are tracking testing and those updates pulled in some (maybe not all) of the gnome3 updates.

- how long did you install lmde? were those the original sources.list or you chance them?
- how often do you update your system (with a dist-upgrade?)
- if you do a
Code: Select all
apt update && apt dist-upgrade
now what will be the output? (in doubt answer "n" and post it here in the forum)
zerozero
Level 16
Level 16
 
Posts: 6474
Joined: Tue Jul 07, 2009 2:29 pm

Re: gdm3 and synaptics touchpad modified after update.

Postby fransje on Wed Feb 22, 2012 2:13 pm

Mmm.. That's a good one..

Okay, here it comes ;-)
- I installed lmde somewhere around a year ago. And yes, those are the source.list I got with it at the time. (oooh, I forgot to say that I'm using the XFCE edition :roll: )
- I used to do a dist-upgrade quite regularly, up until about November. Afterwards I didn't have time to do an upgrade for some time. I considered dist-upgrading again somewhere in January, but the list of updates proposed was long and I didn't have time to check if I wasn't going to break something important, so I didn't do it..
- And doing:
Code: Select all
apt update && apt dist-upgrade

Returns the following -quite exhaustive- list:
Code: Select all
The following packages will be REMOVED:
  aptdaemon console-terminus deskbar-applet gnome-about libbrasero-media0 libepc-1.0-2 libepc-ui-1.0-2 libevince3 libgcr-3-0 libgnome-desktop-3-0
  libnautilus-extension1 libperl5.12 mint-meta-common mintinstall mintmenu nautilus-gksu python-aptdaemon python-gobject-cairo xchat
The following NEW packages will be installed:
  app-install-data autopoint cdrdao console-setup-linux crda dconf-service enchant firmware-libertas fonts-liberation fonts-opensymbol gettext
  gir1.2-clutter-gst-1.0 gir1.2-cogl-1.0 gir1.2-coglpango-1.0 gir1.2-evince-3.0 gir1.2-gconf-2.0 gir1.2-gnomebluetooth-1.0 gir1.2-gst-plugins-base-0.10
  gir1.2-gtkclutter-1.0 gir1.2-gtksource-3.0 gir1.2-javascriptcoregtk-3.0 gir1.2-rb-3.0 gir1.2-soup-2.4 gir1.2-sushi-1.0 gir1.2-totem-1.0
  gir1.2-totem-plparser-1.0 gir1.2-webkit-3.0 glib-networking-common glib-networking-services gnome-icon-theme-symbolic gnome-sushi gnome-sushi-common
  grilo-plugins-0.1 hplip hplip-data ibus-qt4 intltool-debian iw libao-common libao4 libaudiofile1 libavahi-ui-gtk3-0 libbind9-80 libbison-dev
  libboost-iostreams1.48.0 libboost-regex1.48.0 libboost-signals1.48.0 libboost-system1.48.0 libboost-thread1.48.0 libbrasero-media3-1 libcamel-1.2-29
  libclutter-gst-1.0-0 libclutter-gtk-1.0-0 libclutter-imcontext-0.1-0 libcluttergesture-0.0.2-0 libcurl3-nss libdconf0 libdmapsharing-3.0-2 libdns81
  libebook-1.2-12 libecal-1.2-10 libedataserver-1.2-15 libepc-1.0-3 libepc-ui-1.0-3 libescpr1 libevent-2.0-5 libevince3-3 libexo-helpers libexpat1-dev
  libgck-1-0 libgcr-3-1 libgcr-3-common libgdata13 libgdk-pixbuf2.0-common libgjs0b libgnome-bluetooth8 libgnome-desktop-3-2 libgnome-keyring-common
  libgnomekbd7 libgrilo-0.1-0 libgssdp-1.0-3 libgtksourceview-3.0-0 libgtksourceview-3.0-common libgupnp-1.0-4 libgupnp-av-1.0-2 libgupnp-igd-1.0-4
  libhunspell-1.3-0 libibus-qt1 libisc83 libisccc80 libisccfg82 libjavascriptcoregtk-1.0-0 libjim0debian2 libjs-jquery-ui liblwres80 liblzma5
  libmail-sendmail-perl libminiupnpc5 libmono-cairo4.0-cil libmono-corlib4.0-cil libmono-data-tds4.0-cil libmono-i18n-west4.0-cil libmono-i18n4.0-cil
  libmono-posix4.0-cil libmono-security4.0-cil libmono-sharpzip4.84-cil libmono-simd4.0-cil libmono-sqlite4.0-cil libmono-system-configuration4.0-cil
  libmono-system-core4.0-cil libmono-system-data4.0-cil libmono-system-drawing4.0-cil libmono-system-enterpriseservices4.0-cil libmono-system-security4.0-cil
  libmono-system-transactions4.0-cil libmono-system-web-applicationservices4.0-cil libmono-system-web-services4.0-cil libmono-system-web4.0-cil
  libmono-system-xml4.0-cil libmono-system4.0-cil libmono-web4.0-cil libmozjs185-1.0 libmozjs9d libmx-1.0-2 libnatpmp1 libnautilus-extension1a libnl-3-200
  libnl-genl-3-200 libnl-route-3-200 libnm-gtk-common libnm-gtk0 liboauth0 liboobs-1-5 libopenal-data libpackagekit-glib2-14 libperl5.14 libpython2.7
  librest-0.7-0 librhythmbox-core5 libsane-hpaio libsonic0 libsushi-1.0-0 libsys-hostname-long-perl libtinfo-dev libtotem0 libtracker-sparql-0.12-0
  libunique-3.0-0 libv8-3.6.6.14 libvpx1 libvte-2.90-common libx11-doc libyajl2 libyelp0 libzthread-2.3-2 linux-headers-3.2.0-1-amd64
  linux-headers-3.2.0-1-common linux-image-3.2.0-1-amd64 linux-kbuild-3.2 minissdpd mono-4.0-gac mscompress nautilus nautilus-data packagekit
  packagekit-backend-aptcc po-debconf printer-driver-all printer-driver-c2050 printer-driver-c2esp printer-driver-escpr printer-driver-foo2zjs
  printer-driver-gutenprint printer-driver-hpcups printer-driver-hpijs printer-driver-m2300w printer-driver-min12xxw printer-driver-pnm2ppa
  printer-driver-postscript-hp printer-driver-ptouch printer-driver-pxljr printer-driver-sag-gdi printer-driver-splix python-gi python-gi-cairo
  python-gobject-2 python-packagekit python-pycurl python-renderpm python-reportlab python-reportlab-accel python2.7-dev qdbus rhythmbox-data seahorse-daemon
  wireless-regdb xulrunner-9.0 yelp-xsl zeitgeist-core
The following packages have been kept back:
  xserver-xorg xserver-xorg-core xserver-xorg-input-evdev xserver-xorg-input-synaptics xserver-xorg-input-wacom xserver-xorg-video-apm xserver-xorg-video-ark
  xserver-xorg-video-ati xserver-xorg-video-chips xserver-xorg-video-cirrus xserver-xorg-video-fbdev xserver-xorg-video-i128 xserver-xorg-video-i740
  xserver-xorg-video-intel xserver-xorg-video-mach64 xserver-xorg-video-mga xserver-xorg-video-neomagic xserver-xorg-video-nouveau
  xserver-xorg-video-openchrome xserver-xorg-video-r128 xserver-xorg-video-radeon xserver-xorg-video-rendition xserver-xorg-video-s3
  xserver-xorg-video-s3virge xserver-xorg-video-savage xserver-xorg-video-siliconmotion xserver-xorg-video-sis xserver-xorg-video-sisusb
  xserver-xorg-video-tdfx xserver-xorg-video-trident xserver-xorg-video-tseng xserver-xorg-video-vesa xserver-xorg-video-vmware xserver-xorg-video-voodoo
The following packages will be upgraded:
  adduser alsa-utils apache2.2-bin aptitude aptitude-doc-en asymptote baobab bash bind9-host binutils binutils-dev bison bluez bluez-firmware brasero
  brasero-common bsdmainutils chromium chromium-inspector colord console-setup cpp-4.5 cpp-4.6 cron cups-driver-gutenprint cups-pk-helper curl
  dconf-gsettings-backend debian-installer-launcher debianutils dialog dmidecode dnsutils dselect emacsen-common eog espeak espeak-data evince evince-common
  exo-utils f-spot fancontrol feh file file-roller foomatic-db fotoxx g++-4.6 gcc-4.5 gcc-4.5-base gcc-4.6 gcc-4.6-base gcc-4.6-multilib gdebi gdebi-core
  gedit gedit-common gir1.2-clutter-1.0 gir1.2-freedesktop gir1.2-gdkpixbuf-2.0 gir1.2-glib-2.0 gir1.2-gtk-3.0 git git-core git-man glib-networking
  gnome-bluetooth gnome-desktop-data gnome-desktop3-data gnome-dictionary gnome-disk-utility gnome-keyring gnome-search-tool gnome-settings-daemon
  gnome-system-log gnome-system-tools gnome-terminal gnome-terminal-data gnome-user-share gnome-utils-common gstreamer0.10-ffmpeg gstreamer0.10-nice
  gstreamer0.10-plugins-bad gstreamer0.10-plugins-ugly gtk2-engines-pixbuf hpijs htop hugin hugin-data hugin-tools iceweasel initscripts insserv iso-codes
  kexec-tools keyboard-configuration klibc-utils less lib32asound2 lib32gcc1 lib32gomp1 lib32quadmath0 lib32stdc++6 lib32v4l-0 lib32z1
  libalgorithm-diff-xs-perl libapt-pkg-perl libarchive1 libart2.0-cil libasound2 libasound2-plugins libaudio2 libaudit0 libavahi1.0-cil libavc1394-0
  libbabl-0.0-0 libbluetooth3 libburn4 libc-bin libc-dev-bin libc6 libc6-dev libc6-dev-i386 libc6-i386 libcairo-perl libcdaudio1 libclutter-1.0-common
  libcolord1 libcroco3 libcryptui0a libcurl3 libcurl3-gnutls libdbus-glib1.0-cil libdbus1.0-cil libdecoration0 libdirac-decoder0 libdirac-encoder0 libdv4
  libenchant1c2a libepc-common libertas-firmware libesd0 libespeak1 libexif12 libexo-1-0 libflickrnet2.2-cil libgail-common libgail18 libgcc1 libgconf2.0-cil
  libgdict-1.0-6 libgdk-pixbuf2.0-0 libgdu-gtk0 libgegl-0.0-0 libgfortran3 libggi-target-x libggi2 libgirepository-1.0-1 libglade2.0-cil libglib-perl
  libglib2.0-cil libglib2.0-data libglibmm-2.4-1c2a libgmime-2.4-2 libgmime2.4-cil libgmp10 libgmpxx4ldbl libgnome-desktop-2-17 libgnome-keyring0
  libgnome-keyring1.0-cil libgnome-vfs2.0-cil libgnome2-canvas-perl libgnome2.24-cil libgomp1 libgpg-error0 libgpod-common libgpod4 libgstfarsight0.10-0
  libgtk2-perl libgtk2.0-0 libgtk2.0-bin libgtk2.0-cil libgtk2.0-common libgtkhtml3.14-19 libgtkmm-3.0-1 libgutenprint2 libhpmud0 libhtml-parser-perl
  libisofs6 libjbig2dec0 libjpeg-progs libjpeg8 libk5crypto3 libklibc liblist-moreutils-perl liblocale-gettext-perl liblouis-data libmad0 libmagic1 libmhash2
  libmission-control-plugins0 libmono-addins-gui0.2-cil libmono-addins0.2-cil libmono-cairo2.0-cil libmono-corlib2.0-cil libmono-data-tds2.0-cil
  libmono-i18n-west2.0-cil libmono-messaging2.0-cil libmono-posix2.0-cil libmono-security2.0-cil libmono-sharpzip2.84-cil libmono-simd2.0-cil
  libmono-sqlite2.0-cil libmono-system-data-linq2.0-cil libmono-system-data2.0-cil libmono-system-messaging2.0-cil libmono-system-web2.0-cil
  libmono-system2.0-cil libmono-wcf3.0-cil libmono2.0-cil libncurses5 libncurses5-dev libncursesw5 libndesk-dbus-glib1.0-cil libndesk-dbus1.0-cil
  libnet-dbus-perl libnet-ssleay-perl libnewt0.52 libnice10 libnotify0.4-cil libnspr4-0d libnuma1 libopenal1 libp11-kit0 libpam-gnome-keyring libpam-modules
  libpam-modules-bin libpam-runtime libpam0g libpango-perl libpano13-2 libpano13-bin libpcsclite1 libpeas-1.0-0 libpng12-0 libpolkit-agent-1-0
  libpolkit-backend-1-0 libpolkit-gobject-1-0 libpoppler-glib6 libpoppler-qt4-3 libpoppler13 libproxy0 libpurple0 libqt4-dbus libqt4-declarative
  libqt4-designer libqt4-dev libqt4-help libqt4-network libqt4-opengl libqt4-opengl-dev libqt4-qt3support libqt4-script libqt4-scripttools libqt4-sql
  libqt4-sql-mysql libqt4-sql-sqlite libqt4-svg libqt4-test libqt4-xml libqt4-xmlpatterns libqtcore4 libqtgui4 libquadmath0 libraptor2-0
  libreadline-gplv2-dev libreadline5 libreadline6 libreoffice-base-core libreoffice-calc libreoffice-core libreoffice-draw libreoffice-gnome libreoffice-gtk
  libreoffice-impress libreoffice-math libreoffice-writer librsvg2-2 librsvg2-common libsamplerate0 libschroedinger-1.0-0 libselinux1 libsensors4
  libsgutils2-2 libslang2 libslp1 libsnmp15 libsocket6-perl libstdc++6 libstdc++6-4.6-dev libtalloc2 libtext-charwidth-perl libtext-iconv-perl libthunarx-2-0
  libtumbler-1-0 libupower-glib1 libusbmuxd1 libuuid-perl libv4l-0 libv4lconvert0 libvcdinfo0 libvisual-0.4-0 libvisual-0.4-plugins libvte-2.90-9
  libvte-common libvte9 libwebkitgtk-1.0-0 libx11-6 libx11-dev libxcb-dri2-0 libxcb-randr0 libxcb-render0 libxcb-shape0 libxcb-shm0 libxcb-util0 libxcb-xv0
  libxcb1 libxcb1-dev libxerces2-java libxerces2-java-gcj libxml-parser-perl libxml2 libxml2-utils libzephyr4 linux-headers-2.6-amd64 linux-headers-amd64
  linux-image-2.6-amd64 linux-image-amd64 linux-libc-dev live-config live-config-doc live-config-sysvinit live-tools lm-sensors locales lsb-base lsb-release
  media-player-info mesa-utils min12xxw mono-2.0-gac mono-gac mono-runtime multiarch-support nautilus-open-terminal nautilus-sendto ncurses-bin
  network-manager network-manager-gnome obexd-client patch pcscd perl perl-base perl-modules perlmagick pidgin pidgin-data pnm2ppa policykit-1
  policykit-1-gnome poppler-utils psmisc python python-brlapi python-crypto python-cupshelpers python-dbus python-dev python-evolution python-fpconst
  python-gconf python-glade2 python-gnome2 python-gnomedesktop python-gnomekeyring python-gobject python-gst0.10 python-gtk2 python-libxml2 python-mako
  python-minimal python-numpy python-software-properties python-uno python-vte python-wnck python2.7 python2.7-minimal python3 python3-minimal python3.2
  python3.2-minimal pyxplot pyxplot-doc qt4-designer qt4-dev-tools qt4-linguist-tools qt4-qmake radeontool rhythmbox rhythmbox-plugins rxvt-unicode
  sabnzbdplus sabnzbdplus-theme-classic sabnzbdplus-theme-plush sabnzbdplus-theme-smpl samba-common samba-common-bin seahorse smbclient
  software-properties-gtk sudo system-config-printer system-config-printer-udev sysv-rc sysvinit sysvinit-utils tasksel tasksel-data telepathy-gabble
  telepathy-mission-control-5 texlive-base texmaker texmaker-data thunar thunar-data thunar-media-tags-plugin tomboy totem totem-common totem-mozilla
  totem-plugins transmission-common transmission-gtk ttf-liberation ttf-opensymbol tumbler tumbler-common udisks upower usb-modeswitch usb-modeswitch-data
  usbmuxd util-linux vim vim-common vim-runtime w3m whiptail wpasupplicant x11-common xdg-utils xfce4-panel xfce4-power-manager xfce4-power-manager-data
  xfce4-power-manager-plugins xfce4-screenshooter xfce4-settings xfce4-xkb-plugin xfdesktop4 xfdesktop4-data xkb-data xserver-xorg-input-all xz-utils yelp
  zlib1g zlib1g-dev
479 upgraded, 198 newly installed, 19 to remove and 34 not upgraded.
Need to get 622 MB/634 MB of archives.
After this operation, 249 MB of additional disk space will be used.
Do you want to continue [Y/n]? n
fransje
Level 1
Level 1
 
Posts: 12
Joined: Tue Sep 20, 2011 8:23 am

Re: gdm3 and synaptics touchpad modified after update.

Postby zerozero on Wed Feb 22, 2012 2:32 pm

yeahh, it's a too long time without DU, and with a distro like lmde that is crucial.

being in xfce most of the chances (GUI-wise specially) won't affect you, but there's some system maintenance that you have to do now in order to achieve a successful DU:
- i wouldn't care to much about the removals and installs (it's something we have to accept in testing), but those held back
Code: Select all
The following packages have been kept back:
  xserver-xorg xserver-xorg-core xserver-xorg-input-evdev xserver-xorg-input-synaptics xserver-xorg-input-wacom xserver-xorg-video-apm xserver-xorg-video-ark
  xserver-xorg-video-ati xserver-xorg-video-chips xserver-xorg-video-cirrus xserver-xorg-video-fbdev xserver-xorg-video-i128 xserver-xorg-video-i740
  xserver-xorg-video-intel xserver-xorg-video-mach64 xserver-xorg-video-mga xserver-xorg-video-neomagic xserver-xorg-video-nouveau
  xserver-xorg-video-openchrome xserver-xorg-video-r128 xserver-xorg-video-radeon xserver-xorg-video-rendition xserver-xorg-video-s3
  xserver-xorg-video-s3virge xserver-xorg-video-savage xserver-xorg-video-siliconmotion xserver-xorg-video-sis xserver-xorg-video-sisusb
  xserver-xorg-video-tdfx xserver-xorg-video-trident xserver-xorg-video-tseng xserver-xorg-video-vesa xserver-xorg-video-vmware xserver-xorg-video-voodoo
do worry me :shock: it's an old and well-known issue.
this topic might give some ideas how to deal with that viewtopic.php?f=201&t=94378

as for the touchpad, have you seen this http://www.linuxmint.com/rel_debian.php
zerozero
Level 16
Level 16
 
Posts: 6474
Joined: Tue Jul 07, 2009 2:29 pm

Re: gdm3 and synaptics touchpad modified after update.

Postby fransje on Wed Feb 22, 2012 3:48 pm

Yeah, I happened to stumble upon your posts this afternoon, so was somewhat aware of the holding-back issue..

So if I understand this correctly, the linuxmint source is holding back those packages waiting for improvements? And I could bypass them, and update them via debian, at the risk of losing the patched fonts..? You said in one of your posts that the debian fonts aren't that bad anymore.. But do you use chrome as your browser?

I also stumbled upon the LMDE known-issues, with the info on the synaptics pad, but it really doesn't seem to work as I want... I have:
Code: Select all
Section "InputClass"
    Identifier "touchpad catchall"
    Driver "synaptics"
    MatchIsTouchpad "on"
        Option "TapButton1" "0"
        Option "VertEdgeScroll" "0"
        Option  "VertTwoFingerScroll"   "1"
        Option  "HorizTwoFingerScroll"   "1"
EndSection

But my pad options are apparently being over-ridden somewhere, because it stays is "VertEdgeScroll" mode, albeit without "TapButton1" enabled (which was the standard option for the touchpad)..

Any ideas?
fransje
Level 1
Level 1
 
Posts: 12
Joined: Tue Sep 20, 2011 8:23 am

Re: gdm3 and synaptics touchpad modified after update.

Postby zerozero on Wed Feb 22, 2012 3:57 pm

i use FF, so probably i don't see that difference that much, in that link i gave you earlier Gene says that the rendering in chrome/ium is affected (and i take his word for it :wink: ) but you find also a workaround that apparently fixes the issue;

in the end of the day is a trade-off, you keep the font rendering and risk a xorg breakage or solve the xorg hold back and might loose some rendering quality :shock:

unfortunately about the touchpad i'm afraid i can't help you, first because i don't use xfce and second because i hate those things :lol: (even in the laptop i have a micro-mouse - guess i'm just too old-fashioned :P )
zerozero
Level 16
Level 16
 
Posts: 6474
Joined: Tue Jul 07, 2009 2:29 pm

Re: gdm3 and synaptics touchpad modified after update.

Postby fransje on Wed Feb 22, 2012 4:29 pm

Hahaha. Yeah.. I can understand the aversion for touchpads.. ;-)
Anyways, thanks for help! I'll try the total dist-upgrade, and see what happens. I'll hope for the best.

Did somebody else maybe encounter similar issues with a touchpad?

Kind regards,

Francois.
fransje
Level 1
Level 1
 
Posts: 12
Joined: Tue Sep 20, 2011 8:23 am

Re: gdm3 and synaptics touchpad modified after update.

Postby whirly on Wed Feb 22, 2012 5:03 pm

whirly
Level 2
Level 2
 
Posts: 68
Joined: Tue Jul 05, 2011 7:20 pm

Re: gdm3 and synaptics touchpad modified after update.

Postby whirly on Wed Feb 22, 2012 5:29 pm

seems a bit old though
it showed me a mouse i don't have, and an older nvideo card config than the one i have now
it should be system settings---hardware--mouse touchpad
but it's not clear to me what you have now and what you'll have if you upgrade
whirly
Level 2
Level 2
 
Posts: 68
Joined: Tue Jul 05, 2011 7:20 pm

Re: gdm3 and synaptics touchpad modified after update.

Postby fransje on Thu Feb 23, 2012 7:47 am

Mm.. Yes, it seems quite old.. They mention using /etc/X11/xorg.conf...

But I decided to do my global system update anyways, and now my synpatics touchpad is working as I want it too..

Unfortunately, now my gdm background is in some shade of blue, and I just cant seem to be able to change it the way I want. The weird thing is that my terminal (ROXTerm) also has the same background, while being configured to be transparent. So I would expect to see my desktop background in my terminal, but instead, I apparently have the gdm login background...
Does anybody know why this is happening and how I could change it? I already tried changing the /etc/gdm3/greeter.gconf-defaults file, but that didn't help..

And I also lost the star in my menu icon... But I think this might come from the replacement of the xfce mint-menu by the standard xfce menu..
fransje
Level 1
Level 1
 
Posts: 12
Joined: Tue Sep 20, 2011 8:23 am

Re: gdm3 and synaptics touchpad modified after update.

Postby whirly on Thu Feb 23, 2012 10:43 pm

try
sudo dpkg-reconfigure gdm3 after changing
whirly
Level 2
Level 2
 
Posts: 68
Joined: Tue Jul 05, 2011 7:20 pm

Re: gdm3 and synaptics touchpad modified after update.

Postby fransje on Mon Feb 27, 2012 1:26 pm

Mmm.. Yes, I also ran
Code: Select all
sudo dpkg-reconfigure gdm3

after my changes, but that didn't seem to change anything... :-(
fransje
Level 1
Level 1
 
Posts: 12
Joined: Tue Sep 20, 2011 8:23 am

Linux Mint is funded by ads and donations.
 

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 1 guest