Help with unresolvable dependencies

Post your update and upgrade related errors here
Forum rules
Before you post please read this

Help with unresolvable dependencies

Postby TheEighthDwarf on Tue Feb 28, 2012 2:05 am

I've run into one of those unresolvable dependency problems I'd only heard about in back alleys and taverns of ill repute, and I'd be grateful for any help.

I use LMDE x64. I'm trying to install an R library called Rattle, which is for data mining, which requires a few things, such as libgtk2.0-dev. So I try to install it and this happens:

Code: Select all
$ sudo apt-get install libgtk2.0-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgtk2.0-dev : Depends: libgdk-pixbuf2.0-dev (>= 2.21.0) but it is not going to be installed
                 Depends: libpango1.0-dev (>= 1.20) but it is not going to be installed
                 Depends: libcairo2-dev (>= 1.6.4-6.1) but it is not going to be installed
E: Broken packages


I'm getting more things like this, like when I tried to install the HP LaserJet thingamabob ("hplip" or whatever). Here's my sources.list contents:

Code: Select all
deb http://debian.linuxmint.com/latest/multimedia testing main non-free
deb http://debian.linuxmint.com/latest/security testing/updates main contrib non-free
deb http://debian.linuxmint.com/latest testing main contrib non-free
deb http://packages.linuxmint.com/ debian main upstream import backport
deb-src http://debian.linuxmint.com/latest/security testing/updates main contrib non-free
deb-src http://debian.linuxmint.com/latest testing main contrib non-free
deb-src http://packages.linuxmint.com/ debian main upstream import backport


Suggestions?

Thanks in advance!
TheEighthDwarf
Level 1
Level 1
 
Posts: 7
Joined: Sun Jul 03, 2011 8:18 pm

Linux Mint is funded by ads and donations.
 

Re: Help with unresolvable dependencies

Postby nomko on Tue Feb 28, 2012 3:01 am

As i understand it, the 3 files mentioned at the bottom are too old for the program you want to install.

libgdk-pixbuf2.0-dev => you need version 2.21.0
libpango1.0-dev => you need version 1.20
libcairo2-dev you need version 1.6.4-6.1

Libcairo2 can be found here: http://packages.debian.org/search?keywords=libcairo2
libgdk-pixbuf can be found here: http://packages.debian.org/search?suite=default&section=all&arch=any&searchon=names&keywords=libgdk
libpango can be found here: http://packages.debian.org/search?suite=default&section=all&arch=any&searchon=names&keywords=libpango

Make sure that you, beside the "standard" file, also installs the -dev fiule since this is the file specifically asked for.
User avatar
nomko
Level 9
Level 9
 
Posts: 2917
Joined: Sat Feb 25, 2012 7:28 pm
Location: The Hague, The Netherlands

Re: Help with unresolvable dependencies

Postby TheEighthDwarf on Tue Feb 28, 2012 3:17 am

nomko wrote:Libcairo2 can be found here: http://packages.debian.org/search?keywords=libcairo2
Make sure that you, beside the "standard" file, also installs the -dev fiule since this is the file specifically asked for.


Thanks for your answer.

So you recommend installing the older versions, replacing the newer ones I (think I) have?

If so, how do I do that? In Synaptic I don't see the older versions, and I'm not sure what to do with the versions on the page you linked.
TheEighthDwarf
Level 1
Level 1
 
Posts: 7
Joined: Sun Jul 03, 2011 8:18 pm

Re: Help with unresolvable dependencies

Postby nomko on Tue Feb 28, 2012 4:51 am

TheEighthDwarf wrote:So you recommend installing the older versions, replacing the newer ones I (think I) have?

Yes, replacing the old version with a newer version will solve your problem.

If so, how do I do that? In Synaptic I don't see the older versions, and I'm not sure what to do with the versions on the page you linked.

By updating the older version with a newer version, the older version will be overwritten by the new one.

Check these links:
http://forums.linuxmint.com/viewtopic.php?f=190&t=69114

http://packages.linuxmint.com/list.php?release=Debian here you can find the libcairo package.

There's also a bug report if this:
https://bugs.launchpad.net/linuxmint/+bug/750446
User avatar
nomko
Level 9
Level 9
 
Posts: 2917
Joined: Sat Feb 25, 2012 7:28 pm
Location: The Hague, The Netherlands

Re: Help with unresolvable dependencies

Postby zerozero on Tue Feb 28, 2012 7:47 am

you have 2 options:
- check the pin priority and level all to 700, do a DU and then the libcairo2-dev v. that you want should be installed;
- in synaptic, look for libcairo2-dev, menu, force version and in the dropdown menu choose the v. from testing;
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm

Re: Help with unresolvable dependencies

Postby Monsta on Tue Feb 28, 2012 7:58 am

Hmm, these errors look strange. Your sources.list looks like the usual Latest repos list (only the repos are listed in reverse order for some reason :D) - but where you try to install libgtk2.0-dev from? The same Latest repos or some other ones not mentioned in your message?

Did a quick install simulation (sudo apt-get -s install libgtk2.0-dev) on my system, saw no such problems with versions...
(LMDE x64, tracking Latest, Update Pack 3, neither libgtk2.0-dev nor other mentioned libs installed)
Monsta
Level 8
Level 8
 
Posts: 2497
Joined: Fri Aug 19, 2011 3:46 am

Re: Help with unresolvable dependencies

Postby zerozero on Tue Feb 28, 2012 9:19 pm

i just tried now (ok, in incoming, not latest, so may not show much) and no problems at all as well
Code: Select all
amadeu@zerozero:~$ sudo apt-get install libgtk2.0-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  libatk1.0-dev libcairo-script-interpreter2 libcairo2-dev libexpat1-dev
  libfontconfig1-dev libfreetype6-dev libgdk-pixbuf2.0-dev libglib2.0-dev
  libice-dev libpango1.0-dev libpixman-1-dev libpng12-dev libsm-dev
  libxcb-render0-dev libxcb-shm0-dev libxcomposite-dev libxcursor-dev
  libxdamage-dev libxfixes-dev libxft-dev libxi-dev libxinerama-dev
  libxrandr-dev libxrender-dev x11proto-composite-dev x11proto-damage-dev
  x11proto-fixes-dev x11proto-randr-dev x11proto-render-dev
  x11proto-xinerama-dev zlib1g-dev
Suggested packages:
  libcairo2-doc libglib2.0-doc libgtk2.0-doc libpango1.0-doc
The following NEW packages will be installed:
  libatk1.0-dev libcairo-script-interpreter2 libcairo2-dev libexpat1-dev
  libfontconfig1-dev libfreetype6-dev libgdk-pixbuf2.0-dev libglib2.0-dev
  libgtk2.0-dev libice-dev libpango1.0-dev libpixman-1-dev libpng12-dev
  libsm-dev libxcb-render0-dev libxcb-shm0-dev libxcomposite-dev
  libxcursor-dev libxdamage-dev libxfixes-dev libxft-dev libxi-dev
  libxinerama-dev libxrandr-dev libxrender-dev x11proto-composite-dev
  x11proto-damage-dev x11proto-fixes-dev x11proto-randr-dev
  x11proto-render-dev x11proto-xinerama-dev zlib1g-dev
0 upgraded, 32 newly installed, 0 to remove and 34 not upgraded.
Need to get 19.9 MB of archives.
After this operation, 54.9 MB of additional disk space will be used.
Do you want to continue [Y/n]?
what leads me to ask; is your system fully updated, to start with?
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm

Linux Mint is funded by ads and donations.
 

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 4 guests