Update problem with new install of LMDE

Post your update and upgrade related errors here
Forum rules
Before you post please read how to get help

Update problem with new install of LMDE

Postby Ashocka on Wed Mar 07, 2012 5:05 am

Hi

I have just installed LMDE (linuxmint-201109-gnome-dvd-64bit) on this machine http://pastebin.com/0htvcu7m

When running update manager it stops at with this problem

Code: Select all
    E: /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_amd64.deb: trying to overwrite '/usr/lib/gstreamer-0.10/libgstxvid.so', which is also in package gstreamer0.10-plugins-really-bad 0.10.22-0.1
     
     
    Extracting templates from packages: 100%
    Preconfiguring packages ...
    (Reading database ... 150481 files and directories currently installed.)
    Preparing to replace gstreamer0.10-plugins-bad 0.10.22-2 (using .../gstreamer0.10-plugins-bad_0.10.22-3_amd64.deb) ...
    Unpacking replacement gstreamer0.10-plugins-bad ...
    dpkg: error processing /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_amd64.deb (--unpack):
     trying to overwrite '/usr/lib/gstreamer-0.10/libgstxvid.so', which is also in package gstreamer0.10-plugins-really-bad 0.10.22-0.1
    configured to not write apport reports
                                          dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
    Errors were encountered while processing:
     /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_amd64.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    A package failed to install.  Trying to recover:


I have tried rebooting and running it again, etc, etc.

Can anyone provide advice on how to proceed?

Thanks
Geoff
Ashocka
Level 1
Level 1
 
Posts: 24
Joined: Wed Jun 30, 2010 4:48 pm

Linux Mint is funded by ads and donations.
 

Re: Update problem with new install of LMDE

Postby DataMan on Wed Mar 07, 2012 6:56 am

There is a well documented problem with the initial installation of the gstreamer libraries in LMDE.

1. Update the update manager
2. When the update manager loads the many updates, de-select the 2 gstreamer libraries.
3. Proceed with the massive update.
4. When the update manager re-loads updates at the completion of #3, you should see the 2 gstreamer updates. Go ahead and do your updates at that point.

Note : Before doing any of the above, insure that your repositories are pointed to the correct sources.list

http://forums.linuxmint.com/viewtopic.php?f=197&t=79533

Hope this helps.

-DataMan
Linux'd since 2005 Linux ID 422356 Ubuntu ID 15015
User avatar
DataMan
Level 6
Level 6
 
Posts: 1223
Joined: Thu Dec 04, 2008 6:47 am
Location: Carmel, Indiana USA at /var/www

Re: Update problem with new install of LMDE

Postby Ashocka on Wed Mar 07, 2012 9:10 am

Thanks very much

I'm trying to point them to the correct source using the Software Sources in the update manager but I am getting this

Code: Select all
Failed to fetch http://debian.linuxmint.com/latest/dists/testing/updates/main/binary-amd64/Packages  404  Not Found
Failed to fetch http://debian.linuxmint.com/latest/dists/testing/updates/contrib/binary-amd64/Packages  404  Not Found
Failed to fetch http://debian.linuxmint.com/latest/dists/testing/updates/non-free/binary-amd64/Packages  404  Not Found
Failed to fetch http://debian.linuxmint.com/latest/dists/multimedia/main/binary-amd64/Packages  404  Not Found
Failed to fetch http://debian.linuxmint.com/latest/dists/multimedia/contrib/binary-amd64/Packages  404  Not Found
Failed to fetch http://debian.linuxmint.com/latest/dists/multimedia/non-free/binary-amd64/Packages  404  Not Found
Failed to fetch http://debian.linuxmint.com/latest/dists/security/main/binary-amd64/Packages  404  Not Found
Failed to fetch http://debian.linuxmint.com/latest/dists/security/non-free/binary-amd64/Packages  404  Not Found
Some index files failed to download. They have been ignored, or old ones used instead.


I think the directory should be http://debian.linuxmint.com/latest/dists/testing/main/binary-amd64/
Ashocka
Level 1
Level 1
 
Posts: 24
Joined: Wed Jun 30, 2010 4:48 pm

Re: Update problem with new install of LMDE

Postby Ashocka on Fri Mar 09, 2012 1:26 am

Fixed everything. Thanks
Ashocka
Level 1
Level 1
 
Posts: 24
Joined: Wed Jun 30, 2010 4:48 pm


Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 8 guests