LMDE upgrade problem

Post your update and upgrade related errors here
Forum rules
Before you post please read how to get help

LMDE upgrade problem

Postby mcdave on Wed Mar 21, 2012 12:20 am

Hi- hope someone can advise me . . . . .quoted in full below, is this a problem ? If so, what can I do about it ?

trying to overwrite '/usr/lib/gstreamer-0.10/libgstxvid.so', which is also in package gstreamer0.10-plugins-really-bad 0.10.22-0.1
configured to not write apport reports
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
mcdave
Level 1
Level 1
 
Posts: 1
Joined: Wed Mar 21, 2012 12:14 am

Linux Mint is funded by ads and donations.
 

Re: LMDE upgrade problem

Postby lqua on Wed Mar 21, 2012 1:12 am

I get a similar error when I run Update Manager on a freshly installed version of LMDE 64-bit. The system update then aborts, so this error prevents me from having an up-to-date installation:

Code: Select all
E: /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_amd64.deb: trying to overwrite '/usr/lib/gstreamer-0.10/libgstxvid.so', which is also in package gstreamer0.10-plugins-really-bad 0.10.22-0.1
lqua
Level 1
Level 1
 
Posts: 9
Joined: Tue Mar 20, 2012 3:28 am

Re: LMDE upgrade problem

Postby lqua on Wed Mar 21, 2012 1:25 am

Here's a copy-and-paste of LMDE's failed attempt to update my system:

Code: Select all
Extracting templates from packages: 100%
Preconfiguring packages ...
(Reading database ... 138047 files and directories currently installed.)
Preparing to replace gstreamer0.10-plugins-bad 0.10.22-2 (using .../gstreamer0.10-plugins-bad_0.10.22-3_amd64.deb) ...
Unpacking replacement gstreamer0.10-plugins-bad ...
dpkg: error processing /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/gstreamer-0.10/libgstxvid.so', which is also in package gstreamer0.10-plugins-really-bad 0.10.22-0.1
configured to not write apport reports
                                      dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install.  Trying to recover:
lqua
Level 1
Level 1
 
Posts: 9
Joined: Tue Mar 20, 2012 3:28 am

Re: LMDE upgrade problem

Postby lqua on Wed Mar 21, 2012 1:28 am

FWIW, my /etc/apt/sources.list file looks like this:

Code: Select all
deb http://packages.linuxmint.com/ debian main upstream import
deb http://debian.linuxmint.com/latest testing main contrib non-free
deb-src http://debian.linuxmint.com/latest testing main contrib non-free
deb http://debian.linuxmint.com/latest/security testing/updates main contrib non-free
deb-src http://debian.linuxmint.com/latest/security testing/updates main contrib non-free
deb http://debian.linuxmint.com/latest/multimedia testing main non-free
lqua
Level 1
Level 1
 
Posts: 9
Joined: Tue Mar 20, 2012 3:28 am

Re: LMDE upgrade problem

Postby zerozero on Wed Mar 21, 2012 7:17 am

one of you are running a 32bit system and the other a 64bit, so:
Code: Select all
sudo dpkg -i --force-overwrite /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_amd64.deb

or
Code: Select all
sudo dpkg -i --force-overwrite /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_i386.deb
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6492
Joined: Tue Jul 07, 2009 2:29 pm

Re: LMDE upgrade problem

Postby lqua on Wed Mar 21, 2012 9:11 am

That fixed this problem for me, thanks.
lqua
Level 1
Level 1
 
Posts: 9
Joined: Tue Mar 20, 2012 3:28 am


Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 5 guests