Xscreensaver setup to default

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Xscreensaver setup to default

Postby enito on Sat May 05, 2012 12:22 am

Hi,

im trying to setup default xscreensaver, instead of mate-screensaver. How i can do this? i tryed to remove mate-screensaver but i get some dependecies can break my mate desktop,

apt-get remove mate-screensaver
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
mate-core mate-desktop-environment mate-screensaver

any tip? thx!
enito
Level 1
Level 1
 
Posts: 21
Joined: Thu Apr 26, 2012 9:55 am

Linux Mint is funded by ads and donations.
 

Re: Xscreensaver setup to default

Postby Danko8321 on Sat May 05, 2012 8:52 pm

Have you tried to simply install xcreensaver? It should eliminate all other screensavers and hopefully not pull out that nasty dependencies. Try to just install it via terminal and post back here what dependencies it wants to install and remove.
Cheer up! Things are getting worse at a slower rate.
User avatar
Danko8321
Level 4
Level 4
 
Posts: 209
Joined: Thu Sep 22, 2011 2:03 pm
Location: Colombia

Re: Xscreensaver setup to default

Postby enito on Sun May 06, 2012 8:36 pm

Hi

i installed xscreensaver, but still alive the mate-screensaver i cant kill. I removed from auto programs, and added xscreensaver --replace, but still mate screensaver :( any tip?

thx
enito
Level 1
Level 1
 
Posts: 21
Joined: Thu Apr 26, 2012 9:55 am

Re: Xscreensaver setup to default

Postby äxl on Mon May 07, 2012 4:17 am

But mate-screensaver shouldn't stand in the way of xscreensaver. Couldn't you just put the time of the former high and set up the latter with
Code: Select all
xscreensaver-demo

Strangely enough when I want to dist-upgrade it also wants to remove mate-core and mate-desktop-environment (and atril). So maybe this is not just mate-screensaver ...
Maybe you could show the output of
Code: Select all
apt update
apt dist-upgrade
My Linux history: Ubuntu 10.04 - 10.10 - LMDE 201109 - UP4 My sources.list/preferences

Computers is not science. And it's not magic - it's something in between.
User avatar
äxl
Level 5
Level 5
 
Posts: 524
Joined: Fri Apr 06, 2012 6:14 am
Location: Germany

Re: Xscreensaver setup to default

Postby enito on Mon May 07, 2012 9:58 am

Hi,

thx for reply here the results

apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
cinnamon compiz compiz-fusion-plugins-extra compiz-fusion-plugins-main compiz-gtk compizconfig-settings-manager gir1.2-muffin-3.0 gir1.2-sushi-1.0 gnome-sushi
libcogl5 libcompizconfig0 libmuffin0 libmx-1.0-2 libsushi-1.0-0 libupnp3 python-compizconfig simple-ccsm
The following NEW packages will be installed:
libmtdev1 libupnp6
The following packages will be upgraded:
compiz-core compiz-plugins coreutils gir1.2-clutter-1.0 libclutter-1.0-0 libclutter-gst-1.0-0 libclutter-gtk-1.0-0 libclutter-imcontext-0.1-0
libcluttergesture-0.0.2-0 libcogl-pango0 libjs-jquery-ui libkpathsea6 libmutter0 libxslt1.1 virtualbox-guest-dkms virtualbox-guest-utils virtualbox-guest-x11 vlc
vlc-nox vlc-plugin-notify vlc-plugin-pulse xnest xserver-common xserver-xorg-core xserver-xorg-input-evdev xserver-xorg-input-synaptics xserver-xorg-input-wacom
xserver-xorg-video-apm xserver-xorg-video-ark xserver-xorg-video-ati xserver-xorg-video-chips xserver-xorg-video-cirrus xserver-xorg-video-fbdev
xserver-xorg-video-i128 xserver-xorg-video-i740 xserver-xorg-video-intel xserver-xorg-video-mach64 xserver-xorg-video-mga xserver-xorg-video-neomagic
xserver-xorg-video-openchrome xserver-xorg-video-r128 xserver-xorg-video-radeon xserver-xorg-video-rendition xserver-xorg-video-s3 xserver-xorg-video-s3virge
xserver-xorg-video-savage xserver-xorg-video-siliconmotion xserver-xorg-video-sis xserver-xorg-video-sisusb xserver-xorg-video-tdfx xserver-xorg-video-trident
xserver-xorg-video-tseng xserver-xorg-video-vesa xserver-xorg-video-vmware xserver-xorg-video-voodoo xsltproc
56 upgraded, 2 newly installed, 17 to remove and 0 not upgraded.
Need to get 25.2 MB of archives.
After this operation, 33.5 MB disk space will be freed.

Not sure to do it, can get some breakeages of compiz and emerald... any clue?

with aptitude

aptitude dist-upgrade
The following NEW packages will be installed:
compiz-gnome{ab} libmtdev1{a} libupnp6{ab}
The following packages will be upgraded:
compiz compiz-core{b} compiz-plugins{b} coreutils gir1.2-clutter-1.0 libclutter-1.0-0{b} libclutter-gst-1.0-0 libclutter-gtk-1.0-0 libclutter-imcontext-0.1-0
libcluttergesture-0.0.2-0 libcogl-pango0{b} libjs-jquery-ui libkpathsea6 libmutter0 libxslt1.1 virtualbox-guest-dkms virtualbox-guest-utils virtualbox-guest-x11
vlc vlc-nox vlc-plugin-notify vlc-plugin-pulse xnest xserver-common xserver-xorg-core xserver-xorg-input-evdev xserver-xorg-input-synaptics
xserver-xorg-input-wacom xserver-xorg-video-apm xserver-xorg-video-ark xserver-xorg-video-ati xserver-xorg-video-chips xserver-xorg-video-cirrus
xserver-xorg-video-fbdev xserver-xorg-video-i128 xserver-xorg-video-i740 xserver-xorg-video-intel xserver-xorg-video-mach64 xserver-xorg-video-mga
xserver-xorg-video-neomagic xserver-xorg-video-openchrome xserver-xorg-video-r128 xserver-xorg-video-radeon xserver-xorg-video-rendition xserver-xorg-video-s3
xserver-xorg-video-s3virge xserver-xorg-video-savage xserver-xorg-video-siliconmotion xserver-xorg-video-sis xserver-xorg-video-sisusb xserver-xorg-video-tdfx
xserver-xorg-video-trident xserver-xorg-video-tseng xserver-xorg-video-vesa xserver-xorg-video-vmware xserver-xorg-video-voodoo xsltproc
The following packages are RECOMMENDED but will NOT be installed:
libclutter-1.0-common libgl1-mesa-dri
57 packages upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
Need to get 25.6 MB of archives. After unpacking 1,517 kB will be used.
The following packages have unmet dependencies:
libcogl-pango0 : Breaks: libcogl5 (< 1.10.0-1) but 1.8.2-1 is installed.
libcompizconfig0 : Depends: compiz-core-abiversion-20090619 which is a virtual package.
compiz-gtk : Depends: compiz-core (= 0.8.4-5.1) but 1:0.7.9+git20080918.shame-0 is to be installed.
compiz-fusion-plugins-extra : Depends: compiz-core-abiversion-20090619 which is a virtual package.
libupnp6 : Conflicts: libupnp3 but 1:1.6.6-5.1 is installed.
libclutter-1.0-0 : Breaks: libcogl5 but 1.8.2-1 is installed.
compiz-gnome : Depends: libgnome-desktop-2 (>= 2.22.0) which is a virtual package.
Depends: libmetacity0 (>= 1:2.22.0) which is a virtual package.
Conflicts: compiz-gtk but 0.8.4-5.1 is installed.
compiz-plugins : Conflicts: compiz-gtk but 0.8.4-5.1 is installed.
compiz-fusion-plugins-main : Depends: compiz-core-abiversion-20090619 which is a virtual package.
compiz-core : Conflicts: compiz-gtk but 0.8.4-5.1 is installed.
The following actions will resolve these dependencies:

Remove the following packages:
1) cinnamon
2) compiz
3) compiz-fusion-plugins-extra
4) compiz-fusion-plugins-main
5) compiz-gtk
6) compizconfig-settings-manager
7) gir1.2-muffin-3.0
8) gir1.2-sushi-1.0
9) gnome-sushi
10) libcogl5
11) libcompizconfig0
12) libmuffin0
13) libmx-1.0-2
14) libsushi-1.0-0
15) libupnp3
16) python-compizconfig
17) simple-ccsm

Keep the following packages at their current version:
18) compiz-gnome [Not Installed]

Leave the following dependencies unresolved:
19) nautilus recommends gnome-sushi
20) compiz-core recommends compiz-fusion-plugins-main
21) emerald recommends compiz
enito
Level 1
Level 1
 
Posts: 21
Joined: Thu Apr 26, 2012 9:55 am

Re: Xscreensaver setup to default

Postby Danko8321 on Tue May 08, 2012 4:39 am

enito wrote:Hi,

thx for reply here the results

apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
cinnamon compiz compiz-fusion-plugins-extra compiz-fusion-plugins-main compiz-gtk compizconfig-settings-manager gir1.2-muffin-3.0 gir1.2-sushi-1.0 gnome-sushi
libcogl5 libcompizconfig0 libmuffin0 libmx-1.0-2 libsushi-1.0-0 libupnp3 python-compizconfig simple-ccsm
The following NEW packages will be installed:
libmtdev1 libupnp6
The following packages will be upgraded:
compiz-core compiz-plugins coreutils gir1.2-clutter-1.0 libclutter-1.0-0 libclutter-gst-1.0-0 libclutter-gtk-1.0-0 libclutter-imcontext-0.1-0
libcluttergesture-0.0.2-0 libcogl-pango0 libjs-jquery-ui libkpathsea6 libmutter0 libxslt1.1 virtualbox-guest-dkms virtualbox-guest-utils virtualbox-guest-x11 vlc
vlc-nox vlc-plugin-notify vlc-plugin-pulse xnest xserver-common xserver-xorg-core xserver-xorg-input-evdev xserver-xorg-input-synaptics xserver-xorg-input-wacom
xserver-xorg-video-apm xserver-xorg-video-ark xserver-xorg-video-ati xserver-xorg-video-chips xserver-xorg-video-cirrus xserver-xorg-video-fbdev
xserver-xorg-video-i128 xserver-xorg-video-i740 xserver-xorg-video-intel xserver-xorg-video-mach64 xserver-xorg-video-mga xserver-xorg-video-neomagic
xserver-xorg-video-openchrome xserver-xorg-video-r128 xserver-xorg-video-radeon xserver-xorg-video-rendition xserver-xorg-video-s3 xserver-xorg-video-s3virge
xserver-xorg-video-savage xserver-xorg-video-siliconmotion xserver-xorg-video-sis xserver-xorg-video-sisusb xserver-xorg-video-tdfx xserver-xorg-video-trident
xserver-xorg-video-tseng xserver-xorg-video-vesa xserver-xorg-video-vmware xserver-xorg-video-voodoo xsltproc
56 upgraded, 2 newly installed, 17 to remove and 0 not upgraded.
Need to get 25.2 MB of archives.
After this operation, 33.5 MB disk space will be freed.

Not sure to do it, can get some breakeages of compiz and emerald... any clue?

with aptitude

aptitude dist-upgrade
The following NEW packages will be installed:
compiz-gnome{ab} libmtdev1{a} libupnp6{ab}
The following packages will be upgraded:
compiz compiz-core{b} compiz-plugins{b} coreutils gir1.2-clutter-1.0 libclutter-1.0-0{b} libclutter-gst-1.0-0 libclutter-gtk-1.0-0 libclutter-imcontext-0.1-0
libcluttergesture-0.0.2-0 libcogl-pango0{b} libjs-jquery-ui libkpathsea6 libmutter0 libxslt1.1 virtualbox-guest-dkms virtualbox-guest-utils virtualbox-guest-x11
vlc vlc-nox vlc-plugin-notify vlc-plugin-pulse xnest xserver-common xserver-xorg-core xserver-xorg-input-evdev xserver-xorg-input-synaptics
xserver-xorg-input-wacom xserver-xorg-video-apm xserver-xorg-video-ark xserver-xorg-video-ati xserver-xorg-video-chips xserver-xorg-video-cirrus
xserver-xorg-video-fbdev xserver-xorg-video-i128 xserver-xorg-video-i740 xserver-xorg-video-intel xserver-xorg-video-mach64 xserver-xorg-video-mga
xserver-xorg-video-neomagic xserver-xorg-video-openchrome xserver-xorg-video-r128 xserver-xorg-video-radeon xserver-xorg-video-rendition xserver-xorg-video-s3
xserver-xorg-video-s3virge xserver-xorg-video-savage xserver-xorg-video-siliconmotion xserver-xorg-video-sis xserver-xorg-video-sisusb xserver-xorg-video-tdfx
xserver-xorg-video-trident xserver-xorg-video-tseng xserver-xorg-video-vesa xserver-xorg-video-vmware xserver-xorg-video-voodoo xsltproc
The following packages are RECOMMENDED but will NOT be installed:
libclutter-1.0-common libgl1-mesa-dri
57 packages upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
Need to get 25.6 MB of archives. After unpacking 1,517 kB will be used.
The following packages have unmet dependencies:
libcogl-pango0 : Breaks: libcogl5 (< 1.10.0-1) but 1.8.2-1 is installed.
libcompizconfig0 : Depends: compiz-core-abiversion-20090619 which is a virtual package.
compiz-gtk : Depends: compiz-core (= 0.8.4-5.1) but 1:0.7.9+git20080918.shame-0 is to be installed.
compiz-fusion-plugins-extra : Depends: compiz-core-abiversion-20090619 which is a virtual package.
libupnp6 : Conflicts: libupnp3 but 1:1.6.6-5.1 is installed.
libclutter-1.0-0 : Breaks: libcogl5 but 1.8.2-1 is installed.
compiz-gnome : Depends: libgnome-desktop-2 (>= 2.22.0) which is a virtual package.
Depends: libmetacity0 (>= 1:2.22.0) which is a virtual package.
Conflicts: compiz-gtk but 0.8.4-5.1 is installed.
compiz-plugins : Conflicts: compiz-gtk but 0.8.4-5.1 is installed.
compiz-fusion-plugins-main : Depends: compiz-core-abiversion-20090619 which is a virtual package.
compiz-core : Conflicts: compiz-gtk but 0.8.4-5.1 is installed.
The following actions will resolve these dependencies:

Remove the following packages:
1) cinnamon
2) compiz
3) compiz-fusion-plugins-extra
4) compiz-fusion-plugins-main
5) compiz-gtk
6) compizconfig-settings-manager
7) gir1.2-muffin-3.0
8) gir1.2-sushi-1.0
9) gnome-sushi
10) libcogl5
11) libcompizconfig0
12) libmuffin0
13) libmx-1.0-2
14) libsushi-1.0-0
15) libupnp3
16) python-compizconfig
17) simple-ccsm

Keep the following packages at their current version:
18) compiz-gnome [Not Installed]

Leave the following dependencies unresolved:
19) nautilus recommends gnome-sushi
20) compiz-core recommends compiz-fusion-plugins-main
21) emerald recommends compiz


That is freakishly weird. Could you please post back the result of this command?

Code: Select all
inxi -F


Also, what version of Mate are you running and how are you trying to install XScreenSaver (perhaps trough a crappy ppa?)?
Cheer up! Things are getting worse at a slower rate.
User avatar
Danko8321
Level 4
Level 4
 
Posts: 209
Joined: Thu Sep 22, 2011 2:03 pm
Location: Colombia

Re: Xscreensaver setup to default

Postby äxl on Tue May 08, 2012 4:48 am

Also
Code: Select all
inxi -r
My Linux history: Ubuntu 10.04 - 10.10 - LMDE 201109 - UP4 My sources.list/preferences

Computers is not science. And it's not magic - it's something in between.
User avatar
äxl
Level 5
Level 5
 
Posts: 524
Joined: Fri Apr 06, 2012 6:14 am
Location: Germany

Re: Xscreensaver setup to default

Postby xircon on Tue May 08, 2012 6:20 am

Just rename the mate screensaver and add xscreensaver to your autostart list.

Steve
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"
User avatar
xircon
Level 5
Level 5
 
Posts: 775
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: Xscreensaver setup to default

Postby Danko8321 on Tue May 08, 2012 7:33 am

äxl wrote:Also
Code: Select all
inxi -r


Good one! Didn't know you could do that with inxi; should keep that in mind instead of using "cat /etc/apt/sources.list"

Cheerio. Danko.
Cheer up! Things are getting worse at a slower rate.
User avatar
Danko8321
Level 4
Level 4
 
Posts: 209
Joined: Thu Sep 22, 2011 2:03 pm
Location: Colombia

Re: Xscreensaver setup to default

Postby äxl on Tue May 08, 2012 5:57 pm

Good would also be an option for /etc/apt/preferences (Apt-Pinning).
My Linux history: Ubuntu 10.04 - 10.10 - LMDE 201109 - UP4 My sources.list/preferences

Computers is not science. And it's not magic - it's something in between.
User avatar
äxl
Level 5
Level 5
 
Posts: 524
Joined: Fri Apr 06, 2012 6:14 am
Location: Germany

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 6 guests