<SOLVED> I can sign into MATE but not into Cinnamon anymore

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

<SOLVED> I can sign into MATE but not into Cinnamon anymore

Postby trebzgum on Thu Apr 19, 2012 12:24 am

Hello,
I have just installed LMDE 201204 RC 64bit and was able to sign into both Mate & Cinnamon until I installed the NVIDIA 295.20 driver following the directions from this post: viewtopic.php?f=191&t=82424. Now when I try to sign into Cinnamon the screen refreshes and takes back to sign in screen. I can only sign into Mate. Any help would be appreciated.
TIA
Last edited by trebzgum on Mon Apr 23, 2012 6:12 pm, edited 2 times in total.
trebzgum
Level 1
Level 1
 
Posts: 11
Joined: Tue Apr 17, 2012 6:35 pm

Linux Mint is funded by ads and donations.
 

Re: I can sign into MATE but not into Cinnamon anymore

Postby non-portable on Thu Apr 19, 2012 5:50 am

The obvious difference between Mate and Cinnamon is that Cinnamon requires working 3d graphics.

I have an nvidia card, and this is what I get from running 'inxi -G' in a terminal

Graphics: Card nVidia GF106 [Quadro 2000M] X.Org 1.11.4 Res: 1920x1080@50.0hz
GLX Renderer Quadro 2000M/PCIe/SSE2 GLX Version 4.2.0 NVIDIA 295.20

Note the GLX Version. If yours says mesa then you probably don't have nVidia glx installed or configured. I don't know which way you installed the nVidia drivers (that thread mentions several methods) but if you installed from the repos then:

update-alternatives --query glx

should at least show /usr/lib/nvidia as an alternative. If it does show nvidia as an alternative but the top 4 lines don't look like this

Link: glx
Status: manual
Best: /usr/lib/nvidia
Value: /usr/lib/nvidia

and instead show mesa, then

sudo update-alternatives --set glx /usr/lib/nvidia

should fix the problem.

Please note that there are many stages that this could have gone wrong and many potential solutions and this is only one that only works for the particular path I've mentioned. Sorry, I felt I had to put that in because I'm used to people reading "if x do y" and ignoring the "if x" bit. I'm sure you're not like that :)
non-portable
Level 1
Level 1
 
Posts: 27
Joined: Sun Mar 25, 2012 1:28 pm

Re: I can sign into MATE but not into Cinnamon anymore

Postby trebzgum on Thu Apr 19, 2012 4:11 pm

Hi non-portable,
These are the steps I followed for a newer card [GeForce 8400GS]:
1) apt install nvidia-kernel-dkms nvidia-glx build-essential nvidia-settings nvidia-xconfig
2)sudo nvidia-xconfig [this created an xconfig file, since it said I did not have one]
3)apt remove --purge xserver-xorg-video-nouveau libdrm-nouveau1a [removed nouveau, it did not let me blacklist it received errors]
4)rebooted

inxi -G gives me:
Graphics: Card nVidia G98 [GeForce 8400 GS] X.Org 1.11.4 Res: 1280x1024@50.0hz
GLX Renderer GeForce 8400 GS/PCIe/SSE2 GLX Version 3.3.0 NVIDIA 295.20

update-alternatives --query glx gives me:
Link: glx
Status: manual
Best: /usr/lib/nvidia
Value: /usr/lib/nvidia

Alternative: /usr/lib/mesa-diverted
Priority: 5
Slaves:
glx--libGL.so.1-x86_64-linux-gnu /usr/lib/mesa-diverted/x86_64-linux-gnu/libGL.so.1

Alternative: /usr/lib/nvidia
Priority: 100
Slaves:
glx--libGL.so.1-x86_64-linux-gnu /usr/lib/x86_64-linux-gnu/nvidia/libGL.so.1
glx--libXvMCNVIDIA.so.1-x86_64-linux-gnu /usr/lib/x86_64-linux-gnu/nvidia/libXvMCNVIDIA.so.1
glx--libXvMCNVIDIA_dynamic.so.1-x86_64-linux-gnu /usr/lib/x86_64-linux-gnu/nvidia/libXvMCNVIDIA_dynamic.so.1
glx--libnvidia-cfg.so.1-x86_64-linux-gnu /usr/lib/x86_64-linux-gnu/nvidia/libnvidia-cfg.so.1
glx--linux-libglx.so /usr/lib/nvidia/libglx.so
glx--nvidia-bug-report.sh /usr/lib/nvidia/nvidia-bug-report.sh
glx--nvidia_drv.so /usr/lib/nvidia/nvidia_drv.so
trebzgum
Level 1
Level 1
 
Posts: 11
Joined: Tue Apr 17, 2012 6:35 pm

Re: I can sign into MATE but not into Cinnamon anymore

Postby non-portable on Thu Apr 19, 2012 5:51 pm

That would seem to indicate that you have working video drivers/GL. It take it you can run glxgears and it functions fine. The next step would probably be to look at your ~/.xsession-errors file. This will often log the problem. To do that you need to log in to Cinnamon, allow it to fail. Then hit CTL+ALT+F2, log in as yourself and run

cp .xsession-errors xsession-errors-cinnamon

Sometimes an error won't show in .xsession-errors, so extra info could be obtained with

dmesg | tail -n 50 > dmesg.cinnamon

and

cp /var/log/Xorg.0.log ./Xorg.0.log.cinnamon

Then when you log in to MATE you'll have preserved the failed login info and hopefully see what's causing the problem. If the X server is borking, the info is likely to be in Xorg.0.log.cinnamon. It's probably more likely to be in xsession-errors-cinnamon, that's where I would start looking. dmesg.cinnamon has an outside chance of containing useful info.

Sorry that this is all about collecting info and nothing about fixing but I guess you have to figure out the problem to fix it. Feel free to attach the 3 files you generate, I'll happily look at them.
non-portable
Level 1
Level 1
 
Posts: 27
Joined: Sun Mar 25, 2012 1:28 pm

Re: I can sign into MATE but not into Cinnamon anymore

Postby trebzgum on Thu Apr 19, 2012 7:26 pm

Okay, I have the 3 files generated but when I try to attach them it says "the extensions txt is not allowed".
So I used pastebin, I hope that's ok?
dmesg.cinnamon: http://pastebin.com/embed_js.php?i=mVpzVN0b
Xorg.0.log.cinnamon: http://pastebin.com/embed_js.php?i=usQfNKUb
xsession-errors-cinnamon: http://pastebin.com/embed_js.php?i=C17UfbGW
trebzgum
Level 1
Level 1
 
Posts: 11
Joined: Tue Apr 17, 2012 6:35 pm

Re: I can sign into MATE but not into Cinnamon anymore

Postby non-portable on Thu Apr 19, 2012 8:18 pm

Your Xserver isn't complaining. The meat of this is in xsession-errors and there are loads of errors. Compiz window decorator crashed and that's shown in dmesg but I assume that's to do with when you were running MATE.

I'm not sure how many of the errors are normal for a Cinnamon session, so I'm going to check that on my computer now.

It does appear that Cinnamon is attempting to start over the top of another window manager but I guess it could be itself respawning all the time. The other alternative is that MATE and Cinnamon are not playing nicely together. You could quickly try removing MATE

sudo apt-get remove --purge mate-*

Then see if you can log in to Cinnamon. It would provide a quick check to see if MATE is the problem. One thing to note though is that if you can't log in via Cinnamon, you will need to reinstall MATE and if your network connection uses network manager then you must make sure you have local copies of the packages by running

sudo apt-get install --download-only mate-desktop-environment

That way if you can't log in with Cinnamon, you can CTL+ALT+F2, log in and type

sudo apt-get install mate-desktop-environment

and know it will work. I'll check to see what Cinnamon outputs on my computer now.

---

When I log in to Cinnamon, it works but I see a lot of the same errors you see.

Failed to connect to the VirtualBox kernel service
gnome-keyring-daemon: insufficient process capabilities, unsecure memory might get used
...
Gtk-Message: Failed to load module "canberra-gtk-module"
...
Window manager warning: Screen 0 on display ":0" already has a window manager; try using the --replace option to replace the current window manager.
gnome-session[17517]: WARNING: App \'cinnamon.desktop\' respawning too quickly
gnome-session[17517]: ******************* START ********************************
(etc)
gnome-session[17517]: ******************* END **********************************
(etc)


The canberra-gtk-module warning can be fixed by installing libcanberra-gtk-module. It's not the issue but it seemed to improve launch speeds for me.

Do you have Virtualbox in your autostart programs? Maybe even from UP3? Again, unlikely to be the problem.

The gnome-keyring-daemon and the fact that there's already a window manager running seem to be the problem. My bet is that a removal of MATE will sort it out. It's certainly worth an attempt. It may be that you will need to decide whether you want MATE or Cinnamon until these issues are resolved.

If that doesn't work out try logging in to Cinnamon again, then switch to another screen with CTL+ALT+F2 or whatever and

ps ax > processes-cinnamon

then log back in to MATE and check through the processes-cinnamon file and look for another window manager running or post it here again.
Last edited by non-portable on Thu Apr 19, 2012 8:45 pm, edited 1 time in total.
non-portable
Level 1
Level 1
 
Posts: 27
Joined: Sun Mar 25, 2012 1:28 pm

Re: I can sign into MATE but not into Cinnamon anymore

Postby trebzgum on Thu Apr 19, 2012 11:57 pm

Thanks for your help so far non-portable, I removed MATE but still could not log into Cinnamon, reinstalled and still no go. As far as Virtualbox at startup, no, it's not there and it's not even installed. The libcanberra-gtk-module is already installed though. Here's the processes-cinnamon:
http://pastebin.com/embed_js.php?i=GHXUzNdW

You mention compiz and now I remember the reason I installed the nvidia drivers is for compiz to work with 3D effects. When I installed the drivers I was logged into Cinnamon & I saw the compiz effects were not working so I searched how to activate and used the command: "compiz --replace" and added it to my startup applications, that's when I rebooted and could not log into Cinnamon, so I logged into mate and compiz was activated. I saw that it was using alot of CPU so I have disabled it since. Could that be the problem?
trebzgum
Level 1
Level 1
 
Posts: 11
Joined: Tue Apr 17, 2012 6:35 pm

Re: I can sign into MATE but not into Cinnamon anymore

Postby non-portable on Fri Apr 20, 2012 8:28 am

The ps output is from when you are back on the login screen, unfortunately. It needs to be done while the session is thrashing away before it gives up. I guess there might not be a lot of time to do that?
non-portable
Level 1
Level 1
 
Posts: 27
Joined: Sun Mar 25, 2012 1:28 pm

Re: I can sign into MATE but not into Cinnamon anymore

Postby trebzgum on Fri Apr 20, 2012 2:34 pm

You're right, not a lot of time is given. By the time I finish typing my pw at tty1 screen it takes me back to lmde log in screen. I doubt I would even have time to type in the "ps ax > processes-cinnamon" command. :(
trebzgum
Level 1
Level 1
 
Posts: 11
Joined: Tue Apr 17, 2012 6:35 pm

Re: I can sign into MATE but not into Cinnamon anymore

Postby äxl on Fri Apr 20, 2012 4:33 pm

How about putting it into ~/.profile or /etc/rc.local? And adding instead of pasting:
Code: Select all
ps aux >> processes-cinnamon
My Linux history: Ubuntu 10.04 - 10.10 - LMDE 201109 - UP4 My sources.list/preferences

Computers is not science. And it's not magic - it's something in between.
User avatar
äxl
Level 5
Level 5
 
Posts: 524
Joined: Fri Apr 06, 2012 6:14 am
Location: Germany

Re: I can sign into MATE but not into Cinnamon anymore

Postby trebzgum on Fri Apr 20, 2012 4:51 pm

äxl wrote:How about putting it into ~/.profile or /etc/rc.local? And adding instead of pasting:
Code: Select all
ps aux >> processes-cinnamon

That seemed to work, thanks äxl, here is the new processes-cinnamon:
http://pastebin.com/embed_js.php?i=vGf5i6si
trebzgum
Level 1
Level 1
 
Posts: 11
Joined: Tue Apr 17, 2012 6:35 pm

Re: I can sign into MATE but not into Cinnamon anymore

Postby äxl on Fri Apr 20, 2012 6:33 pm

Just adding to non-portable. No own ideas yet. :D
My Linux history: Ubuntu 10.04 - 10.10 - LMDE 201109 - UP4 My sources.list/preferences

Computers is not science. And it's not magic - it's something in between.
User avatar
äxl
Level 5
Level 5
 
Posts: 524
Joined: Fri Apr 06, 2012 6:14 am
Location: Germany

Re: I can sign into MATE but not into Cinnamon anymore

Postby zerozero on Fri Apr 20, 2012 7:08 pm

trebzgum wrote:You mention compiz and now I remember the reason I installed the nvidia drivers is for compiz to work with 3D effects. When I installed the drivers I was logged into Cinnamon & I saw the compiz effects were not working so I searched how to activate and used the command: "compiz --replace" and added it to my startup applications, that's when I rebooted and could not log into Cinnamon, so I logged into mate and compiz was activated. I saw that it was using alot of CPU so I have disabled it since. Could that be the problem?

this is most certainly the problem >> cinnamon (and for that matter gnome-shell) are incompatible with compiz.
added it to my startup applications

so I have disabled it since
^^how?
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm

Re: I can sign into MATE but not into Cinnamon anymore

Postby trebzgum on Sat Apr 21, 2012 4:20 pm

Zerozero, I enabled compiz by adding it to the "Startup Applications" with the following command "compiz --replace". I rebooted & could not sign in to Cinnamon, so I tried signing into Mate and compiz was enabled, but since compiz kept using too much CPU I disabled it from starting up in MATE under "Startup Applications".
trebzgum
Level 1
Level 1
 
Posts: 11
Joined: Tue Apr 17, 2012 6:35 pm

Re: I can sign into MATE but not into Cinnamon anymore

Postby zerozero on Sat Apr 21, 2012 7:05 pm

navigate to home/.config/autostart and see if you locate any compiz related desktop.file or you could while in mate "switch off" compiz using the fusion icon (i believe it's installed, if not sudo apt-get install fusion-icon.
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm

Re: I can sign into MATE but not into Cinnamon anymore

Postby cecar on Sat Apr 21, 2012 8:51 pm

I have exactly the same problem. Disable Compiz do not help for me.
cecar
Level 4
Level 4
 
Posts: 365
Joined: Tue Aug 24, 2010 2:47 am
Location: Stenungsund, Sweden

Re: I can sign into MATE but not into Cinnamon anymore

Postby trebzgum on Sat Apr 21, 2012 11:36 pm

zerozero wrote:navigate to home/.config/autostart and see if you locate any compiz related desktop.file or you could while in mate "switch off" compiz using the fusion icon (i believe it's installed, if not sudo apt-get install fusion-icon.

I double clicked the 'compiz.destop' file in my home folder to open it and it my screen refreshed & it turned on compiz, I'm sure it was off since I did not have wobbly windows. This may be a silly question but how do you shut it off under the compiz fusion icon? Is it under 'Select Window Manager' and choosing Metacity? If I select that my transparent docky menu background turns black. So I just log out since I have it to not to load at start up. Here's the contents of the compiz.desktop file:

[Desktop Entry]
Type=Application
Exec=compiz --replace
Hidden=false
X-MATE-Autostart-enabled=false
Name[en_US]=compiz
Name=compiz
Comment[en_US]=compiz
Comment=compiz
trebzgum
Level 1
Level 1
 
Posts: 11
Joined: Tue Apr 17, 2012 6:35 pm

Re: I can sign into MATE but not into Cinnamon anymore

Postby non-portable on Sun Apr 22, 2012 12:36 am

Did you check ~/.config/autostart ?

grep compiz ~/.config/autostart/*

just in case the .desktop file isn't called compiz.

Mate shouldn't need anything in there to start Compiz when you log in. In gnome2 it was simply a gconf setting (/desktop/gnome/applications/window_manager/default), so I assume Mate is very similar. Maybe someone with Mate installed will post the setting.

I'm sorry I missed the info you put in the last post I responded to, luckily there are brilliant people here who don't miss stuff :)

Cecar,

Maybe you have a very different problem with the same result?
non-portable
Level 1
Level 1
 
Posts: 27
Joined: Sun Mar 25, 2012 1:28 pm

Re: I can sign into MATE but not into Cinnamon anymore

Postby trebzgum on Sun Apr 22, 2012 12:59 am

Did you check ~/.config/autostart ?

yes, I opened the file in pluma and posted the result in my last post

grep compiz ~/.config/autostart/*

gives me:
me@me ~ $ grep compiz ~/.config/autostart/*
/home/me/.config/autostart/compiz.desktop:Exec=compiz --replace
/home/me/.config/autostart/compiz.desktop:Name[en_US]=compiz
/home/me/.config/autostart/compiz.desktop:Name=compiz
/home/me/.config/autostart/compiz.desktop:Comment[en_US]=compiz
/home/me/.config/autostart/compiz.desktop:Comment=compiz

If I delete the compiz selection from my Startup Applications will it delete 'compiz.desktop'? Right now I have it unchecked.
trebzgum
Level 1
Level 1
 
Posts: 11
Joined: Tue Apr 17, 2012 6:35 pm

Re: I can sign into MATE but not into Cinnamon anymore

Postby zerozero on Sun Apr 22, 2012 7:03 am

If I delete the compiz selection from my Startup Applications will it delete 'compiz.desktop'? Right now I have it unchecked.
i'm not sure, the positive way of doing it is deleting the compiz.desktop.

you can also try (as you did) turn to metacity in fusion-icon and then login into cinnamon (probably it will works, dunno)

what i know is that regarding compiz, you have to decide: either you use mate (and can use compiz at will > for the high cpu usage there's a few tricks, äxl knows it better than me :) ) or you use cinnamon/gnome-shell (and stay as far as you can from anything compiz-related)
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm

Linux Mint is funded by ads and donations.
 
Next

Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 5 guests