Firefox and Thunderbird 12

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Re: Firefox and Thunderbird 12

Postby gothmog123 on Mon May 07, 2012 2:41 pm

Can you install it?

"Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
iceweasel : Depends: xulrunner-12.0 (>= 12.0-4) but it is not going to be installed
E: Broken packages"
running LMDE MATE 201204
gothmog123
Level 1
Level 1
 
Posts: 28
Joined: Tue Apr 26, 2011 12:59 pm

Linux Mint is funded by ads and donations.
 

Re: Firefox and Thunderbird 12

Postby zerozero on Mon May 07, 2012 2:57 pm

i would have to boot into that system to try it;
in the meantime
Code: Select all
apt install xulrunner-12.0
tell you what (let's try to go down to the source of the problem)
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6480
Joined: Tue Jul 07, 2009 2:29 pm

Re: Firefox and Thunderbird 12

Postby gothmog123 on Mon May 07, 2012 3:00 pm

The following packages have unmet dependencies:
xulrunner-12.0 : Depends: libfontconfig1 (>= 2.9.0) but 2.8.0-2.1ubuntu3 is to be installed
E: Broken packages
running LMDE MATE 201204
gothmog123
Level 1
Level 1
 
Posts: 28
Joined: Tue Apr 26, 2011 12:59 pm

Re: Firefox and Thunderbird 12

Postby craigevil on Mon May 07, 2012 3:05 pm

Code: Select all
# apt-get install -t experimental iceweasel
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  libmozjs12d xulrunner-12.0
Suggested packages:
  ttf-lyx latex-xft-fonts xfonts-mathml ttf-mathematica4.1 mozplugger libgnomeui-0
The following NEW packages will be installed:
  libmozjs12d xulrunner-12.0
The following packages will be upgraded:
  iceweasel
1 upgraded, 2 newly installed, 0 to remove and 60 not upgraded.
Need to get 16.8 MB of archives.
After this operation, 31.3 MB of additional disk space will be used.


Install with no problems here, but I am on sid not LMDE.


$ apt-cache policy iceweasel
iceweasel:
Installed: 12.0-4
Candidate: 12.0-4
Version table:
*** 12.0-4 0
1 http://ftp.us.debian.org/debian/ experimental/main i386 Packages
100 /var/lib/dpkg/status
10.0.4esr-2 0
500 http://ftp.us.debian.org/debian/ unstable/main i386 Packages


$ apt-cache policy libfontconfig1
libfontconfig1:
Installed: 2.9.0-3
Candidate: 2.9.0-3
Version table:
*** 2.9.0-3 0
500 http://ftp.us.debian.org/debian/ unstable/main i386 Packages
100 /var/lib/dpkg/status
Debian Sid KDE4.8.4 Kernel 3.4 Thinkpad R40 CPU Pentium M 1.3MHz RAM 2GB ATI Mobility 7500
Debian - "If you can't apt-get something, it isn't useful or doesn't exist"
Giant Debian sources.list | Debian upgrade script smxi | sysinfo script inxi
craigevil
Level 5
Level 5
 
Posts: 559
Joined: Wed Sep 15, 2010 6:10 am
Location: down the rabbit hole

Re: Firefox and Thunderbird 12

Postby zerozero on Mon May 07, 2012 3:08 pm

ahh, you have 2 quick ways of solving the problem:
1- disable temporary the linuxmint repo in the sources.list file (put a # before it), save the file and update and then try to install iceweasel (for sure this time it will without errors)
2- open synaptic, look for libfontconfig1, and now in the menu > package > force version > in the popup window choose 2.9.0 and install it; after that iceweasel should also install without errors.
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6480
Joined: Tue Jul 07, 2009 2:29 pm

Re: Firefox and Thunderbird 12

Postby gothmog123 on Mon May 07, 2012 3:22 pm

No those methods don't work because libfontconfig1 2.9 is not in the testing repos. I think mozilla.debian.net just screwed up bigtime. Maybe someone should send them an email haha

http://packages.debian.org/search?keywo ... ection=all

it's -only- in unstable
running LMDE MATE 201204
gothmog123
Level 1
Level 1
 
Posts: 28
Joined: Tue Apr 26, 2011 12:59 pm

Re: Firefox and Thunderbird 12

Postby zerozero on Mon May 07, 2012 3:44 pm

yeahh, you're right, not even in testing it installs
Code: Select all
zerozero@debian:~$ sudo apt-get install -s -t experimental iceweasel
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 iceweasel : Depends: xulrunner-12.0 (>= 12.0-4) but it is not going to be installed
E: Broken packages
zerozero@debian:~$ sudo apt-get install -s -t experimental xulrunner-12.0Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 xulrunner-12.0 : Depends: libfontconfig1 (>= 2.9.0) but 2.8.0-3.1 is to be installed
E: Broken packages


Code: Select all
zerozero@debian:~$ apt-cache policy iceweasel libfontconfig1
libfontconfig1:
  Installed: 2.8.0-3.1
  Candidate: 2.8.0-3.1
  Version table:
 *** 2.8.0-3.1 0
        500 http://ftp.debian.org/debian/ testing/main amd64 Packages
        100 /var/lib/dpkg/status
iceweasel:
  Installed: 10.0.4esr-2
  Candidate: 10.0.4esr-2
  Version table:
     12.0-4 0
          1 http://ftp.debian.org/debian/ experimental/main amd64 Packages
 *** 10.0.4esr-2 0
        500 http://ftp.debian.org/debian/ testing/main amd64 Packages
        100 /var/lib/dpkg/status

Code: Select all
zerozero@debian:~$ inxi -r
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://ftp.debian.org/debian testing main contrib non-free
           deb http://security.debian.org/ testing/updates main contrib non-free
           deb http://www.debian-multimedia.org testing main non-free
           deb-src http://ftp.debian.org/debian testing main contrib non-free
           deb-src http://security.debian.org/ testing/updates main contrib non-free
           deb-src http://www.debian-multimedia.org testing main non-free
           deb http://ftp.debian.org/debian experimental main
           deb-src http://ftp.debian.org/debian experimental main
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6480
Joined: Tue Jul 07, 2009 2:29 pm

Re: Firefox and Thunderbird 12

Postby iLobster on Fri May 18, 2012 3:42 am

There is something strange with this damn packet. It has been breaking my mind for two weeks at least.
According to debian site libfontconfig1 2.9.0 IS in testing AND sid.
But there is only 2.8.0-3 in synaptic (LMDE + testing).
Solve this situation by direct downloading libfontconfig1 and its dependencies from debian testing repo.
After its installatoin also discovered, that gnome 3.4 packets were held somehow because of libfontconfig1 too.

Now there is a trouble with libclutter...
iLobster
Level 2
Level 2
 
Posts: 69
Joined: Fri Jul 08, 2011 9:07 am

Linux Mint is funded by ads and donations.
 
Previous

Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 2 guests