set LMDE default session to mate

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

set LMDE default session to mate

Postby pratsriv on Wed Apr 25, 2012 3:59 pm

Hi,

I like Mate I would like it to be my default environment. I gave the command:
Code: Select all
sudo /usr/lib/x86_64-linux-gnu/lightdm/lightdm-set-defaults -s mate-session

It returned no output (probably succeeded). But when I login with default xsession option, gnome3 shows-up again.

contents of /etc/lightdm/lightdm.conf
Code: Select all
[SeatDefaults]
xserver-allow-tcp=false
greeter-hide-users=true
user-session=mate-session
session-wrapper=/etc/X11/Xsession
autologin-user=myusername
autologin-user-timeout=0


contents of ~/.xsession-errors : http://pastebin.com/0w2rKkKG

what am I missing?
pratsriv
Level 1
Level 1
 
Posts: 4
Joined: Wed Apr 25, 2012 3:49 pm

Linux Mint is funded by ads and donations.
 

Re: set LMDE default session to mate

Postby xenopeek on Wed Apr 25, 2012 5:03 pm

Moved here by moderator. Reason: LMDE.
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14983
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: set LMDE default session to mate

Postby pratsriv on Fri Apr 27, 2012 10:15 pm

further info:

uname:
Linux prateek-mint 2.6.39-2-amd64 #1 SMP Tue Jul 5 02:51:22 UTC 2011 x86_64 GNU/Linux
pratsriv
Level 1
Level 1
 
Posts: 4
Joined: Wed Apr 25, 2012 3:49 pm

Re: set LMDE default session to mate

Postby äxl on Mon Apr 30, 2012 6:50 pm

Why are you using LightDM? Aren't GDM or MDM good enough?
I'm using GDM3 and I don't have to set my default session. It's just using the selection from last time.
My Linux history: Ubuntu 10.04 - 10.10 - LMDE 201109 - UP4 My sources.list/preferences

Computers is not science. And it's not magic - it's something in between.
User avatar
äxl
Level 5
Level 5
 
Posts: 524
Joined: Fri Apr 06, 2012 6:14 am
Location: Germany

Re: set LMDE default session to mate

Postby pratsriv on Tue May 01, 2012 12:48 am

Thank you for the response, had been desperately waiting for it.
Well, mine is slightly old computer and I thought LightDM would not slow it down.
Also, the reference I used to install Mate used LightDM, I just followed it.
If GDM/MDM is not resource hungry, I can go for it right away.
Only trouble being: I do not know how to switch to GDM/MDM.
Appreciate any help I can get. Thank you!
pratsriv
Level 1
Level 1
 
Posts: 4
Joined: Wed Apr 25, 2012 3:49 pm

Re: set LMDE default session to mate

Postby pratsriv on Tue May 01, 2012 2:03 am

found the solution to install MDM on another post in the forum.
Thank you. MDM is awesome!
I did get some errors as below, but the system is still functional:

Setting up mdm (1.0.0) ...
dpkg: error processing mdm (--configure):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
mdm
pratsriv
Level 1
Level 1
 
Posts: 4
Joined: Wed Apr 25, 2012 3:49 pm

Re: set LMDE default session to mate

Postby rjha94 on Tue May 22, 2012 3:12 pm

Please check /usr/share/xsessions folder, on my box (LMDE)

Code: Select all
rjha@mint /etc/lightdm $ ls -l /usr/share/xsessions/
total 28
-rw-r--r-- 1 root root  152 Mar 20 18:21 cinnamon.desktop
-rw-r--r-- 1 root root   86 Feb 19 21:30 lightdm-xsession.desktop
-rw-r--r-- 1 root root 6376 Mar  1 02:46 mate.desktop
-rw-r--r-- 1 root root 9715 Apr 20 00:39 ssh.desktop

So the session name should be "mate" and not "mate-session"

Also, you should be aware that auto-login sessions will override the user-sessions. I can see that you have set auto-login to true.
rjha94
Level 1
Level 1
 
Posts: 3
Joined: Sun May 20, 2012 7:59 am

Re: set LMDE default session to mate

Postby BrunoMiranda on Wed May 30, 2012 11:59 am

Hi,

I like Mate I would like it to be my default environment. I gave the command:

Code: Select all
sudo /usr/lib/x86_64-linux-gnu/lightdm/lightdm-set-defaults -s mate-session


It returned no output (probably succeeded). But when I login with default xsession option, gnome3 shows-up again.

contents of /etc/lightdm/lightdm.conf

Code: Select all
[SeatDefaults]
xserver-allow-tcp=false
greeter-hide-users=true
user-session=mate-session
session-wrapper=/etc/X11/Xsession
autologin-user=myusername
autologin-user-timeout=0



:roll: This works on Mint 12 LXDE :D
You have really helped me on this one...
Thanks!
BrunoMiranda
Level 2
Level 2
 
Posts: 92
Joined: Thu Jun 24, 2010 2:22 pm

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 10 guests