[Unresolved but Dropped] LMDE - Disable fast user switching.

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

[Unresolved but Dropped] LMDE - Disable fast user switching.

Postby Trapper on Sat May 19, 2012 9:29 am

LMDE & MATE

I need to disable fast user switching for all users but still allow normal logout & login. I've disabled user switching in the desktop lockdown options in mateconf-editor and gconf-editor for all users and through the root account too but everyone can still switch users. Is there something else I need to do?

If disabling user switching is not possible then I need to find a way to automatically shut down a running popfile process during user switching and restart it again as the new user so the new user won't be utilizing the old user's database. I do shutdown popfile at logout through a shutdown entry in my /etc/mdm/PostSession/Default and popfile startup at login is controlled through the current user's Startup Applications prefs. I have no idea how I can accomplish the same thing with user switching. ???
Last edited by Trapper on Fri Sep 21, 2012 2:56 pm, edited 1 time in total.
Trapper
Level 3
Level 3
 
Posts: 185
Joined: Sat Dec 03, 2011 12:21 pm
Location: Sebring, Florida USA

Linux Mint is funded by ads and donations.
 

Re: LMDE - Disable fast user switching.

Postby äxl on Fri Jun 01, 2012 2:17 pm

http://unix.stackexchange.com/questions ... s-in-gnome

Code: Select all
mateconftool-2 -s -t bool /desktop/mate/lockdown/disable_user_switching true
My Linux history: Ubuntu 10.04 - 10.10 - LMDE 201109 - UP4 My sources.list/preferences

Computers is not science. And it's not magic - it's something in between.
User avatar
äxl
Level 5
Level 5
 
Posts: 524
Joined: Fri Apr 06, 2012 6:14 am
Location: Germany

Re: LMDE - Disable fast user switching.

Postby Trapper on Sat Jun 02, 2012 8:16 am

äxl wrote:http://unix.stackexchange.com/questions/3821/how-to-disable-multiple-logins-in-gnome

Code: Select all
mateconftool-2 -s -t bool /desktop/mate/lockdown/disable_user_switching true


Looks good and I thought I had finally found success but it doesn't prevent user switching. :(
Trapper
Level 3
Level 3
 
Posts: 185
Joined: Sat Dec 03, 2011 12:21 pm
Location: Sebring, Florida USA

Re: LMDE - Disable fast user switching.

Postby äxl on Sat Jun 02, 2012 9:39 am

http://en.wikipedia.org/wiki/Fast_user_switching
Maybe you can prevent MDM or the XServer to open another session/virtual terminal.
My Linux history: Ubuntu 10.04 - 10.10 - LMDE 201109 - UP4 My sources.list/preferences

Computers is not science. And it's not magic - it's something in between.
User avatar
äxl
Level 5
Level 5
 
Posts: 524
Joined: Fri Apr 06, 2012 6:14 am
Location: Germany


Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 7 guests