Enabling Compiz in Mate

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Enabling Compiz in Mate

Postby mark1mint on Fri Jun 01, 2012 3:00 am

Hi ,I'm trying Mint Debian mostly using the Mate desktop (Cinnamon is proving to be too buggy at the moment on my computer),I have the fglrx driver installed through synaptic,and Compiz plugins also installed,but no matter what effect I select in the Compiz control panel,I get nothing,no wobbly windows,no desktop expo,nothing .Clearly I must be missing something stupid,can you please point me in the right direction?
mark1mint
Level 3
Level 3
 
Posts: 128
Joined: Tue May 22, 2012 4:36 pm

Linux Mint is funded by ads and donations.
 

Re: Enabling Compiz in Mate

Postby Darcy on Fri Jun 01, 2012 3:50 am

try entering this in a Terminal Window, then try compiz.

Code: Select all
compiz --replace
CPU - AMD Phenom 9850 Quad 2.5 GHz
MB - ASUS M3N HT Deluxe
RAM - 8 GB DDR2 800MHz
GPU - Nvidia 9800 GT
OS - LMDE 64 bit
User avatar
Darcy
Level 2
Level 2
 
Posts: 60
Joined: Tue Dec 13, 2011 7:19 pm

Re: Enabling Compiz in Mate

Postby deviceguru on Mon Jun 04, 2012 2:33 pm

I tried that suggestion and, although it does enable compiz, CPU utilization immediately jumps to about 70 percent from less than 10 percent when compiz starts.
Linux user since 2000 ~ visit my blog at DeviceGuru.com
deviceguru
Level 1
Level 1
 
Posts: 17
Joined: Thu Oct 07, 2010 8:43 pm

Re: Enabling Compiz in Mate

Postby Nuts2u on Mon Jun 04, 2012 4:10 pm

Open a terminal and type the following command:

killall -9 marco

Then press the enter key. This will allow your cpu utilization to drop down quite a bit.
Silence is golden. Duct tape is silver. Welcome to Hell. Here's your copy of Windows.
Nuts2u
Level 1
Level 1
 
Posts: 7
Joined: Sun Nov 27, 2011 8:44 pm

Re: Enabling Compiz in Mate

Postby mark1mint on Mon Jun 04, 2012 6:47 pm

Darcy wrote:try entering this in a Terminal Window, then try compiz.

Code: Select all
compiz --replace

That half worked,as compiz was started as window manager,and its effects kinda worked,but the terminal got stuck on some operation while enabling plugins or something like that,and the new settings didn't stick:upon logging out and then back in,or rebooting,compiz was disabled again.
I kinda fixed it following this advice
in a terminal type “mateconf-editor”
When the editor opens:
Go to /desktop/mate/session/required_components/windowmanager and replace "marco" with "compiz".

from this tutorial http://community.linuxmint.com/tutorial/view/919
now things work reasonably well,apart from the fact that Alt+Tab and Ctrl+Alt+Tab no longer work:any ideas on how can I fix that? Hopefully is something silly that I am overlooking,like setting the correct key bindings or something.
mark1mint
Level 3
Level 3
 
Posts: 128
Joined: Tue May 22, 2012 4:36 pm

Re: Enabling Compiz in Mate

Postby Honest Mistake on Tue Jun 05, 2012 7:26 am

Check your Compiz settings - maybe Application Switcher plugin is turned off?
Honest Mistake
Level 1
Level 1
 
Posts: 46
Joined: Mon Mar 05, 2012 4:40 am

Re: Enabling Compiz in Mate

Postby mark1mint on Tue Jun 05, 2012 9:50 am

Honest Mistake wrote:Check your Compiz settings - maybe Application Switcher plugin is turned off?


Sure,it was turned off indeed :oops: thank you very much for the heads up.

But,in the meantime I've discovered that Compiz doesn't stick not even if it's specified as the default window manager with Configuration Editor,meaning I still have to call it with
Code: Select all
 compiz --replace
and still the terminal windows hangs on something like
Setting Update "active_plugins"
-any ideas on how to straighten this?
mark1mint
Level 3
Level 3
 
Posts: 128
Joined: Tue May 22, 2012 4:36 pm

Re: Enabling Compiz in Mate

Postby Honest Mistake on Tue Jun 05, 2012 1:20 pm

mark1mint wrote:But,in the meantime I've discovered that Compiz doesn't stick not even if it's specified as the default window manager with Configuration Editor,meaning I still have to call it with
Code: Select all
 compiz --replace
and still the terminal windows hangs on something like
Setting Update "active_plugins"
-any ideas on how to straighten this?

Unless I'm misunderstanding your post, I think I know what is wrong. Running "compiz --replace" in the terminal does not actually hang. The problem is that you should be running "compiz --replace &" to make the new process independent from the terminal. Without that the process continues to run in the terminal and will terminate when you close the terminal.

But if you want to run compiz at startup, you should just put "compiz --replace" in your startup applications. Changing the window manager setting to compiz in the mateconf-editor does not actually start compiz (don't ask me why) - it just makes sure that marco window manager doesn't start as well (marco doesn't play well with compiz).
Honest Mistake
Level 1
Level 1
 
Posts: 46
Joined: Mon Mar 05, 2012 4:40 am

Re: Enabling Compiz in Mate

Postby mark1mint on Thu Jun 07, 2012 6:12 pm

Once again,thanks a lot :) That did the trick,now Compiz is working and stays enabled as the preferred windows manager in Mate.
On a side note,I still think that either more detailed instructions on how to enable and run properly Compiz in Mint (when choosing the Mate desktop) should go in the release notes,or these tweaks should be more automated once one installs the Compiz plugins package from repository.
mark1mint
Level 3
Level 3
 
Posts: 128
Joined: Tue May 22, 2012 4:36 pm

Re: Enabling Compiz in Mate

Postby Zorba on Fri Oct 12, 2012 5:24 pm

For better results do the following:

1- Install "compizconfig-settings-manager" and "compiz-fusion-plugins-extra"

2- In terminal run "compiz --replace"

3- Go to Startup Applications click on add and in the name field write "compiz" and in the command field enter "compiz --replace"(without the punctuation) click on Add again then Close. This is to make compiz start automatically on next logins.

4- To stop that high CPU usage run in terminal “mateconf-editor”. When the editor opens go to /desktop/mate/session/required_components/windowmanager and replace "marco" with "compiz".

5- To change window decorations install gconf-editor then run it (In terminal run "gconf-editor"). Navigate to /apps/metacity/general/theme and set the value to your Metacity theme name. Mint’s default is Mint-X.

There you go!!!!!!
Image Image
User avatar
Zorba
Level 7
Level 7
 
Posts: 1980
Joined: Tue May 29, 2012 10:12 pm
Location: Tunisia

Re: Enabling Compiz in Mate

Postby Zorba on Tue May 14, 2013 9:48 am

In case you lose window decoration after installing another desktop environment, simply run:
Code: Select all
sudo apt-get install compiz-gnome


and
Code: Select all
gtk-window-decorator --replace&

That's it :D
Image Image
User avatar
Zorba
Level 7
Level 7
 
Posts: 1980
Joined: Tue May 29, 2012 10:12 pm
Location: Tunisia

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: ron_h and 6 guests