Mouse cursor disappears

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Mouse cursor disappears

Postby bennypr0fane on Sat Jun 02, 2012 6:15 pm

Hello,
I just installed LMDE with xfce on my desktop PC (Is there a way to specifiy my system in my profile?).
Everything works fine, except the mouse cursor keeps disappearing - it seems not during use, but if I leave the system idle for a few minutes.
How might I go about looking for the culprit of this problem?
It's a USB-mouse, and unplugging and replugging it doesn't help...
Thanks, Ben
Linux Mint Debian Edition (201303) with Cinnamon
on Acer TravelMate 8172Z /w Intel Pentium dual core U5400,
Intel HD Graphics
bennypr0fane
Level 1
Level 1
 
Posts: 25
Joined: Sat Jun 02, 2012 6:00 pm
Location: Vienna, Austria

Linux Mint is funded by ads and donations.
 

Re: Mouse cursor disappears

Postby zerozero on Sat Jun 02, 2012 6:31 pm

[moved here]
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6485
Joined: Tue Jul 07, 2009 2:29 pm

Re: Mouse cursor disappears

Postby Arlo James Barnes on Wed Jul 03, 2013 7:32 pm

I also have this problem. Not sure if switching monitors (I have a laptop with a broken screen, and usually get Internet at a library or school since my home access is erratic) or going to sleep (as when the lid is closed) triggers it, but disappearance of the cursor is consistent in the respect that it occurs most times the computer is on for a while, and is usually accompanied by disappearance of desktop icons (but not background), and the Panel. To my limited knowledge this indicates a glitch in X.

Due to the disappearance of said items, all I can do at that point is open a terminal by right-clicking on the desktop and selecting 'Open in Terminal' (while the cursor is invisible, it is still there as can be evidenced when I click 'control' and the little flashy thing appears (I enabled it in mouse settings)) and from there restart the system, which fixes it but interrupts what I am doing (I can see that programs are still running when I press alt-tab (and an interesting thing is that all running programs are shown there, whereas normally it would just be the ones in the current workspace), but they do not appear when I use alt-tab)...OR I can restart X using control-alt-backspace which presents me with the login prompt after it is done restarting X. This seems to close any open programs and is thus equivalent work-flow-wise to restarting the computer except that it does not actually restart it; all the above problems (panel, icons, etc) are fixed except that the cursor is still invisible.

Even telling me (and I suppose by extension bennypr0fane) what specifically to Google for would be very helpful.
And I second his question about whether system details can be included in a profile.

Thank you.

[Edit: forgot my system details. Running Nadia, not the DebIan version, with MATE. I am using a trackpad original to my laptop, a Compaq Presario F500.]
[Edit 2: Just read READ: How To Get Help! (which I should have read before posting, as it says in the little 'Forum rules' information box above the post submission form), specifically "Do not resurrect support topics older than 6 months, outdated information can cause issues with newer releases." Oops! Sorry. Please disregard this post.]
Arlo James Barnes
Level 1
Level 1
 
Posts: 1
Joined: Sat Feb 09, 2013 12:50 am


Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 2 guests