Cannot get Conky Lua themes to work

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Cannot get Conky Lua themes to work

Postby cmost on Sat Jun 16, 2012 9:02 am

Okay, I'm hitting a brick wall here. I'm running the latest LMDE fully up to date. I've installed Conky-all from the repositories and its dependencies. I cannot for the life of me get any of the fancy lua type conky scripts to display. I've followed numerous tutorials to the letter, but cannot figure this one out. I'd really love to get the 'Infinity' theme (here: http://gnome-look.org/content/show.php/Infinity?content=151516) or the 'conky grey' theme (here: http://gnome-look.org/content/show.php/conky_grey?content=137272) to work but all I get is a black (or sometimes white) box as shown in the screenshot. I have nvidia graphics and Cinnamon desktop. Any ideas?
Attachments
Screenshot_conky.jpg
Screenshot_conky.jpg (100.62 KiB) Viewed 2803 times
AMD Phenom II 64 X6 1090T Black Edition Hexa-Core
8 GB DDR2 RAM
nVidia GeForce GTX 660
Sabayon Linux - KDE 4.x
Linux Kernel 3.14
cmost
Level 4
Level 4
 
Posts: 398
Joined: Tue Sep 18, 2007 7:36 am
Location: Newport, Kentucky

Linux Mint is funded by ads and donations.
 

Re: Cannot get Conky Lua themes to work

Postby zerozero on Sat Jun 16, 2012 9:54 am

the conky you have on the right side of the screen is been called from where?
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6488
Joined: Tue Jul 07, 2009 2:29 pm

Re: Cannot get Conky Lua themes to work

Postby cmost on Sat Jun 16, 2012 12:00 pm

@zerozero

The Conky script I have on the right (it's just the clock) is called 'revolutionary clock'. The script is stored in ~/.Conky I call the script like this:

Code: Select all
/home/cmost/.Conky/revolutionary_clock/start_conky.sh


These were per the installation instructions. The start_conky.sh script essentially calls Conky with this command:

Code: Select all
conky -c $HOME/.Conky/revolutionary_clock/conkyrc


The revolutionary clock conky script is irrelevant in my opinion because I cannot call Lua conky scripts even if the clock conky script is disabled; it's ~/.Conky directory is deleted, etc. I don't think this script is interfering but perhaps you know something I don't know about conky. :-)
AMD Phenom II 64 X6 1090T Black Edition Hexa-Core
8 GB DDR2 RAM
nVidia GeForce GTX 660
Sabayon Linux - KDE 4.x
Linux Kernel 3.14
cmost
Level 4
Level 4
 
Posts: 398
Joined: Tue Sep 18, 2007 7:36 am
Location: Newport, Kentucky

Re: Cannot get Conky Lua themes to work

Postby zerozero on Sat Jun 16, 2012 12:57 pm

cmost,
it's been awhile since i hacked some conky (i try to avoid it because it's really addictive and i end up spending days on it :lol: ) but:
- you have in that shoot 3 instances of conky running: the revolutionary clock (on the top right), some other conky on the right just bellow the conky-clock (with 4 lua graphics) and the legacy conky script on the top left that afaik gets loaded if you don't have a home/ .conkyrc

- i usually never face this issue because always put my conky scripts in home, named as .conkyrc (or if and when i use more than one script .conkyrc1 and so on);
- then you can have the lua script(s) in a home/scripts folder (optional) and call the script from within conky;

this is a bit vague (sorry about that) but i'm typing from memory, later with lmde in from of me i can give you more precise instructions.
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6488
Joined: Tue Jul 07, 2009 2:29 pm

Re: Cannot get Conky Lua themes to work

Postby cmost on Sat Jun 16, 2012 2:11 pm

@ zerozero

Just to clarify, the items below the clock on the upper right are screenlets. Also to clarify, I've tried running Lua conky scripts WITHOUT the clock script or screenlets running, to no avail.
AMD Phenom II 64 X6 1090T Black Edition Hexa-Core
8 GB DDR2 RAM
nVidia GeForce GTX 660
Sabayon Linux - KDE 4.x
Linux Kernel 3.14
cmost
Level 4
Level 4
 
Posts: 398
Joined: Tue Sep 18, 2007 7:36 am
Location: Newport, Kentucky

Re: Cannot get Conky Lua themes to work

Postby zerozero on Sat Jun 16, 2012 2:49 pm

oh my bad :shock: they really looked like lua graphics to me.
seeing the instructions at gnome.org for conky_grey
install conky_grey
copy files
- conkyrc_grey
- conky_grey.lua
in ~/.conky/

did you follow all this?
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6488
Joined: Tue Jul 07, 2009 2:29 pm

Re: Cannot get Conky Lua themes to work

Postby cmost on Sat Jun 16, 2012 3:20 pm

I followed the instructions to the letter. I've followed several tutorials for different Lua conky scripts, just to be sure. They simply won't work on my system. I just don't know why.
AMD Phenom II 64 X6 1090T Black Edition Hexa-Core
8 GB DDR2 RAM
nVidia GeForce GTX 660
Sabayon Linux - KDE 4.x
Linux Kernel 3.14
cmost
Level 4
Level 4
 
Posts: 398
Joined: Tue Sep 18, 2007 7:36 am
Location: Newport, Kentucky

Re: Cannot get Conky Lua themes to work

Postby zerozero on Sat Jun 16, 2012 4:40 pm

cmost,
i got it to work
Image
but i'm using file manager doesn't handle the desktop, so there's one setting here that you have to tweak
Code: Select all
own_window_type desktop
works for me but won't work if you have nautilus handling the desktop.

regarding the rest:
1- disable all the other;
2- create a .conky folder in home where you put conky_grey.lua
3- move conky_grey to home and rename it .conkyrc
that should do it.
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6488
Joined: Tue Jul 07, 2009 2:29 pm

Re: Cannot get Conky Lua themes to work

Postby matfx on Thu Jul 26, 2012 7:53 am

Thanks zerozero, your little tweak does help to show up conky.
matfx
Level 1
Level 1
 
Posts: 6
Joined: Wed Oct 12, 2011 12:07 pm
Location: Malaysia

Re: Cannot get Conky Lua themes to work

Postby Sector11 on Sat Jul 28, 2012 8:36 am

I'm curious if this got solved or not.
#! pushed to Debian SID & OpenBox
Conky PitStop
Sector11
Level 1
Level 1
 
Posts: 43
Joined: Mon Nov 22, 2010 10:33 am

Re: Cannot get Conky Lua themes to work

Postby zerozero on Sat Jul 28, 2012 11:53 am

Sector11, it is solved for me but with the conditions mentioned in the my previous post.
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6488
Joined: Tue Jul 07, 2009 2:29 pm

Re: Cannot get Conky Lua themes to work

Postby cmost on Sat Jul 28, 2012 12:58 pm

I haven't marked this solved because disabling Nautilus control of the desktop makes all the icons disappear, which is a show stopper for me (I'm sure others too.) Ultimately, we would get to have Lua themes AND icons on the desktop.
AMD Phenom II 64 X6 1090T Black Edition Hexa-Core
8 GB DDR2 RAM
nVidia GeForce GTX 660
Sabayon Linux - KDE 4.x
Linux Kernel 3.14
cmost
Level 4
Level 4
 
Posts: 398
Joined: Tue Sep 18, 2007 7:36 am
Location: Newport, Kentucky

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 5 guests