cannot change icon theme in LMDE XFCE

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

cannot change icon theme in LMDE XFCE

Postby mmutoo on Mon Aug 13, 2012 10:32 pm

Hi everybody,
I am a new user of Linux, and I am enjoying using Mint flavors. Specifically, I have installed the xfce version and I am happy with it. Except I cannot change the icon theme! No matter how many times I go to settings manager and select the "nuoveXT.2.2" theme for the icons, they go back to a theme which I don't know what it is! Does anybody have a clue? I can give you more information if you tell me how (I am still not good with the terminal).

Many thanks.
mmutoo
Level 1
Level 1
 
Posts: 29
Joined: Mon Nov 07, 2011 8:30 pm

Linux Mint is funded by ads and donations.
 

Re: cannot change icon theme in LMDE XFCE

Postby widget on Tue Aug 14, 2012 8:19 pm

mmutoo wrote:Hi everybody,
I am a new user of Linux, and I am enjoying using Mint flavors. Specifically, I have installed the xfce version and I am happy with it. Except I cannot change the icon theme! No matter how many times I go to settings manager and select the "nuoveXT.2.2" theme for the icons, they go back to a theme which I don't know what it is! Does anybody have a clue? I can give you more information if you tell me how (I am still not good with the terminal).

Many thanks.

I think a little more info is needed here.

I just checked and there is no such icon theme in my default install of LMDE. So, how did you get it?

Is it in your /usr/share/icon directory?

Is it showing up in your Settings manager>Appearence tool? If not how are you choosing it?

I have LMDE Xfce installed on here. Not on it write now but it is on this box so I can check the buggers.
Dell XPS 420 Core2 Quad Q 6600, audigy5.1, Radeon HD 6450 - currently 4 320Gb HDD, Debian Squeeze for secure use, Debian testing for daily use, Debian Sid for fun.
widget
Level 3
Level 3
 
Posts: 167
Joined: Thu May 14, 2009 2:49 am
Location: S.E. Montana

Re: cannot change icon theme in LMDE XFCE

Postby mmutoo on Wed Aug 15, 2012 10:12 am

Thanks widget for the reply. Yes, it is in /usr/share/icons directory. If I remember correctly, I have installed it from synaptic. Also it might be helpful if you know that I have installed the LXDE desktop from synaptic as well. And yes, I can see it in Settings manager>Appearence, and I do choose it.
mmutoo
Level 1
Level 1
 
Posts: 29
Joined: Mon Nov 07, 2011 8:30 pm

Re: cannot change icon theme in LMDE XFCE

Postby widget on Wed Aug 15, 2012 2:21 pm

mmutoo wrote:Thanks widget for the reply. Yes, it is in /usr/share/icons directory. If I remember correctly, I have installed it from synaptic. Also it might be helpful if you know that I have installed the LXDE desktop from synaptic as well. And yes, I can see it in Settings manager>Appearence, and I do choose it.

I did a bit of research as I can't find such an icon set in my Debian testing repo anywhere.

I did find the Lxde standard icon theme. This is the discription from Synaptic;
Code: Select all
LXDE standard icon theme
 
LXDE-Icon-Theme is the standard icon theme for the Lightweight X11 Desktop
Environment (LXDE).

It is also known as the nuoveXT2 icon theme from which it is derived from.

So mounting my Sid install with Lxde on it I find the icon set. Opening Thunar as root I copy the icons from there to this Debian testing install that is my production OS.

Open Settings Manager and there it is. Click on it and it changes to that icon theme. Can't say it blows my skirt up but it works here.

Why doesn't it work in yours? This is the question. It must work if you log into a Lxde session.

I think I would create a ~/.icons directory in your /home. Copy that icon theme to that directory and change the permissions to your user (in /usr/share/icons it is owned by root)

If you use the file browser opened as root you can change it with the gui you get by right clicking on the stuff and changing it there. Probably a pain to do it that way. May change the permissions on the directory and not the stuff inside it. That is a lot of crap to change permissions on one at a time.

I would, as root;
Code: Select all
chown -R <user name> /home/<user name>/.icons/nuoveXT2

That should do it. Log out and back in or reboot and see what happens.

Sounds really strange that it does not work. I will copy the bugger over into my LMDE Xfce install and see if it will work there.

Need to get over there sometime today to do my update/upgrade cycle the LMDE recommended way. Not too hot on that myself but as long as it works as well as it has been I will continue recommend LMDE, particularly Xfce, to noobs.
Dell XPS 420 Core2 Quad Q 6600, audigy5.1, Radeon HD 6450 - currently 4 320Gb HDD, Debian Squeeze for secure use, Debian testing for daily use, Debian Sid for fun.
widget
Level 3
Level 3
 
Posts: 167
Joined: Thu May 14, 2009 2:49 am
Location: S.E. Montana

Re: cannot change icon theme in LMDE XFCE

Postby mmutoo on Wed Aug 15, 2012 8:20 pm

thanks widget. I tried what you suggested. Unfortunately, it did not work! I use pcmanfm in lxde and it did the change in owner automatically.
mmutoo
Level 1
Level 1
 
Posts: 29
Joined: Mon Nov 07, 2011 8:30 pm

Re: cannot change icon theme in LMDE XFCE

Postby widget on Thu Aug 16, 2012 10:50 pm

Well it was a possibility. Should actually work from your user directory.

Haven't been able to get over to LMDE, employment is nice but does interfer with your life.

Will have to really look at this. Makes no sense to me at all.
Dell XPS 420 Core2 Quad Q 6600, audigy5.1, Radeon HD 6450 - currently 4 320Gb HDD, Debian Squeeze for secure use, Debian testing for daily use, Debian Sid for fun.
widget
Level 3
Level 3
 
Posts: 167
Joined: Thu May 14, 2009 2:49 am
Location: S.E. Montana

Re: cannot change icon theme in LMDE XFCE

Postby widget on Sun Aug 19, 2012 11:44 pm

Sorry for the delay. Just too busy to get over here to LMDE Xfce. Got here tonight though.

Using the same source as before I got the icon set and dropped it in my icons directory. Logged out and back in.

Works fine.

The only thing I could think of was that I got that from the Sid repo. Checked the version number against what is available in the LMDE repo and it is the same version.

The only thing I can think of now is that there may be a minor glitch in your settings manager. Yup, grasping at straws.

You might, just to cover that base, run;
Code: Select all
sudo dpkg-reconfigure xfce4-settings

that is the package supplying the settings manager.

You could even try;
Code: Select all
sudo apt-get remove xfce4-settings

and
Code: Select all
sudo apt-get install xfce4-settings

I can't believe it is in the icon package itself as you say it works under lxde.

You have probably noticed my sig. You may want to do something similar. I have no idea what kind of hardware you are running.

As you can see I am running a 64 bit system. If you are running a 32bit install there may be a difference in results.
Dell XPS 420 Core2 Quad Q 6600, audigy5.1, Radeon HD 6450 - currently 4 320Gb HDD, Debian Squeeze for secure use, Debian testing for daily use, Debian Sid for fun.
widget
Level 3
Level 3
 
Posts: 167
Joined: Thu May 14, 2009 2:49 am
Location: S.E. Montana

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 5 guests