Cannot exit X when VGA monitor active [SOLVED]

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Cannot exit X when VGA monitor active [SOLVED]

Postby terdon on Sun Sep 16, 2012 10:28 am

I have a strange problem. If I connect an external VGA monitor to my laptop, exiting the X environment in any way crashes the computer.

For example, say I am working with my two monitors (the laptop's and one connected to my VGA port) active. Hitting Ctrl+Alt+F Key should take me down to a tty. What actually happens is that the VGA screen goes blank, as you would expect, but the laptop screen, although still on, shows nothing. I know the screen is on because it is slightly more illuminated than when it is off.

When in this state, I can do nothing to regain access to the machine. I have tried:

1. Ctrl+F Key (and even Ctrl+Alt+F Key, just in case) combinations and none seem to have any effect.

2. Ctrl+Alt+Del : Nothing

3.Magic SysRq key: Nothing

4. Blindly typing my username and password and trying to reboot/shutdown or restart GDM or MDM: Nothing

The only thing that works is a hard reset.

The exact same behavior occurs when killing the X server through Ctrl+Alt+Backspace, rebooting or shutdown. There is no difference if I reboot/shutdown/log out using the WM's graphical menu or if I use the "shutdown" or "reboot" commands.

It is also not WM-dependent. I have the same problem using Cinnamon, Gnome 3, MATE and xfce4.

It is, however, VGA dependent. I have tried connecting another VGA monitor and have the same problem. I do _not_, however, have this problem if a screen is connected to the DisplayPort. It is, therefore, a VGA specific issue.


To make things even stranger, this only occurs when both screens are active. If either the laptop screen or the VGA monitor is inactive the problem goes away.

Finally, this problem arose when I upgraded to the latest LMDE. It did not occur with the previous release of LMDE. I am not sure what has changed since I used the same kernel version in both releases (I had upgraded the kernel while on the previous release) and, I think, the same nvidia drivers. Oh, and yes, I have updated the nvidia driver.


Hardware:
Dell M4500 laptop
CPU: Intel Core i7
RAM: 8GB
Graphics: nVidia GT216 [Quadro FX 880M]


Software:
LMDE, kernel 3.2.0-2-amd64
Xorg: 1.11.4
nVidia kernel: 295.20-1+3.2.9-1

Possibly relevant files:
/var/log/Xorg.0.log
~/.xsession-errors


Does anyone have any ideas how to fix this? Thanks in advance for any help.
Last edited by terdon on Wed Sep 19, 2012 8:01 am, edited 1 time in total.
User avatar
terdon
Level 4
Level 4
 
Posts: 276
Joined: Tue Jan 13, 2009 2:52 pm
Location: Marseille

Linux Mint is funded by ads and donations.
 

Re: Cannot exit X (or restart/shutdown) when VGA monitor act

Postby terdon on Wed Sep 19, 2012 7:59 am

In case anyone else encounters this, LMDE Update Pack 5 came out yesterday. The problem was fixed when I updated my system. I don't know precisely which package was fixed but my current specs are:

LDME, kernel 3.2.0-3-amd64
Xorg: 1.12.1.902-1
nVidia kernel: 302.17+1+2+3.2.21-2

Oh, well, all's well that ends well. Marking as solved.
User avatar
terdon
Level 4
Level 4
 
Posts: 276
Joined: Tue Jan 13, 2009 2:52 pm
Location: Marseille


Return to Newbie Questions

Who is online

Users browsing this forum: erikandreassen and 3 guests