Upgrading a 2yr old LMDE ----> tricky, better don't

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Upgrading a 2yr old LMDE ----> tricky, better don't

Postby msbln on Sat Oct 19, 2013 8:22 am

Here's the problem:

I want to go from UP6 to UP7, about 1300 updates.
Mintupdates freezes, so I tried

sudo apt-get upgrade

Downloads a lot, but doesn't start installing,
message:

Code: Select all
N: Ignoring file 'playonlinux.list.save' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
N: Ignoring file 'playonlinux.list.save' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
E: »gnome-session-fallback« konnte nicht unmittelbar konfiguriert werden. Lesen Sie »man 5 apt.conf« unter APT::Immediate-Configure bezüglich weiterer Details. (2)


I believe point E is the problem. gnome-session-fallback couldn't be configured.
What does it mean and what could/should I do about it?

Thanks.
Last edited by msbln on Mon Oct 21, 2013 5:59 am, edited 2 times in total.
LMDE MATE
msbln
Level 2
Level 2
 
Posts: 54
Joined: Mon Jan 10, 2011 2:49 pm

Linux Mint is funded by ads and donations.
 

Re: Cannot update/upgrade

Postby Monsta on Sat Oct 19, 2013 8:36 am

msbln wrote:sudo apt-get upgrade

Read this thread carefully.
Monsta
Level 8
Level 8
 
Posts: 2414
Joined: Fri Aug 19, 2011 3:46 am

Re: Cannot update/upgrade

Postby msbln on Sat Oct 19, 2013 9:12 am

sudo apt-get dist-upgrade

leads to the same message
LMDE MATE
msbln
Level 2
Level 2
 
Posts: 54
Joined: Mon Jan 10, 2011 2:49 pm

Re: Cannot update/upgrade

Postby Monsta on Sat Oct 19, 2013 9:23 am

First, please post the output of
Code: Select all
inxi -Sr

Second, please run dist-upgrade with the default locale so the messages would be in English:
Code: Select all
LC_ALL=C sudo apt-get dist-upgrade
and post the output here.
Monsta
Level 8
Level 8
 
Posts: 2414
Joined: Fri Aug 19, 2011 3:46 am

Re: Cannot update/upgrade

Postby msbln on Sat Oct 19, 2013 9:40 am

I have to prepare you, I'm trying to update an old version of LMDE.
Maybe it is yet possible.

Code: Select all
$ inxi -Sr
System:    Host ibm Kernel 3.0.0-1-686-pae i686 (32 bit) Distro Linux Mint Debian Edition
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://packages.linuxmint.com/ debian main upstream import
           deb http://www.mirrorservice.org/sites/debian.linuxmint.com/debian/latest testing main contrib non-free
           deb http://www.mirrorservice.org/sites/debian.linuxmint.com/debian/latest/security testing/updates main contrib non-free
           deb http://www.mirrorservice.org/sites/debian.linuxmint.com/debian/latest/multimedia testing main non-free


Code: Select all
$ sudo apt-get dist-upgrade
...
E: Could not perform immediate configuration on 'gnome-session-fallback'. Please see man 5 apt.conf under APT::Immediate-Configure for details. (2)
LMDE MATE
msbln
Level 2
Level 2
 
Posts: 54
Joined: Mon Jan 10, 2011 2:49 pm

Re: Cannot update/upgrade

Postby Monsta on Sat Oct 19, 2013 9:59 am

msbln wrote:Kernel 3.0.0-1-686-pae

two years old :shock:

And how does that fit into this statement?
I want to go from UP6 to UP7, about 1300 updates.


Well, okay... try this:
Code: Select all
LC_ALL=C sudo apt-get dist-upgrade -o APT::Immediate-Configure=0
Last edited by Monsta on Sat Oct 19, 2013 10:02 am, edited 1 time in total.
Monsta
Level 8
Level 8
 
Posts: 2414
Joined: Fri Aug 19, 2011 3:46 am

Re: Cannot update/upgrade

Postby msbln on Sat Oct 19, 2013 10:01 am

Possibly the system cannot be updated.
I just tried this:

Code: Select all
$ sudo aptitude safe-upgrade
Löse Abhängigkeiten auf ...                   
offen: 186397; geschlossen: 279145; zurückgestellt: 170; Konflikte: 898       om
$


in English (my translation):

Resolving dependencies...
open: 186397; closed: 279145; unclear: 170; conflicts: 898

Doesn't look good, does it?
LMDE MATE
msbln
Level 2
Level 2
 
Posts: 54
Joined: Mon Jan 10, 2011 2:49 pm

Re: Cannot update/upgrade

Postby Monsta on Sat Oct 19, 2013 10:39 am

Well, then scrap it and reinstall from the latest ISO, if you don't want to try my suggestions :)
Monsta
Level 8
Level 8
 
Posts: 2414
Joined: Fri Aug 19, 2011 3:46 am

Re: Cannot update/upgrade

Postby msbln on Sat Oct 19, 2013 10:43 am

I do want to try your suggestion.
I'm running now
Code: Select all
LC_ALL=C sudo apt-get dist-upgrade -o APT::Immediate-Configure=0

I keep you informed about what happens.
LMDE MATE
msbln
Level 2
Level 2
 
Posts: 54
Joined: Mon Jan 10, 2011 2:49 pm

Re: Cannot update/upgrade

Postby msbln on Sat Oct 19, 2013 10:50 am

And how does that fit into this statement?
"I want to go from UP6 to UP7, about 1300 updates."


That's what mintupdate told me. But before starting to pull in,
mintupdate always freezed.
LMDE MATE
msbln
Level 2
Level 2
 
Posts: 54
Joined: Mon Jan 10, 2011 2:49 pm

Re: Cannot update/upgrade

Postby msbln on Sun Oct 20, 2013 1:55 pm

After a lot of time upgrading (hours) the process stopped with the following message:

Errors were encountered while processing:
/var/cache/apt/archives/mint-themes-gtk3_3.8-1_all.deb
N: Ignoring file 'playonlinux.list.save' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
N: Ignoring file 'playonlinux.list.save' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
E: Sub-process /usr/bin/dpkg returned an error code (1)


Any idea how to proceed? The machine is running and I haven't restarted it yet.
LMDE MATE
msbln
Level 2
Level 2
 
Posts: 54
Joined: Mon Jan 10, 2011 2:49 pm

Re: Cannot update/upgrade

Postby Monsta on Sun Oct 20, 2013 2:21 pm

No ideas - I don't know what errors "were encountered". You probably skipped some messages before it.

You can try to resume the process with
Code: Select all
sudo dpkg --configure -a
and/or
Code: Select all
sudo apt-get -f install
or just
Code: Select all
sudo apt-get dist-upgrade
and hope to catch the message.
Monsta
Level 8
Level 8
 
Posts: 2414
Joined: Fri Aug 19, 2011 3:46 am

Re: Cannot update/upgrade

Postby msbln on Sun Oct 20, 2013 3:01 pm

Command-line was not accessible so I had to restart,
after that there was no xsession just tty1 (whatever that is),
after typing in your suggestions always the following last lines appeared:

dpkg: warning: 'ldconfig' not found in PATH or not executable
dpkg: warning: 'start-stop-daemon' not found in PATH or not executable
dpkg: error: 2 expected programs not found in PATH or not executable
Note: root's PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin
E: Sub-process /usr/bin/dpkg returned an error code (2)
LMDE MATE
msbln
Level 2
Level 2
 
Posts: 54
Joined: Mon Jan 10, 2011 2:49 pm

Re: Cannot update/upgrade

Postby Monsta on Mon Oct 21, 2013 3:05 am

msbln wrote:Command-line was not accessible so I had to restart,
after that there was no xsession just tty1 (whatever that is)

That's not good. Restarting in the middle of the upgrade means asking for trouble.
Well, at least you have the console. Log in as root and try to run the commands there (just remove "sudo" from them; you don't need it when you're logged in as root).
Monsta
Level 8
Level 8
 
Posts: 2414
Joined: Fri Aug 19, 2011 3:46 am

Re: Cannot update/upgrade

Postby msbln on Mon Oct 21, 2013 4:37 am

Monsta, thanks for staying with me.
As it is becoming a little over my head, I changed the direction.
I played back the image of the old LMDE and will not try to update the whole system.
Next to that partition I installed a fresh LMDE.
So I have both for the time being.

What I do not unterstand is, why the latest LMDE is on UP6 when UP7 is out already.
First I have to install the downloaded LMDE and then update to UP7 (over 1000+ updates).
Is there a more efficient way (especially if one wants to do this on more than one pc)?
LMDE MATE
msbln
Level 2
Level 2
 
Posts: 54
Joined: Mon Jan 10, 2011 2:49 pm

Re: Cannot update/upgrade

Postby Monsta on Mon Oct 21, 2013 5:13 am

msbln wrote:I played back the image of the old LMDE and will not try to update the whole system.

You'll have to update it sooner or later. You'll want to install some new software from the repositories, that software will pull in new libs, especially libc6 and other core ones... and you may end up with a partially upgraded system which may or may not work fine.
It's easier to follow the updates. That's the way LMDE is.

msbln wrote:What I do not unterstand is, why the latest LMDE is on UP6 when UP7 is out already.
First I have to install the downloaded LMDE and then update to UP7 (over 1000+ updates).

Yes, because the new ISOs will be released only after UP8, which will be after Mint 16 release (so my guess is December 2013 - January 2014).
Monsta
Level 8
Level 8
 
Posts: 2414
Joined: Fri Aug 19, 2011 3:46 am

Re: Cannot update/upgrade

Postby msbln on Mon Oct 21, 2013 5:56 am

The old LMDE is going to be just temporary, for reference in terms of some adjustments, configurations...
The new LMDE is going to be the standard (this time following the updates closely).

Thanks for your advice and patience :D
LMDE MATE
msbln
Level 2
Level 2
 
Posts: 54
Joined: Mon Jan 10, 2011 2:49 pm

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 5 guests