Problems with glade

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Problems with glade

Postby stanley82 on Sat Dec 14, 2013 2:16 pm

I've just installed glade from the repository on my Debian Mint box. Disaster, glade flashes on then off that's it. Worse still after coffer my black screen would flash on then off every time I touched a key or mouse. Reboot still awful, Firefox comes up, so does Thunderbird, gedit, synaptic, terminal etc it's still flash on then off. I booted into recovery and su password and aptitude purge glade that got rid of glade but I still do not have control of my machine. What a mess glade has got me into. I think the problem is deep inside x11 as a few other hard to describe video things possible to do with my video card appeared. I had to change a boot option from vga=779 to vga=771 to get the left side of the screen on the left not right. Any ideas? Ian.
stanley82
Level 2
Level 2
 
Posts: 57
Joined: Sat Jan 28, 2012 11:01 pm

Linux Mint is funded by ads and donations.
 

Re: Problems with glade

Postby Cebra on Sat Dec 28, 2013 1:11 pm

Have you fixed this problem or is there any solution? I have the same problem.

If I start glade via 'sudo glade' it opens fine.
Cebra
Level 1
Level 1
 
Posts: 1
Joined: Sat Dec 28, 2013 1:09 pm

Re: Problems with glade

Postby stanley82 on Mon Dec 30, 2013 4:57 pm

I have a problem with gtk libgtk-3-dev did the same thing exactly. It's stated as being headers and libs so that gcc can link to the gtk stuff. Strange that it does that. I've restored from backup, what a pest. Ian.
stanley82
Level 2
Level 2
 
Posts: 57
Joined: Sat Jan 28, 2012 11:01 pm

Re: Problems with glade

Postby Monsta on Tue Dec 31, 2013 5:14 am

You know, both glade and libgtk-3-dev depend on so many packages that it's hard to guess which one causes the problem.
Since you have a backup, I propose an experiment:

  1. Get the list of the packages glade depends on. Run sudo apt-get install glade, press 'n' to abort the installation and look at the list of packages that are offered. In my case, it's as follows:
    Code: Select all
    The following extra packages will be installed:
      devhelp devhelp-common libatk-bridge2.0-dev libatk1.0-dev libatk1.0-doc libcairo-script-interpreter2 libcairo2-dev libdevhelp-3-2 libfontconfig1-dev
      libgdk-pixbuf2.0-dev libgladeui-2-0 libgladeui-common libglib2.0-dev libglib2.0-doc libgtk-3-dev libgtk-3-doc libharfbuzz-dev libice-dev libpango1.0-dev
      libpango1.0-doc libpcre3-dev libpcrecpp0 libpixman-1-dev libpng12-dev libsm-dev libxcb-render0-dev libxcb-shm0-dev libxcomposite-dev libxcursor-dev
      libxft-dev libxi-dev libxinerama-dev libxrandr-dev libxrender-dev x11proto-composite-dev x11proto-randr-dev x11proto-render-dev x11proto-xinerama-dev

  2. Do the same for libgtk-3-dev. In my case, it wants to install the following packages:
    Code: Select all
    The following extra packages will be installed:
      libatk-bridge2.0-dev libatk1.0-dev libcairo-script-interpreter2 libcairo2-dev libfontconfig1-dev libgdk-pixbuf2.0-dev libglib2.0-dev libharfbuzz-dev
      libice-dev libpango1.0-dev libpcre3-dev libpcrecpp0 libpixman-1-dev libpng12-dev libsm-dev libxcb-render0-dev libxcb-shm0-dev libxcomposite-dev
      libxcursor-dev libxft-dev libxi-dev libxinerama-dev libxrandr-dev libxrender-dev x11proto-composite-dev x11proto-randr-dev x11proto-render-dev
      x11proto-xinerama-dev

  3. As you see, some packages are present in both lists. Install them manually one by one to see which one causes the problem.
    Of course, your lists may differ from mine, so you'll have to look at them carefully.
Monsta
Level 8
Level 8
 
Posts: 2017
Joined: Fri Aug 19, 2011 3:46 am


Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 6 guests