How to install funcitoning ATI driver in LMDE recovery mode?

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

How to install funcitoning ATI driver in LMDE recovery mode?

Postby OmegaD on Tue Jan 07, 2014 3:24 pm

Hi,

I recently upgraded from LMDE Xfce 3.2.0-2-amd64 to 3.10-2-amd64. Now I can't log in. Linux boots up to the login screen, but the screen appears for about a tenth of a second, flicker / flashes into black oblivion, and then that cycle repeats a few times before it finally crashes, leaving me with a blinky dos cursor.

Info that is probably now irrelevant: The first round of updates crashed in the middle due to not enough disk space in the partition, so I used a Cinnamon Live CD to make more space on the partition, then booted into safe mode, where I ran apt-get dist-upgrade, update, install, upgrade, autoremove.

Graphics Card: SAPPHIRE 100253HDMI Radeon HD 4650 512MB 128-bit GDDR2 PCI Express 2.0 x16 HDCP Ready Low Profile Ready Video Card

I tried adding the radeon.modeset=0 parameter while booting up, but that had no effect.

Do I just need to install drivers for my graphics card before I will be able to log in? If so, how do I do that from the safe mode command line? (I'm guessing they'll be proprietary, and I'm not sure how to get them on my computer.)

Thanks.
Last edited by OmegaD on Sat Jan 11, 2014 7:21 pm, edited 1 time in total.
OmegaD
Level 1
Level 1
 
Posts: 18
Joined: Mon Feb 27, 2012 5:15 pm

Linux Mint is funded by ads and donations.
 

Re: Screen flicker, can't log in to LMDE Xfce 3.10-2-amd64

Postby OmegaD on Tue Jan 07, 2014 3:57 pm

UPDATE: I came across this post: http://forum.linuxmint.com/viewtopic.php?f=46&t=154287&p=801513#p801513 and tried it, but got the same results.

However I did notice something potentially relevant in the process. When I ran Xorg-configure it got up to the part where it gives the "List of video drivers:" and then after the list I got the following error:

Code: Select all
Number of created screens does not match number of detected devices.
  Configuration failed.
Server terminated with error (2). Closing log file.

I don't know if that's useful information or not, but I thought I'd post it in case it helps in identifying the problem.
OmegaD
Level 1
Level 1
 
Posts: 18
Joined: Mon Feb 27, 2012 5:15 pm

Re: Screen flicker, can't log in to LMDE Xfce 3.10-2-amd64

Postby OmegaD on Tue Jan 07, 2014 4:07 pm

UPDATE: I came across this: http://forums.debian.net/viewtopic.php?f=5&t=105330#p503782 and tried entering the following code:

Code: Select all
aptitude purge ~nfglrx
mv /etc/X11/xorg.conf  /etc/X11/xorg.conf.bak
echo options radeon modeset=1 /etc/modprobe.d/radeon-kms.conf

I have no idea what that last line does, but it didn't work either.
OmegaD
Level 1
Level 1
 
Posts: 18
Joined: Mon Feb 27, 2012 5:15 pm

Re: Screen flicker, can't log in to LMDE Xfce 3.10-2-amd64

Postby kurotsugi on Tue Jan 07, 2014 4:08 pm

indeed, that's a graphic card driver problem. anyway, did you uninstall the ATI driver before upgrade or not? if not, try to reinstall the driver. you can also try liquorix kernel. somehow ATI cards works better with them.

EDIT: the last line should be
Code: Select all
sudo echo "radeon.modeset=1" >> /etc/modprobe.d/radeon-kms.conf
after this command you need to run to make it work
sudo update-initramfs -u
this command is to make sure that the initram is using radeon driver.
kurotsugi
Level 5
Level 5
 
Posts: 936
Joined: Fri Jan 25, 2013 3:54 am

Re: Screen flicker, can't log in to LMDE Xfce 3.10-2-amd64

Postby OmegaD on Tue Jan 07, 2014 4:54 pm

did you uninstall the ATI driver before upgrade or not?

Everything worked fine before I started my upgrade from 3.2.0-2-amd64, if that's what you're asking. (Yes, I had my drivers installed and operational at that time.)

you can also try liquorix kernel

...no idea what that means or how to do it :oops:

sudo echo "radeon.modeset=1" >> /etc/modprobe.d/radeon-kms.conf
sudo update-initramfs -u

After logging in as root and entering that code, I get the following error repeated over and over:

Code: Select all
libkmod: ERROR ../libkmod/libkmod-config.c:686 kmod_config_parse: /etc/modprobe.d/radeon-kms.conf line 3: ignoring bad line starting with 'radeon.modeset=1'

After running that and rebooting I now get errors in the startup text saying:

Code: Select all
modprobe: bad line 3: 1 tokens found, 2 needed

...after posting that error a few times it tries to boot up, and I have the same login screen failure.

Incidentally, it would now seem that I no longer have an xorg.conf file. I'm guessing that's not good?
Last edited by OmegaD on Tue Jan 07, 2014 5:32 pm, edited 1 time in total.
OmegaD
Level 1
Level 1
 
Posts: 18
Joined: Mon Feb 27, 2012 5:15 pm

Re: Screen flicker, can't log in to LMDE Xfce 3.10-2-amd64

Postby kurotsugi on Tue Jan 07, 2014 5:09 pm

my bad. open /etc/modprobe.d/radeon-kms.conf and remove the line with radeon.modeset=1. after that, add
Code: Select all
drm
radeon modeset=1
to /etc/initramfs-tools/modules then run 'update-initramfs -u' if it didn't work you can try liquorix kernel as I've suggested above.

anyway, for the first question, we have to uninstall the ATI driver before install a new kernel so that the modules will be compiled properly. you can read this link to know how to upgrade properly viewtopic.php?f=198&t=146220

to install liquorix kernel, add 'deb http://liquorix.net/debian sid main' to your source.list, run 'sudo apt-get update'. you'll see liquorix kernels on your synaptic.
kurotsugi
Level 5
Level 5
 
Posts: 936
Joined: Fri Jan 25, 2013 3:54 am

Re: Screen flicker, can't log in to LMDE Xfce 3.10-2-amd64

Postby OmegaD on Tue Jan 07, 2014 5:36 pm

I discovered that this is a known bug with Linux Mint Debian: http://www.linuxmint.com/rel_debian.php ...so I tried following their advice and entering the following code:

Code: Select all
apt-get clean
apt-get update
apt-get install build-essential module-assistant fglrx-driver fglrx-modules-dkms libgl1-fglrx-glx glx-alternative-fglrx fglrx-control fglrx-glx

I got some errors related to fglrx-glx, so I tried entering the next recommended command:

Code: Select all
aticonfig --initial -f

I then got an error because fglrx-driver wasn't installed, and realized I probably typed something in wrong. Anyway I then tried installing it:

Code: Select all
apt-get install fglrx-driver

I then got an error because that driver won't support my graphics card. The blue screen recommended removing fglrx from xorg.conf andn xorg.conf.d/ and installing xserver-xorg-video-radeon. I don't think I have an xorg.conf file anymore, and I wouldn't know how to edit it anyway, so I just cancelled installation, and ran the following again:

Code: Select all
aptitude purge ~nfglrx

I then tried to run the code to move my xorg.conf file again, but there was no such file. So then I ran the following code:

Code: Select all
xserver-xorg-video-radeon

...but it said it's already at the newest version. Tried rebooting, same error. (I'm assuming the end result of all of that was no change at all but I figured I would post it in case I messed something new up!)
OmegaD
Level 1
Level 1
 
Posts: 18
Joined: Mon Feb 27, 2012 5:15 pm

Re: Screen flicker, can't log in to LMDE Xfce 3.10-2-amd64

Postby OmegaD on Tue Jan 07, 2014 6:00 pm

my bad. open /etc/modprobe.d/radeon-kms.conf and remove the line with radeon.modeset=1.

Ok, I typed:

Code: Select all
vi /etc/modprobe.d/radeon-kms.conf

(I found a tutorial here: http://www.debian.org/doc/manuals/debian-tutorial/ch-editor.html.) Here is what the code looked like before I edited:

Code: Select all
options radeon modeset=1
radeon.modeset=1
~

I figured I'd need to delete all of that, so I did, then saved and quit. (Now the file's empty.) Then I entered:

Code: Select all
vi /etc/initramfs-tools/modules

After I edited it it looked like this:

Code: Select all
drm
radeon modeset=1


I saved and quit, rebooted. Same problem.
OmegaD
Level 1
Level 1
 
Posts: 18
Joined: Mon Feb 27, 2012 5:15 pm

Re: Screen flicker, can't log in to LMDE Xfce 3.10-2-amd64

Postby OmegaD on Sat Jan 11, 2014 6:49 pm

I tried hooking up directly to my MoBo, but had the same problem.

MoBo: ASUS M4A78T-E AM3 AMD 790GX HDMI ATX AMD
Onboard Video Chipset: ATI Radeon HD 3300 built-in 128MB DDR3 1333 SidePort Memory

...probably because it is also ATI.

Still waiting for some help if anyone has any ideas. Right now I can't use LMDE on my PC because of the login screen crash. :|
OmegaD
Level 1
Level 1
 
Posts: 18
Joined: Mon Feb 27, 2012 5:15 pm

Re: How to install funcitoning ATI driver in LMDE recovery m

Postby OmegaD on Tue Apr 15, 2014 6:57 pm

I tried installing the ATI driver in Recovery mode (http://forums.linuxmint.com/viewtopic.php?f=199&t=161853)...

...but it said it couldn't install because it was missing kernel headers (/lib/modules/3.10-2-amd64/build/include/linux/version.h) and "DKMS" failed, or something like that.
OmegaD
Level 1
Level 1
 
Posts: 18
Joined: Mon Feb 27, 2012 5:15 pm

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 3 guests