Installing the german-language package of Libreoffice

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Installing the german-language package of Libreoffice

Postby Minzen on Sat Jan 11, 2014 7:45 am

Hello,

I'm using Libreoffice on my LMDE-system. I installed the "office productivity suite -- German language package" but I read in the description that the spelling dictionaries aren't included. So I wanted to install the myspell-de package but I couldn't find it! I can only find other language (e.g.:myspell-en-us, myspell-hr) but not the myspell-de. Is there a way to get this package because I need to use the spelling check of Libreoffice.

Thanks in advance for your help!
Minzen
Level 1
Level 1
 
Posts: 26
Joined: Sun Nov 03, 2013 12:18 pm

Linux Mint is funded by ads and donations.
 

Re: Installing the german-language package of Libreoffice

Postby kurotsugi on Sat Jan 11, 2014 8:00 am

the correct package is 'myspell-de-de' or 'myspell-de-de-oldspell' for the old orthography ones.
kurotsugi
Level 5
Level 5
 
Posts: 704
Joined: Fri Jan 25, 2013 3:54 am

Re: Installing the german-language package of Libreoffice

Postby py-thon on Sat Jan 11, 2014 10:27 am

dict-de_de-1901_oldspell_2012-09-29.oxt ( http://extensions.libreoffice.org/exten ... ctionaries )
dict-de_de-frami_2013-12-06.oxt ( http://extensions.libreoffice.org/exten ... ctionaries )
Tower: LMDE Mate 64bit - Netbook: LMDE Mate 32bit
py-thon
Level 3
Level 3
 
Posts: 167
Joined: Fri Sep 27, 2013 2:24 pm
Location: Paraguay

Re: Installing the german-language package of Libreoffice

Postby Minzen on Sun Jan 12, 2014 6:18 am

Thank you kurotsugi, but I can't find the 'myspell-de-de' at my package management software. Is there a way to show it?

Thank you py-thon. I've added the 'dict-de_de-frami_2013-12-06.oxt' at the extension manager of Libreoffice but I'm unable to use the spelling check in Libreoffice. Is there a way to activiate it or anything alike this?
Minzen
Level 1
Level 1
 
Posts: 26
Joined: Sun Nov 03, 2013 12:18 pm

Re: Installing the german-language package of Libreoffice

Postby eanfrid on Sun Jan 12, 2014 6:42 am

For your language, you must install the following packages:
- hunspell-de-de (dictionary) or hunspell-de-de-frami
- mythes-de (synonyms)
- hyphen-de (hyphenation)

Edit: py-thon (see below) is right. I still had these packages from legacy (for french language) and they are not required anymore. I only have myspell-fr now.
Last edited by eanfrid on Sun Jan 12, 2014 2:06 pm, edited 3 times in total.
No, Linux is not a Windows clone for free - Before asking any question here...
"Never attribute to malice that which is adequately explained by stupidity." (Hanlon's razor)

Debian GNU/Linux Wheezy 64bit w/custom 3.12 kernel - MATE 1.8
User avatar
eanfrid
Level 6
Level 6
 
Posts: 1211
Joined: Mon Apr 30, 2012 2:49 am
Location: France

Re: Installing the german-language package of Libreoffice

Postby kurotsugi on Sun Jan 12, 2014 7:06 am

in terminal, run 'sudo apt-get update && apt-cache policy myspell-de-de'. if it tells you that it unable to locate the package you'll need to add debian testing repo into your sources.list then run 'sudo apt-get update && sudo apt-get install myspell-de-de myspell-de-de-oldspell' else, if it can find the package simply run 'sudo apt-get install myspell-de-de myspell-de-de-oldspell'.
kurotsugi
Level 5
Level 5
 
Posts: 704
Joined: Fri Jan 25, 2013 3:54 am

Re: Installing the german-language package of Libreoffice

Postby py-thon on Sun Jan 12, 2014 10:46 am

On my system there are neither myspell-de-de, hunspell-de-de, mythes-de nor hyphen-de installed. Spellchecking and hyphenation work without those packages. As far as I know current LibreOffice doesn't need those packages anymore (the version numbers show 3.3 or 2012).

After installing the oxt (click or doubleclick the oxt-file) you can see whether the language-package is correctly installed in Extras-Optionen. See attached photos. The small ABC-symbol before Standard - Deutsch (Deutschland) is important.
Sprache1.png

Sprache2.png

Edit:
If your package management software doesn't show myspell-de-de there seems to be some problem with your repository. Run
Code: Select all
mint-choose-debian-mirrors
to change to another download mirror. Probably you then need
Code: Select all
apt-get update
to load the current package list (might be the package list is automatically updated with changing mirror and this is not necessary).
Tower: LMDE Mate 64bit - Netbook: LMDE Mate 32bit
py-thon
Level 3
Level 3
 
Posts: 167
Joined: Fri Sep 27, 2013 2:24 pm
Location: Paraguay

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 3 guests