Disable Bluetooth ? [SOLVED]

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Disable Bluetooth ? [SOLVED]

Postby ron_h on Tue May 06, 2014 8:08 pm

LMDE 201403 Cinnamon 64bit

I have seen elsewhere in these forums a recommendation (actually for Mint 13) to disable Bluetooth with the menu/GUI ("Startup Applications") which is what I want to do. I know how to set up a new startup item but It is not obvious to me what command(s) to put in such an item to disable Bluetooth. Can someone please help ?

Ron

| sadly, SOLVED means using rc.local rather than the menu/GUI Startup applications
Last edited by ron_h on Thu May 08, 2014 6:10 am, edited 1 time in total.
ron_h
Level 3
Level 3
 
Posts: 180
Joined: Tue Apr 15, 2014 7:03 am
Location: Sydney, NSW, AU

Linux Mint is funded by ads and donations.
 

Re: Disable Bluetooth ?

Postby Kalyk on Wed May 07, 2014 1:52 am

This post http://forums.linuxmint.com/viewtopic.php?f=46&t=160478 and others suggest doing
Code: Select all
sudo service bluetooth stop
sudo rfkill block bluetooth

Probably any of the two commands will stop bluetooth from operating.
The sudo I put in front because you probably need that right for this action, I can't test it here.
If it's a system startup item then the sudo is probably not necessary, because root does its thing then.
But you can try without sudo, because now you have to type your password for the action to take place.
Add (Solved) to the topic-title of the first post when appropriate so others know they might find a solution here.
User avatar
Kalyk
Level 5
Level 5
 
Posts: 597
Joined: Wed Mar 12, 2014 5:29 pm
Location: The Netherlands

Re: Disable Bluetooth ?

Postby ron_h on Wed May 07, 2014 3:12 am

I ran those 2 commands in a terminal, and after I supplied my password, they stopped Bluetooth. I added a Startup item with those 2 commands, and rebooted. On restart, unfortunately Bluetooth came up active. It looked (from the other Startup items there) as if Startup items maybe needed to be a single command, so I created a script file consisting of these 2 commands, and made the script file executable. I executed the script file and after I supplied my password, it stopped Bluetooth. So I edited the Startup item I'd created and pointed it at the script file instead of the 2 commands. I then rebooted, but, sadly, Bluetooth came up active on the restart

Ron
ron_h
Level 3
Level 3
 
Posts: 180
Joined: Tue Apr 15, 2014 7:03 am
Location: Sydney, NSW, AU

Re: Disable Bluetooth ?

Postby Kalyk on Wed May 07, 2014 3:19 am

When you search in Google
Code: Select all
disable bluetooth site:forums.linuxmint.com
then you get a lot.

Or perhaps the rfkill-command can be put at the end of /etc/rc.local .

Another interesting link http://namhuy.net/1397/disable-bluetooth-ubuntu-xubuntu-linux-mint.html
Add (Solved) to the topic-title of the first post when appropriate so others know they might find a solution here.
User avatar
Kalyk
Level 5
Level 5
 
Posts: 597
Joined: Wed Mar 12, 2014 5:29 pm
Location: The Netherlands

Re: Disable Bluetooth ?

Postby ron_h on Wed May 07, 2014 5:16 am

Thanks for that, I will investigate further.

I know can disable Bluetooth after bootup is complete. I am aware I can change a system script to disable Bluetooth, but I would like, if possible, to do it by adding a suitable item to the Startup Programs/GUI that I access via System Settings. I prefer to leave system scripts alone, as it's not unknown for them to be changed in a system update - in which case user modifications can be lost.

Ron
ron_h
Level 3
Level 3
 
Posts: 180
Joined: Tue Apr 15, 2014 7:03 am
Location: Sydney, NSW, AU

Re: Disable Bluetooth ?

Postby Kalyk on Wed May 07, 2014 5:53 am

I think rc.local is sortof your own thing, I also put things in there in the past and never had the problem, that anything overruled that.
But if a solution works for you then it should be fine.
Add (Solved) to the topic-title of the first post when appropriate so others know they might find a solution here.
User avatar
Kalyk
Level 5
Level 5
 
Posts: 597
Joined: Wed Mar 12, 2014 5:29 pm
Location: The Netherlands

Re: Disable Bluetooth ?

Postby ron_h on Thu May 08, 2014 5:32 am

Well, if rc.local is a 'user' thing then that's what I'll use. Life is a learning experience :-)
| and, by modifying rc.local, and rebooting, Bluetooth is indeed disabled.
| Many thanks

At a slight tangent, where, if anywhere, are the results of executing System Settings-Startup Programs logged, especially ones added or modified by a user ? I've looked at the various files in /var/log and can't find any sign of results in any of them. It'd be helpful sometimes when expected results don't eventuate.

Ron
ron_h
Level 3
Level 3
 
Posts: 180
Joined: Tue Apr 15, 2014 7:03 am
Location: Sydney, NSW, AU

Re: Disable Bluetooth ?

Postby DavidCBillen on Tue Jul 08, 2014 12:57 pm

Kalyk wrote:When you search in Google
Code: Select all
disable bluetooth site:forums.linuxmint.com
then you get a lot.

Or perhaps the rfkill-command can be put at the end of /etc/rc.local .

Another interesting link http://namhuy.net/1397/disable-bluetooth-ubuntu-xubuntu-linux-mint.html


Their procedure worked for me, but heads up: I blindly (and stupidly) typed their command to remove all the bluetooth services into my console and it removed cinnamon!
DavidCBillen
Level 1
Level 1
 
Posts: 1
Joined: Tue Jul 08, 2014 12:54 pm

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 6 guests