Password no longer works [Sorto Solved]

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

Password no longer works [Sorto Solved]

Postby rfharabin on Sun May 25, 2014 9:25 pm

I have always used the same password for al my Linux distros so I have a hard time believing that I forgot the password but I cannot update or anything that requires a password.

Is there a fix or do I have to uninstall and reinstall?
Last edited by rfharabin on Tue Jun 10, 2014 8:24 am, edited 2 times in total.
rfharabin
Level 2
Level 2
 
Posts: 67
Joined: Thu Feb 13, 2014 2:39 pm

Linux Mint is funded by ads and donations.
 

Re: Pasword no longer works

Postby turtlebay777 on Mon May 26, 2014 3:11 am

It frequently happens when someone has the problem you report, that either caps or caps lock was accidentally pressed as they set up the password. Try it.
User avatar
turtlebay777
Level 4
Level 4
 
Posts: 386
Joined: Tue Apr 15, 2014 4:56 pm

Re: Pasword no longer works

Postby rfharabin on Mon May 26, 2014 6:25 am

Thanks for the idea but that occurred to me and I tried it. Also I spent at least twenty minutes trying all similar words that I have used even though I am sure none of them were used.

I should say that I have a copy of mint 13 on a thumb drive that I likely can use to get at the root files of the external HD.
rfharabin
Level 2
Level 2
 
Posts: 67
Joined: Thu Feb 13, 2014 2:39 pm

Re: Password no longer works

Postby wayne128 on Mon May 26, 2014 6:51 am

If you have exhausted all kind of combination of known password and yet you could not get into the system, perhaps you need to reset the password..
No need to reinstall.

Follow this tutorial...hopefully you would get there
http://community.linuxmint.com/tutorial/view/339
wayne128
Level 10
Level 10
 
Posts: 3325
Joined: Tue Jul 13, 2010 12:15 am

Re: Password no longer works

Postby rfharabin on Mon May 26, 2014 9:26 am

Thanks, I will try that. What bugs me about this is that I updated after the install and added a program.
rfharabin
Level 2
Level 2
 
Posts: 67
Joined: Thu Feb 13, 2014 2:39 pm

Re: Password no longer works

Postby rfharabin on Mon May 26, 2014 11:47 am

wayne128 wrote:If you have exhausted all kind of combination of known password and yet you could not get into the system, perhaps you need to reset the password..
No need to reinstall.

Follow this tutorial...hopefully you would get there
http://community.linuxmint.com/tutorial/view/339


This did not work for me. Maybe because I have Mint LMDE Cinnamon installed on an external drive. When I installed it, the installer put a Grub
file into my Win7 disk 0 MBR (?) zero sector that defaults to Mint whereby I desire it to default to Win7 as such I have been trying to get "Startup Manager" installed to change this. Somehow the password has been messed up and as I have always used the same password for all the Linux distro's I played with in Win7 VirtualBox and installed on my external HD. I am baffled.

I can get to the Grub but only after the loader where I get the choices of which to load and it shows what is in the loader for these choices.
Thanks for the helpful idea.

Does this info help?
rfharabin
Level 2
Level 2
 
Posts: 67
Joined: Thu Feb 13, 2014 2:39 pm

Re: Password no longer works

Postby wayne128 on Mon May 26, 2014 9:06 pm

I am not familiar with Start up manager.
I did not use it for a few years.

All you need to do now, perhaps, is try boot into your Linuxmint installation, then, do a code as below , to let grub take over the mbr of first hard disk, so that you can boot into Mint directly, or in other words, boot to Mint as the default..
But, since there is a default 10 second timer, you have this time to hit 'e' for edit, when you manage to get into 'edit mode' you scroll down to Linux or Kernel line and append the line with what started in the link, if you could do that, you will be in a 'password-less' console, which then allow you to reset your password...


the command to install grub to mbr, when you are already running Linuxmint , is

sudo grub-install /dev/sda
wayne128
Level 10
Level 10
 
Posts: 3325
Joined: Tue Jul 13, 2010 12:15 am

Re: Password no longer works

Postby rfharabin on Tue May 27, 2014 11:47 am

Before I do a sudo I am going to backup everything with Macrium Reflect. This will take a while as My wife needs to finish her book soon and we are both proofreading it. Plus the normal added spring work.

I had Mint 16-64 Mate on the external HD before and it put all the boot info in the external HD and I had to hit F9 while booting up to get Mint. When I installed Mint LMDE it put a grub boot file on my Disk 0, the internal HD, with the boot options and default to Mint.

Here is what I have if it helps. The first two are internal.

Disk0 ..... sys reserved ........(C) Win7
1 tetra .....100 MB ...............931GB
.............. /sda1................./sda2
ntfs ntfs

Disk1..........(E) internal Backup
1 tetra............/sdb1

Disk2..........(G) Goflex
1 tetra........../sdc1

Disk3........20 GB........20GB........60GB........14GB
120GB........boot.........swap.......Home........xfer
.............../sdd1........./sdd2....../sdd3......./sdd4
............... ext4........................ext4........ntfs


Should I install the boot to /sdd1?
I am wondering if the command you gave would overwrite what is on the internal HD now and not leave me a good boot on my external (120GB) HD.
rfharabin
Level 2
Level 2
 
Posts: 67
Joined: Thu Feb 13, 2014 2:39 pm

Re: Password no longer works

Postby austin.texas on Tue May 27, 2014 12:41 pm

rfharabin wrote:Should I install the boot to /sdd1?

No, you should not install GRUB to sdd1. You should install the GRUB bootloader to the MBR of the drive that Mint is on.
rfharabin wrote: I am wondering if the command you gave would overwrite what is on the internal HD now and not leave me a good boot on my external (120GB) HD.

Do you have a GRUB boot menu on the external drive, left over from Mint 13? Can it boot Windows?

The first step is to get the password working so that you can fix GRUB the way you want.
Try what wayne128 suggested for the password repair.
Mint 17 v2 Cinnamon (64 bit), Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Microsoft-free environment since 1996

To help Linux Mint with a donation, please visit http://www.linuxmint.com/donors.php
User avatar
austin.texas
Level 11
Level 11
 
Posts: 3786
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: Password no longer works

Postby rfharabin on Tue May 27, 2014 3:41 pm

austin.texas wrote:
rfharabin wrote:Should I install the boot to /sdd1?

No, you should not install GRUB to sdd1. You should install the GRUB bootloader to the MBR of the drive that Mint is on.

Mint is on the external HD (disk3) drive where ssd1 is located. sda1 is the on internal HD (disk0) where Win7 is installed and was installed before I put Mint LMDE on the external 120GTB HD. This seems to me to be a bug with Mint LMDE as I had Mint 16 mate on the external 120GB HD before and there was no grub loader on disk0.

Confusing ain't it.
I will try to boot directly from the external drive as soon as I can.
rfharabin
Level 2
Level 2
 
Posts: 67
Joined: Thu Feb 13, 2014 2:39 pm

Re: Password no longer works

Postby rfharabin on Tue May 27, 2014 4:23 pm

[quote="austin.texas"][quote="rfharabin"]
Do you have a GRUB boot menu on the external drive, left over from Mint 13? Can it boot Windows?

No, It will not boot directly from the external (disk3) drive.
rfharabin
Level 2
Level 2
 
Posts: 67
Joined: Thu Feb 13, 2014 2:39 pm

Re: Password no longer works

Postby austin.texas on Tue May 27, 2014 4:40 pm

When you followed the instructions on the page wayne128 gave you, did you " Hold down the Shift key at the start of the boot process "
Hold it down until the GRUB menu appears, then complete the instructions.
Mint 17 v2 Cinnamon (64 bit), Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Microsoft-free environment since 1996

To help Linux Mint with a donation, please visit http://www.linuxmint.com/donors.php
User avatar
austin.texas
Level 11
Level 11
 
Posts: 3786
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: Password no longer works

Postby wayne128 on Wed May 28, 2014 5:35 am

rfharabin wrote:
austin.texas wrote:
rfharabin wrote:Should I install the boot to /sdd1?

No, you should not install GRUB to sdd1. You should install the GRUB bootloader to the MBR of the drive that Mint is on.

Mint is on the external HD (disk3) drive where ssd1 is located. sda1 is the on internal HD (disk0) where Win7 is installed and was installed before I put Mint LMDE on the external 120GTB HD. This seems to me to be a bug with Mint LMDE as I had Mint 16 mate on the external 120GB HD before and there was no grub loader on disk0.

Confusing ain't it.
I will try to boot directly from the external drive as soon as I can.



No, It will not boot directly from the external (disk3) drive.





Should I install the boot to /sdd1?
I am wondering if the command you gave would overwrite what is on the internal HD now and not leave me a good boot on my external (120GB) HD.


A bit confused... but after reading more than two times, I think I understand clearer:
1. You have Mint on external 120G HD
2. You cannot boot with F9, choose 120G HD ( disk3)
3. You can boot to Win7 on first hard disk, /dev/sda

Here I think you can repair your boot loader to make disk3 bootable directly.
a. Boot with Live DVD or Live USB
b, on terminal, use sudo os-prober to find out what exactly is /dev/sdXn of your mint partition


as an example, from my os-prober, the Mint 10 Julia is at /dev/sdc10
Code: Select all
wayne@hp8000:~$ su
Password:
root@hp8000:/home/wayne# os-prober
;;;;
/dev/sda3:Windows 7 (loader):Windows:chain
;;;;
/dev/sdc1:Linux Mint 17 Qiana (17):LinuxMint1:linux
/dev/sdc10:Linux Mint 10 Julia (10):LinuxMint2:linux



c. on terminal, mount mint partition and reinstall grub to mbr of /dev/sdX with these codes
sudo mount /dev/sdXn /mnt
sudo grub-install --root-directory=/mnt /dev/sdX

replace X with proper letter, most likely it is d, replace n with proper number, most likely 1

Hopefully this get your Mint drive bootable with F9 /disk3

if not, then you need to use chroot method... commands later if needed.
wayne128
Level 10
Level 10
 
Posts: 3325
Joined: Tue Jul 13, 2010 12:15 am

Re: Password no longer works

Postby rfharabin on Wed May 28, 2014 8:43 am

Should I install the boot to /sdd1?
I am wondering if the command you gave would overwrite what is on the internal HD now and not leave me a good boot on my external (120GB) HD.


A bit confused... but after reading more than two times, I think I understand clearer:
1. You have Mint on external 120G HD
2. You cannot boot with F9, choose 120G HD ( disk3)
3. You can boot to Win7 on first hard disk, /dev/sda


This is correct but read on. The boot (on disk0) brings up an option page where I have about ten seconds to pick either Win7 or Mint. It will default to Mint. On patch Tuesday this is a problem as I need to default to Win7. Also if anyone else restarts the computer this will likely be a problem. I have programs that start as a service and I want them to run if I am not around to watch over the restart. So far we have not been able to get at the Grub boot stuff on disk0 and in trying to do so I may have messed up password files. This was done before I posted here asking for help.




[/quote][/quote]

My wife's book will have priority today as it did yesterday as she wanted to have it done by today but I will squeeze in time on her breaks then what I need to do with her book will go faster. I do have backups now in case anything goes wrong.

There are two things that are causing me problems. The main thing is the password problem. I am sure I know what the password is but it does not work. The other is getting the boot to choose Win7 as the default. Startup manager should do this. I think that the mess I have now was caused by efforts to correct the Boot options to default to Win7 before I found out about the startup manager. I am thinking that somehow I messed up the password or the programs area that does the password. If I can fix the password problem and get Startup Manager to change the default boot option I will be OK.

I would be happy to have the computer boot as it did before and then use F9 to load Mint or just default to Win7. I can look at the windows boot info in the System Reserve section of Disk0 but cannot see any Linux that has to be installed there.

If I change the boot loader to boot from Disk3 (120GB external) will this mess up my boot as it is now from Disk0? There will be two different boot files, one On disk0 an one on disk3. The disk0 boot file will bring up the option page and then after about ten seconds go to the default.

Here I think you can repair your boot loader to make disk3 bootable directly.
a. Boot with Live DVD or Live USB



What is a Live CD or Live USB (Boot with Live DVD or Live USB)? I have Active boot disk but this is a windows disk.

Many thanks for the patience from you guys.

I am hoping to be able to get lots of time to work on the problem by tomorrow.
rfharabin
Level 2
Level 2
 
Posts: 67
Joined: Thu Feb 13, 2014 2:39 pm

Re: Password no longer works

Postby rfharabin on Thu May 29, 2014 3:53 pm

OK guys, I am making progress but am stuck again.

I hope no one read what I had here earlier. I had to wait till my wife finished for the day and then it was too late. I Will be back to what you said to do late tomorrow or Sunday. It took me awhile to think that I was so slow getting as far as I got that I should have read what was next. Old Swedish saying "We get too soon old and too late smart." LOL
rfharabin
Level 2
Level 2
 
Posts: 67
Joined: Thu Feb 13, 2014 2:39 pm

Re: Password no longer works

Postby austin.texas on Fri May 30, 2014 6:38 am

rfharabin wrote:I am wondering if the command you gave would overwrite what is on the internal HD now and not leave me a good boot on my external (120GB) HD.
No, but you can unplug the internal HD while you fix the external HD, if you would feel more secure doing that.
rfharabin wrote: The boot (on disk0) brings up an option page where I have about ten seconds to pick either Win7 or Mint. It will default to Mint. On patch Tuesday this is a problem as I need to default to Win7. Also if anyone else restarts the computer this will likely be a problem.
This can be fixed easily, after your password is fixed.
rfharabin wrote:So far we have not been able to get at the Grub boot stuff on disk0
Unplugging the internal drive may help with that. That might make the external drive sdb instead of sdc (Disk2 instead of Disk3)
rfharabin wrote: The other is getting the boot to choose Win7 as the default. Startup manager should do this.
I don't know what "Startup Manager" is. But fixing the default boot order after your password is fixed is fairly simple.
rfharabin wrote: There will be two different boot files, one On disk0 an one on disk3.
There already are two Grub menus, one on sda and one on sdc - and that is a good thing.
rfharabin wrote:What is a Live CD or Live USB (Boot with Live DVD or Live USB)? I have Active boot disk but this is a windows disk.
When you download the Mint iso file and burn it to a DVD (or USB), you then have a Live Mint DVD which contains a complete operating system (as well as the Mint installation program). Boot your live DVD and follow wayne128's instructions.
Mint 17 v2 Cinnamon (64 bit), Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Microsoft-free environment since 1996

To help Linux Mint with a donation, please visit http://www.linuxmint.com/donors.php
User avatar
austin.texas
Level 11
Level 11
 
Posts: 3786
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: Password no longer works

Postby rfharabin on Sat May 31, 2014 10:38 am

Today I had all morning to work on the problem of my password. First a question. How will I recognize a Bash Prompt?


I have been working of of the link Wayne128 gave above to reset my password. I printed out all three sheets. It has been over fifty years for me but as I remember; if X is the number of items than the number of possible variations is X Squared. I have been trying a lot of them. What I have is not quite the same as the link shows but the posts below help some.

1) Step seven says to press enter, the press b to boot your system. F10 is my boot but do I need to press enter? Pressing enter starts a new line.


2) Trying different variations brings up different actions but a common end stops with a prompt and when I type in “passwd user name” I get;

usage: passwd [options] [LOGIN]

-a, --all
-d – delete
-e – expire
-h – help
-r –repository REPOSITORY change password in REPOSITORY repository
There are fifteen possible commands.

I cannot get any of these to work properly.

What should be entered in {LOGIN]? I assumed my user name but no luck yet.

Am I at the correct place to reset my password?
rfharabin
Level 2
Level 2
 
Posts: 67
Joined: Thu Feb 13, 2014 2:39 pm

Re: Password no longer works

Postby wayne128 on Sat May 31, 2014 7:42 pm

rfharabin wrote:
1) Step seven says to press enter, the press b to boot your system. F10 is my boot but do I need to press enter? Pressing enter starts a new line.


2) Trying different variations brings up different actions but a common end stops with a prompt and when I type in “passwd user name” I get;

usage: passwd [options] [LOGIN]

-a, --all
-d – delete
-e – expire
-h – help
-r –repository REPOSITORY change password in REPOSITORY repository
There are fifteen possible commands.

I cannot get any of these to work properly.

What should be entered in {LOGIN]? I assumed my user name but no luck yet.

Am I at the correct place to reset my password?



Here is a thread that has lost password, viewtopic.php?f=47&t=117601&hilit=password


I posted some details on how the screen look like , where to edit the kernel line, and after hitting F10 or ctrl-x, how the screen look like, what to enter and so on.
perhaps take a look at it and see if it helps

viewtopic.php?f=47&t=117601&hilit=+password#p675477
wayne128
Level 10
Level 10
 
Posts: 3325
Joined: Tue Jul 13, 2010 12:15 am

Re: Password no longer works

Postby rfharabin on Tue Jun 03, 2014 3:15 pm

wayne128 wrote:

Here is a thread that has lost password, viewtopic.php?f=47&t=117601&hilit=password


I posted some details on how the screen look like , where to edit the kernel line, and after hitting F10 or ctrl-x, how the screen look like, what to enter and so on.
perhaps take a look at it and see if it helps

viewtopic.php?f=47&t=117601&hilit=+password#p675477


Thank you very much, that link helped. It took a lot of n00b guesswork out of the process.

The image shows what I got when I added the rw init=/bin/bash where it was to go.
Next I opened a terminal and entered "Mount /dev/sdd1/ mint" and was told that only root can do that so I tried "fdisk-l" and was told "command not found"

What did I do wrong.
Attachments
P1000706_1.jpg
rfharabin
Level 2
Level 2
 
Posts: 67
Joined: Thu Feb 13, 2014 2:39 pm

Re: Password no longer works

Postby wayne128 on Tue Jun 03, 2014 11:30 pm

rfharabin wrote:The image shows what I got when I added the rw init=/bin/bash where it was to go.


Upto here, I am following OK.

Next I opened a terminal"


To be honest, I am quite lost here.

Just describe here, hope it is not confusing.
When I use 'e' on grub menu , type on linux line with rw init=/bin/bash, I will become a superuser.. and when the display show me

(none) /#


then, I am already root and this is a giant terminal, so to speak..

Your image show that
ls /home
follow by
ls/home
and nothing inbetween... well, it hinted that you are booting to a OS ( I do not know which one) because you are attempting to open a terminal ..

and entered "Mount /dev/sdd1/ mint


also hinted you do not have /home in this OS ( which I do not know where it is)


and was told that only root can do that so I tried "fdisk-l" and was told "command not found"

What did I do wrong.


All I can say is, Linux command is sensitive to syntax and capital letters.
This command has wrong syntax, those wrongs are highlighted in red
Mount /dev/sdd1/ mint

the correct one is
mount /dev/sdd1 /mnt


this one
fdisk-l
has wrong syntax, missing space between fdisk and -l
the correct one is
fdisk -l
wayne128
Level 10
Level 10
 
Posts: 3325
Joined: Tue Jul 13, 2010 12:15 am

Linux Mint is funded by ads and donations.
 
Next

Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 1 guest