xinitrc

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

xinitrc

Postby majest on Thu May 29, 2014 4:46 pm

I can't seem to get my keybindings working on a fresh install of LMDE UP9.

My .xinitrc file is as follows:

Code: Select all
if [ -s ~/.Xmodmap ]; then
    xmodmap ~/.Xmodmap
fi


and my .Xmodmap is thus:

Code: Select all
keycode 62 = Mode_switch
keycode 105 = Mode_switch
keycode 116 = Down NoSymbol Next
keycode 111 = Up NoSymbol Prior
keycode 113 = Left NoSymbol Home
keycode 114 = Right NoSymbol End


The purpose of these changes is to make right-shift + up/down arrow keys behave as page up/down.
majest
Level 1
Level 1
 
Posts: 17
Joined: Thu May 29, 2014 3:34 pm

Linux Mint is funded by ads and donations.
 

xinitrc

Postby majest on Thu May 29, 2014 5:03 pm

I can't seem to get my keybindings working on a fresh install of LMDE UP9 MATE. My .xinitrc file is as follows:

Code: Select all
if [ -s ~/.Xmodmap ]; then
    xmodmap ~/.Xmodmap
fi


and .Xmodmap is thus:

Code: Select all
keycode 62 = Mode_switch
keycode 105 = Mode_switch
keycode 116 = Down NoSymbol Next
keycode 111 = Up NoSymbol Prior
keycode 113 = Left NoSymbol Home
keycode 114 = Right NoSymbol End


It used to work on my old LM Maya install. THanks for any help!
majest
Level 1
Level 1
 
Posts: 17
Joined: Thu May 29, 2014 3:34 pm

Re: xinitrc

Postby majest on Tue Jun 03, 2014 8:15 am

I have been searching on the internet and apparantly this is quite a common problem.

There does not appear to be a solution - I have tried putting a custom startup command: sleep 10 && xmodmap /home/myself/.Xmodmap but this doesn't work. The only thing that works is manually typing xmodmap ~/.Xmodmap from a bash shell once I have logged in. It is quite annoying, it seems this should be eminently fixable! Please help :cry:
majest
Level 1
Level 1
 
Posts: 17
Joined: Thu May 29, 2014 3:34 pm

Re: xinitrc

Postby kurotsugi on Tue Jun 03, 2014 8:30 am

I don't know whether if xinitrc is still working or not :3
AFAIK it's now replaced with /etc/rc.local
kurotsugi
Level 5
Level 5
 
Posts: 891
Joined: Fri Jan 25, 2013 3:54 am

Re: xinitrc

Postby majest on Sun Jun 08, 2014 8:31 am

kurotsugi wrote:I don't know whether if xinitrc is still working or not :3
AFAIK it's now replaced with /etc/rc.local


I can confirm that editing rc.local does not work. Any other ideas? I'm really desperate ;)
majest
Level 1
Level 1
 
Posts: 17
Joined: Thu May 29, 2014 3:34 pm

Re: xinitrc

Postby majest on Tue Jun 10, 2014 6:12 am

Please help me people - my life is falling apart over this... :(
majest
Level 1
Level 1
 
Posts: 17
Joined: Thu May 29, 2014 3:34 pm

Re: xinitrc

Postby majest on Wed Jun 11, 2014 5:17 am

The solution is found. It's shocking, get ready.

Create a new item in Preferences -> Startup Applications with the following command:

/bin/bash -c "sleep 10; /usr/bin/xmodmap /home/username/.Xmodmap"

I don't know why it needs to sleep or why absolute paths are needed. It just works (c).
majest
Level 1
Level 1
 
Posts: 17
Joined: Thu May 29, 2014 3:34 pm

Re: xinitrc

Postby majest on Wed Jun 18, 2014 7:05 pm

Another necessary hack for the startup applications: /bin/bash -c "sleep 10; xset s 0 0 s noblank dpms 0 0 0 -dpms"

This stops XFCE from blanking the screen every 10 minutes.
majest
Level 1
Level 1
 
Posts: 17
Joined: Thu May 29, 2014 3:34 pm

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 3 guests