No Transparency Option in Profile Preferences

All Gurus once were Newbies
Forum rules

No Transparency Option in Profile Preferences

Postby vvarlock on Wed Jul 02, 2014 1:17 am

Hello,

I'm new to linux mint debian edition, but not to debian. After installing the OS I noticed that I couldn't set the transparency option for the terminal. The tab that usually gives you the option simply wasn't there. I figured it was because it wasn't supported without my graphics drivers installed but the option still isn't there. Is there a supported feature in LMDE?

Info
OS: LMDE 64bit
CPU: Intel Core i7
GPU: NVIDIA GeForce GTX 670m

Let me know if any other info is needed. Thank you.
vvarlock
Level 1
Level 1
 
Posts: 10
Joined: Fri May 23, 2014 11:01 pm

Linux Mint is funded by ads and donations.
 

Re: No Transparency Option in Profile Preferences

Postby Monsta on Wed Jul 02, 2014 2:51 am

Oh, you have Cinnamon, I presume? Gnome developers removed this feature from gnome-terminal in version 3.8 IIRC.
Monsta
Level 9
Level 9
 
Posts: 2893
Joined: Fri Aug 19, 2011 3:46 am

Re: No Transparency Option in Profile Preferences

Postby rck2 on Thu Jul 03, 2014 7:45 am

No joke, have you found a work around to this issue?
rck2
Level 1
Level 1
 
Posts: 16
Joined: Fri May 10, 2013 8:02 am
Location: South Carolina

Re: No Transparency Option in Profile Preferences

Postby Monsta on Thu Jul 03, 2014 8:02 am

How do you work around a removed feature? No way. You can only install the earlier version from snapshot.debian.org - and that's only if there won't be any problem with the dependencies.
Monsta
Level 9
Level 9
 
Posts: 2893
Joined: Fri Aug 19, 2011 3:46 am

Re: No Transparency Option in Profile Preferences

Postby vvarlock on Sun Jul 06, 2014 1:09 am

Yes, I'm using cinnamon.

If it's a feature that's no longer supported, can I get the effect another way?
vvarlock
Level 1
Level 1
 
Posts: 10
Joined: Fri May 23, 2014 11:01 pm

Re: No Transparency Option in Profile Preferences

Postby vvarlock on Sun Jul 27, 2014 12:53 am

This isn't really a solution, but I decided to switch from cinnamon to MATE. So far I like it a lot. It seems less buggy and I get my transparent terminals back.

I do a lot of programming and am usually toggling between the terminal and an IDE or browser. This workflow has become very useful for me. Even when I'm forced to work in a Windows environment I'll use cygwin with mintty to get the same effect.

MATE FTW
vvarlock
Level 1
Level 1
 
Posts: 10
Joined: Fri May 23, 2014 11:01 pm

Re: No Transparency Option in Profile Preferences

Postby killer de bug on Sun Jul 27, 2014 4:13 am

With the new Cinnamon 2.2, you can make a window transparent by using your mouse wheel.

Window opacity

You can now shade windows or change their opacity by using your mouse wheel on their titlebar. A quick roll of the mouse wheel makes your window semi-transparent so you can see what’s happening underneath without the need to tile things or to use Alt-tab. This option is available in the “Windows” module.


Problem: we don't have Cinnamon 2.2 in LMDE for now. But normally it will come this summer. :)
Image
If it ain't broke, fix it until it is.
User avatar
killer de bug
Level 11
Level 11
 
Posts: 3563
Joined: Tue Jul 08, 2008 1:49 pm
Location: Graz, Austria

Re: No Transparency Option in Profile Preferences

Postby karlchen on Sun Jul 27, 2014 11:23 am

Note: Turned MrBob22's question into a dedicated thread: How do you switch from Cinnamon to Mate.
Image
Still using Linux Mint 14, 15, or 16? Upgrade to 17 asap!
Europeans: sudo apt-get purge ttip ceta
User avatar
karlchen
Level 15
Level 15
 
Posts: 5927
Joined: Sat Dec 31, 2011 7:21 am

Re: No Transparency Option in Profile Preferences

Postby wsp-1 on Fri Oct 31, 2014 4:29 pm

Monsta wrote:How do you work around a removed feature? No way. You can only install the earlier version from snapshot.debian.org - and that's only if there won't be any problem with the dependencies.

@vvarlock, I was feelin' the same way; how ever I do like my Cinnamon (LMDE). And decided to follow-up on Monstra' advice and degrade my current Gnome Terminal 3.8.11 install. So, here my "work-around" 2 cent 'solution'.

:idea: If I am not mistaken, Trusty Thar, the latest LTS version of the Ubuntu camp shipped their Unity Desktop with Gnome Terminal 3.6.x, hence I downloaded it from the gnome-terminal_3.6.1-1 don't forget to download the additional '-data.deb' aswell! (at the bottom)

I used Synaptic Package Manager to remove 'new' gnome-terminal package. Installed ROXterm, while I was at it, to give me an alternative graphical terminal to work with in my Cinnamon session.

There I issued the following without error:
Code: Select all
cd ./Downloads
sudo dkpg -i gnome-terminal*.deb


I'll mostlikely remove the ROXTerm eventually. Hope it helps anyone else that really misses the background transparency :D .
User avatar
wsp-1
Level 1
Level 1
 
Posts: 3
Joined: Fri Oct 31, 2014 4:03 pm

Re: No Transparency Option in Profile Preferences

Postby jonnymopar on Tue Nov 04, 2014 4:24 pm

I'm also using Cinnamon and I also don't like the fact that they removed that option.

I removed gnome-terminal and started using xfce4-terminal instead. It's VERY similar in function, plus it has the option for transparency. So far it seems to work great. I even changed the Ctrl+Alt+T shortcut so it loads the same way gnome-terminal always did. I basically just followed this: http://howto8165.wordpress.com/2014/08/ ... nsparency/
jonnymopar
Level 1
Level 1
 
Posts: 6
Joined: Tue Oct 21, 2014 2:06 pm

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 5 guests