Keyboard layout issue in LMDE

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

Keyboard layout issue in LMDE

Postby davidgagne80 on Tue Sep 14, 2010 10:46 pm

Hi! I looked everywhere and couldn't find anyone with a similar problem...

I installed LMDE soon after it was released and I'm thrilled with it, but during the installation I didn't select the proper keyboard.

Not a big deal, I went in the control center and changed it after it was done and clicked delete on the wrong one. Everything was fine... Or so I thought.

Everytime I restard the computer the bad layout comes back and I'm stuck with the annoying little icon on my taskbar to select which one I want to use...

anyone know how to delete a bad layout for good?? Everytime, I go back to the control center, and I delete it, but when I reboot, it's back! just bugging me!

Thanks in advance!!
Image
davidgagne80
Level 1
Level 1
 
Posts: 7
Joined: Fri Jun 04, 2010 12:42 am

Linux Mint is funded by ads and donations.
 

Re: Keyboard layout issue in LMDE

Postby stz*j on Wed Sep 15, 2010 5:44 am

Hi, I had a similar problem to yours too, with the 'bad', not needed layout popping up again.

I kinda solved it after some trial and error. Forgot how but try this and see how it goes.

Go to keyboard preferences -> layouts.
1) Delete the keyboard layout(s) you don't need.
2) Click on the reset to defaults.

I think that was what I did. Don't ask the theory behind it.

In my case, I'm alternating between qwerty and colemak layouts so I had to add keep 2 of them before clicking the Reset to defaults.
LMDE (Release 1), tracking debian testing, Kernel 3.14.1-686-pae i686 (32 bit), MATE & Enlightenment;
Plays (and rescues system) with experimental and sid repos on another partition with Cinnamon & Gnome3, if grub boots nice that is.
stz*j
Level 2
Level 2
 
Posts: 82
Joined: Fri Jun 25, 2010 3:08 am

Re: Keyboard layout issue in LMDE

Postby davidgagne80 on Wed Sep 15, 2010 1:02 pm

That does not work with mine... As soon as I press the reset to default button, the bad one reappears and the good one disappears :(

In my case they are 2 different layouts of Canadian keyboard, I want to use Canada Multilingual (because I need all those weird é à â characters to be easily available when I talk to my french relatives) but the regular Canada keyboard keeps popping back... Thanks anyway stz*j !
Image
davidgagne80
Level 1
Level 1
 
Posts: 7
Joined: Fri Jun 04, 2010 12:42 am

Re: Keyboard layout issue in LMDE

Postby secipolla on Wed Sep 15, 2010 2:54 pm

Hi, I don't know if what you're talking about is specific to GNOME or Mint. But the system layout(s) is(are) set in /etc/default/keyboard. This can be configured with the keyboard configuration tool:
Code: Select all
dpkg-reconfigure keyboard-configuration
secipolla
Level 4
Level 4
 
Posts: 356
Joined: Sun Sep 05, 2010 5:19 pm

Re: Keyboard layout issue in LMDE

Postby stz*j on Wed Sep 15, 2010 9:37 pm

I did more research around the debian forums and saw a lot of cases similar to this.

http://forums.debian.net/viewtopic.php? ... em#p284444
http://forums.debian.net/viewtopic.php?p=242260#p242260

The above way works, I've tried it. Also found some other ways like editing the /etc/X11/xorg.conf file which I can't find in my filesystem. I can say that xorg.conf file can fix a LOT of things but they kinda left it out somewhere in the newer versions and put in other replacements I suppose.

I found an interesting one to use
Code: Select all
setxkbmap ca


That'll give you canada's layout but I can't find a way to make it the multilingual one. Oh, and it kinda gets stuck at canada only although you keyboard preferences might show your other layouts. Just click around a little, move the layouts up and down and it'll be ok.

Actually, I see no point in doing so. lol. Just thought you might want to learn a few things. :D
LMDE (Release 1), tracking debian testing, Kernel 3.14.1-686-pae i686 (32 bit), MATE & Enlightenment;
Plays (and rescues system) with experimental and sid repos on another partition with Cinnamon & Gnome3, if grub boots nice that is.
stz*j
Level 2
Level 2
 
Posts: 82
Joined: Fri Jun 25, 2010 3:08 am

Re: Keyboard layout issue in LMDE

Postby ghysmodos on Thu Sep 16, 2010 3:56 am

I had a similar issue ( Italian and German layout),
I found out that I can choose it at the login screen.
ghysmodos
Level 1
Level 1
 
Posts: 9
Joined: Tue Jul 06, 2010 5:01 am
Location: Berlin, Germany

Re: Keyboard layout issue in LMDE

Postby RavanH on Thu Jan 06, 2011 9:16 pm

secipolla wrote:Hi, I don't know if what you're talking about is specific to GNOME or Mint. But the system layout(s) is(are) set in /etc/default/keyboard. This can be configured with the keyboard configuration tool:
Code: Select all
dpkg-reconfigure keyboard-configuration


After going though some steps without really knowing what to choose, this one (but with sudo in front of it) turned out to work. Thanks secipolla :)

I just wish that could have been easier like on Ubuntu / regular Mint ...
RavanH
Level 2
Level 2
 
Posts: 53
Joined: Sun Jan 17, 2010 6:24 am

Re: Keyboard layout issue in LMDE

Postby elav on Sat Jan 08, 2011 1:30 pm

I had a similar problem. What I did was select my keyboard settings in the GDM and I was fixed for ever.
User avatar
elav
Level 2
Level 2
 
Posts: 97
Joined: Tue Oct 26, 2010 11:27 am
Location: /var/www/mint-forum

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 6 guests