Need libgtk2.0-dev...how to get?

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Need libgtk2.0-dev...how to get?

Postby wh7qq on Tue Dec 21, 2010 11:06 pm

I need libgtk2.0-dev in order to compile the hdhomeun_config_gui utility for the hdhomerun tv tuner. I can run it in mythbuntu where the utility is already set up but I would prefer to run it in LMDE. When I try to install it I get:

Code: Select all
$ sudo apt-get install libgtk2.0-dev
[sudo] password for paul:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgtk2.0-dev : Depends: libpango1.0-dev (>= 1.20) but it is not going to be installed
                 Depends: libcairo2-dev (>= 1.6.4-6.1) but it is not going to be installed
E: Broken packages


Suggestions?

Paul
wh7qq
Level 1
Level 1
 
Posts: 34
Joined: Mon Mar 15, 2010 5:43 pm

Linux Mint is funded by ads and donations.
 

Re: Need libgtk2.0-dev...how to get?

Postby beefstu on Wed Dec 22, 2010 6:08 am

Try to install the dependencies manually.
Code: Select all
apt install libpango1.0-dev libcairo2-dev
then try again
Please go through the steps here when posting a question. Once your question has been resolved, edit the original question post and add [Solved] to the subject. Both of these will help others use the forum effectively.
User avatar
beefstu
Level 5
Level 5
 
Posts: 654
Joined: Tue Dec 29, 2009 10:22 am
Location: Southampton, UK

Re: Need libgtk2.0-dev...how to get?

Postby vincent on Wed Dec 22, 2010 6:17 am

Heh, dependency hell in action again! :P

The Mint devs recently updated LMDE's repo to include a patched libcairo2 (for better font rendering than what is default in Debian), and unfortunately they forgot to import a couple of dependencies for libcairo2-dev from the Ubuntu repositories. I ran into this problem a few days ago, but I forgot which packages had to be manually fetched from http://packages.ubuntu.com ... so just apt-get install libcairo2-dev, look at what packages APT is complaining about, and then search for them on Ubuntu's website, download them, install them with "dpkg -i", and rinse and repeat until you solve all the dependency problems.
Debian Testing x64/LM9 Main x64/Windows 7 x64 - LG R580 laptop w/ Intel Core 2 Duo T6500 2.1 GHz, 4 GB DDR2 RAM, Nvidia Geforce G 105M, Ralink rt2860 802.11n, 300 GB WD HD 5400 rpm
vincent
Level 8
Level 8
 
Posts: 2220
Joined: Tue Feb 09, 2010 4:10 am

Re: Need libgtk2.0-dev...how to get?

Postby gotjazz on Thu Dec 23, 2010 8:39 pm

hrm hope that'll be fixed soon - that's not an unimportant package....

sure you can get other packages from the ubuntu servers yourself and so on but still. not everyone compiling stuff that basically works just fine on debian should have to do that on lmde.

but this IS a nice example of how ubuntu packages aren't always 100% good for debian :mrgreen:
Image
User avatar
gotjazz
Level 4
Level 4
 
Posts: 386
Joined: Fri May 28, 2010 11:38 am
Location: Vienna, Austria

Re: Need libgtk2.0-dev...how to get?

Postby Kiranos on Mon Dec 27, 2010 10:01 am

Hi I installed the new "Linux Mint Debian (201012)" And I'm trying to install the same packege and I still get:

Code: Select all

The following packages have unmet dependencies:
libgtk2.0-dev : Depends: libpango1.0-dev (>= 1.20) but it is not going to be installed
                 Depends: libcairo2-dev (>= 1.6.4-6.1) but it is not going to be installed
E: Broken packages



Do you guys have direct links to the correct packages, or better yet a fix in a close timeframe?
Kiranos
Level 1
Level 1
 
Posts: 3
Joined: Mon Dec 27, 2010 9:58 am

Re: Need libgtk2.0-dev...how to get?

Postby vincent on Mon Dec 27, 2010 7:58 pm

No, I don't have direct links to the right packages, as I didn't jot them down when I was solving this issue myself, and I'm not about to go and uninstall and reinstall a bunch of packages when you can easily find this information yourself. :P

Code: Select all
sudo apt-get install libpango1.0-dev libcairo2-dev


Just keep on "apt-get install"-ing packages until you find some required packages that aren't present in Debian's repository, and search for them on http://packages.ubuntu.com.
Debian Testing x64/LM9 Main x64/Windows 7 x64 - LG R580 laptop w/ Intel Core 2 Duo T6500 2.1 GHz, 4 GB DDR2 RAM, Nvidia Geforce G 105M, Ralink rt2860 802.11n, 300 GB WD HD 5400 rpm
vincent
Level 8
Level 8
 
Posts: 2220
Joined: Tue Feb 09, 2010 4:10 am

Re: Need libgtk2.0-dev...how to get?

Postby crispata on Tue Dec 28, 2010 5:11 pm

Having this exact problem. How to get this to the devs attention? -- Is there a bugs thread? The only one I see is locked. I did a reinstall based on this because I was sure it was my fault and I'd irrevocably hosed something up. :oops:

I understand the proposed solution in this thread -- but honestly it kinda stinks. I'm happy to wait awhile for this to get fixed, but hope it does indeed get fixed soon!!
crispata
Level 1
Level 1
 
Posts: 34
Joined: Sat Dec 06, 2008 10:53 pm

Re: Need libgtk2.0-dev...how to get?

Postby vincent on Tue Dec 28, 2010 8:51 pm

Report all bugs on Launchpad...

I think the "bug" escaped the developers' attention mostly because of the fact that regular Mint users don't usually need -dev packages for their day-to-day activities. It's not a showstopper bug though, so I don't mind too much.
Debian Testing x64/LM9 Main x64/Windows 7 x64 - LG R580 laptop w/ Intel Core 2 Duo T6500 2.1 GHz, 4 GB DDR2 RAM, Nvidia Geforce G 105M, Ralink rt2860 802.11n, 300 GB WD HD 5400 rpm
vincent
Level 8
Level 8
 
Posts: 2220
Joined: Tue Feb 09, 2010 4:10 am

Re: Need libgtk2.0-dev...how to get?

Postby crispata on Tue Dec 28, 2010 9:06 pm

I think the "bug" escaped the developers' attention mostly because of the fact that regular Mint users don't usually need -dev packages for their day-to-day activities. It's not a showstopper bug though, so I don't mind too much.


Fair enough. :) I'm not grumpy about it, it was just frustrating to run into right away upon switching to a new distro. Will hit up launchpad...
crispata
Level 1
Level 1
 
Posts: 34
Joined: Sat Dec 06, 2008 10:53 pm

Re: Need libgtk2.0-dev...how to get?

Postby glo0m on Wed Dec 29, 2010 12:13 pm

Hi,

is there a way to downgrade the "affected" packages? (which packages?)
I need to install libgtkmm-2.4-dev (which also needs libgtk2.0-dev and some other -devs that won't install) for compiling Easystroke.

Thx, glo0m
glo0m
Level 1
Level 1
 
Posts: 1
Joined: Wed Dec 29, 2010 11:39 am
Location: Germany

Re: Need libgtk2.0-dev...how to get?

Postby crispata on Thu Dec 30, 2010 7:30 am

FYI bug is here for everyone interested. Someone beat me to it...

https://bugs.launchpad.net/linuxmint/+bug/695621
crispata
Level 1
Level 1
 
Posts: 34
Joined: Sat Dec 06, 2008 10:53 pm

Re: Need libgtk2.0-dev...how to get?

Postby gotjazz on Fri Jan 21, 2011 9:03 am

hrm any news on that?
I hate booting fedora everytime I wasn to try ANYTHING i have to build from source. (current banshee dev versions, building gnome-panel to allow more favorites before grouping them, maybe take another look at gnome-shell)
plus my fedora install is running on rawhide right now so it can break any day which is why I'd rather have some of this stuff on ldme
Image
User avatar
gotjazz
Level 4
Level 4
 
Posts: 386
Joined: Fri May 28, 2010 11:38 am
Location: Vienna, Austria

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: Google Adsense [Bot], Yahoo [Bot] and 3 guests