LMDE Login Puzzler

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

LMDE Login Puzzler

Postby lakehousetech on Tue Dec 28, 2010 5:42 pm

Hey All,
I booted LMDE x64 today, and upon entering in my password at the login prompt the screen goes black momentarily before returning me to the login prompt. Initially I thought there may be a problem with GDM, so I removed all configuration settings and tried again. No go. So I went a step ahead and removed GDM completely and then re-installed it. This also made no difference. Can someone point me in a direction (which log file to check?) or possibly someone else has encountered a similar problem? I found nothing while searching the forums (aside from others with GDM problems). I appreciate your time!

Edit: I am NOT using any Nvidia drivers.
Wherever you go, there you are... - Buckaroo Banzai
http://www.lakehousetech.com
- Mint Debian
User avatar
lakehousetech
Level 4
Level 4
 
Posts: 454
Joined: Wed Nov 07, 2007 3:34 pm
Location: Toronto, ON

Linux Mint is funded by ads and donations.
 

Re: LMDE Login Puzzler

Postby mads on Wed Dec 29, 2010 5:36 am

You could try to add "pci=noacpi" to the kernel line before boot.

1. Restart your PC
2. Highlight the Linux Mint entry and press the "e" key
3. Use the cursor keys to navigate to the line that ends with "quiet splash" (kernel line) and add pci=noacpi, like this:
Code: Select all
... quiet splash pci=noacpi

4. When you are done editing the kernel line, press Ctrl-x to boot

If you see that this change helps, you can make it permanent by editing /etc/default/grub file.
gksudo gedit /etc/default/grub
Change this line:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
and make it look like this:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=noacpi"
Save the file. Finally, run:
sudo update-grub
Reboot your computer.

NOTE: If "pci=noacpi" doesn't help, you could try other options (see 2nd post by "Fornhamfred" in this thread). You find a list of the Kernel Options here.
User avatar
mads
Level 6
Level 6
 
Posts: 1309
Joined: Wed Nov 03, 2010 3:44 pm

[SOLVED] Re: LMDE Login Puzzler

Postby lakehousetech on Thu Dec 30, 2010 11:22 am

Thanks so much for the tips! I finally figured it out. The problem was a theme I installed from http://art.gnome.org/themes/ which fouled everything up. I can't remember which specific theme I installed in particular that caused the login loop issue, but it's possible it is related to incompatibilities with GDM3. The frustrating part of all this was the fact that I removed GDM including all the directories...and upon reinstall it was still screwed up. This tells me that there must be another configuration file somewhere that I missed. I ended up re-installing LMDE and retracing my steps from before to determine where the fault occurred. Needless to say I'm using the included themes from now on. I have to say this is the first time in years of using Linux that I've had a problem that stumped me like this. Hope that this is helpful information for anyone else that encounters a login loop problem. Have a great new year!
Wherever you go, there you are... - Buckaroo Banzai
http://www.lakehousetech.com
- Mint Debian
User avatar
lakehousetech
Level 4
Level 4
 
Posts: 454
Joined: Wed Nov 07, 2007 3:34 pm
Location: Toronto, ON

Re: LMDE Login Puzzler

Postby secipolla on Thu Dec 30, 2010 12:16 pm

Not so long ago there was a person with the same problem (I think in the Debian forum) because he had a conflicting xfce theme too.
secipolla
Level 4
Level 4
 
Posts: 356
Joined: Sun Sep 05, 2010 5:19 pm


Return to Newbie Questions

Who is online

Users browsing this forum: killer de bug and 5 guests