[SOLVED] Compiz

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

[SOLVED] Compiz

Postby KronicBratwurst on Thu Dec 30, 2010 7:14 am

Switching to LMDE, and all works fine... just wondering if it were possible to get minimize/close/whatever else compiz effects (e.g. magic lamp/ glide effects...) without simple-ccsm?
Last edited by KronicBratwurst on Thu Dec 30, 2010 9:42 am, edited 1 time in total.
Image
The box said, "Requires Windows XP or better" so I installed Linux.
KronicBratwurst
Level 1
Level 1
 
Posts: 23
Joined: Tue Jun 01, 2010 6:38 pm

Linux Mint is funded by ads and donations.
 

Re: Compiz

Postby crispata on Thu Dec 30, 2010 8:06 am

Edit: After I typed all this I found this on the Debian Wiki. It's a bit more structured and less seat-of-the-pants than my instructions... :)
They don't mention the compiz-fusion-plugins-extra package though -- you are probably going to want that.

http://wiki.debian.org/Compiz



Unlike Ubuntu or the regular Mint you'll have to go through and manually turn on wobbly windows and the animations plugins and etc, but it's not too bad. It didn't take me very long to have it tarted up nicely.

If you've been using simple ccsm then the full ccsm may seem a bit daunting at first, but most of the eyecandy stuff is reasonably good at default settings. Also most settings have a decent explanatory tooltip if you aren't sure what they do. CCSM will tell you if you enable plugins that conflict with each other (some of them overlap with regard to functionality or keyboard shortcuts) so you can decide what you want to do.

If no one beats me to it, I'm happy to give some better help later tonight when I get home and have my LMDE install as a reference, but if you've fooled around with this at all before I think this should be enough to get you going.

I sorta sniffed my way through this, and again am not at my LMDE computer now, but here's loosely what I did --

Ensure compiz-core is installed (think it was by default)
compiz-fusion-plugins-main (also installed by default, I think)
and compiz-fusion-plugins-extra (not installed by default I think)
and compizconfig-settings-manager
I think compiz-gnome is pulled in as a dependency of something else, but be sure that is there too

Then you just fire up compiz config settings manager (in preferences) and start turning things on. Off the top of my head, you'll want to turn on these typical plugins:

GNOME compatibilty
Wobbly-windows
Animations
Animations Add-On
Window Decorations

If you want the typical cube effects you'll want
Desktop Cube
Rotate Cube

I'm also a big fan of Expo, Scale and Shift Switcher (bind Shift Switcher to Alt-Tab and you get a much nicer looking window picker)

You should also have a look at "Workarounds", and I think at least one of the others will tell you it requires regex matching to be turned on when you enable it. (Which it will then do for you.)

So, having done all that, you can check that it works by doing alt-f2 and typing "compiz --replace"

No matter what, you will lose compiz the next time you log out, so if things go crazy (and they shouldn't -- worst case nothing should happen), just ctrl-alt-backspace to restart x and log back in.

Assuming that they went well, there are a few ways to make compiz permanent.

My favorite way (but it's the least elegant or tech savvy way) is just to install fusion-icon. After you do that, add fusion-icon to Startup Applications. This will create an icon in the tray that you can use to turn Compiz off and on among other things, and it will turn it on when fusion-icon launches every time you login. I've been told that nvidia cards work much better with "loose binding" enabled (one of the options in the right-click menu of fusion-icon) and I have enabled it myself, but couldn't say whether it has made any difference.

You'll want to dig into the settings for the various plugins eventually, but I strongly recommend that you change only one thing at a time until you get comfortable with CCSM.

Hopefully this is enough to get you started. Anyone else can jump in to correct me if I got anything wrong or left something out. :)
crispata
Level 1
Level 1
 
Posts: 34
Joined: Sat Dec 06, 2008 10:53 pm

Re: Compiz

Postby KronicBratwurst on Thu Dec 30, 2010 8:39 am

i installed all the required packages, but when i add the xorg.conf lines and reboot it won't start X... when i start compiz via compiz --replace in the terminal i get this error:
Code: Select all
Xlib:  extension "GLX" missing on display ":0.0".
compiz (core) - Fatal: Root visual is not a GL visual
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0

Launching fallback window manager
Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x1c00003 (Authentica)
Window manager warning: meta_window_activate called by a pager with a 0 timestamp; the pager needs to be fixed.
Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x1c00003 (Authentica)
Window manager warning: meta_window_activate called by a pager with a 0 timestamp; the pager needs to be fixed.


:?:
Image
The box said, "Requires Windows XP or better" so I installed Linux.
KronicBratwurst
Level 1
Level 1
 
Posts: 23
Joined: Tue Jun 01, 2010 6:38 pm

Re: Compiz

Postby crispata on Thu Dec 30, 2010 8:48 am

^^ I didn't modify my xorg.conf at all beyond what I'd done when installing the proprietary nvidia driver -- Are you running the proprietary driver for whatever card you have? (I've only ever used nvidia under Linux -- but I think you need the proprietary driver for Compiz for ATI as well...?)
crispata
Level 1
Level 1
 
Posts: 34
Joined: Sat Dec 06, 2008 10:53 pm

Re: Compiz

Postby KronicBratwurst on Thu Dec 30, 2010 8:53 am

idk if i have the *proprietary* drivers for either... how can i get them?
Image
The box said, "Requires Windows XP or better" so I installed Linux.
KronicBratwurst
Level 1
Level 1
 
Posts: 23
Joined: Tue Jun 01, 2010 6:38 pm

Re: Compiz

Postby crispata on Thu Dec 30, 2010 9:26 am

I can only help you if you have nvidia, and my only experience here is blindly cookbooking the debian wiki. There's another thread here where I think they went about it slightly differently, but this worked for me...

I used the module-assistant method here: http://wiki.debian.org/NvidiaGraphicsDrivers#Methods

It breaks down to these steps, all from a root terminal (use the accessories--> root terminal shortcut to launch, or issue the su command first in a normal terminal)

Code: Select all
apt-get install module-assistant nvidia-kernel-common

Code: Select all
m-a auto-install nvidia-kernel${VERSION}-source

Code: Select all
apt-get install nvidia-glx${VERSION}


Then:
I used the nvidia-xconfig option to create my xorg.conf even though they don't recommend it in the wiki, and it worked fine, which is these steps:
To install:
Code: Select all
apt-get install nvidia-xconfig

Then to have it modify or create your xorg.conf:
*********NOTE:************
If you *created* xorg.conf to add the lines you added previously, or if you are otherwise not sure you added them correctly, I'd do this before running the final nvidia-xconfig command:
This will rename your xorg.conf, and let nvidia-xconfig build you a fresh xorg.conf -- which *for me* went off without a hitch. But this way you have a copy of the old one so you can switch back to that old .conf file if you need to due to problems.
Code: Select all
mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak

So after you run the mv command or choose not to, then do this
Code: Select all
nvidia-xconfig


You aren't supposed to have to reboot to apply these changes, just restart X -- but it didn't seem to go quite right when I did that, and I ended up rebooting anyway. So to be safe just do a reboot. If all went well, not only will Compiz work when you try it, but you should see a brief nvidia splash screen during boot.
crispata
Level 1
Level 1
 
Posts: 34
Joined: Sat Dec 06, 2008 10:53 pm

Re: Compiz

Postby KronicBratwurst on Thu Dec 30, 2010 9:41 am

ty for the help, and i found a page that solved my problem :D
Image
The box said, "Requires Windows XP or better" so I installed Linux.
KronicBratwurst
Level 1
Level 1
 
Posts: 23
Joined: Tue Jun 01, 2010 6:38 pm

Re: [SOLVED] Compiz

Postby crispata on Thu Dec 30, 2010 9:43 am

Nice! :)
crispata
Level 1
Level 1
 
Posts: 34
Joined: Sat Dec 06, 2008 10:53 pm

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 4 guests