gvfs - no permission [SOLVED]

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

gvfs - no permission [SOLVED]

Postby maulbongo on Sun Jan 02, 2011 2:48 pm

Hello,

I got a problem using gvfs-fuse with debian. I installed it like written down here:

http://forums.linuxmint.com/viewtopic.p ... 56#p316972

Now I connect a share and the share gets mounted to /home/mip/.gvfs

But I can't access the files in there.

ls -al ~ | grep gvfs
dr-x------ 2 mip mip 0 2. Jan 2011 .gvfs

So thats all fine, if I compare it to my ubuntu machine, all is same.
And when I mount the share via Nautilus using gvfs-mount with ubuntu and debian the shares are there, but I cant access them with debian, with ubuntu it works.
What I have seen is, that there arrived today new updates for gvfs, but I can't say that it worked before.
Is there a known problem or can someone check it?
Last edited by maulbongo on Mon Jan 03, 2011 4:48 am, edited 1 time in total.
maulbongo
Level 1
Level 1
 
Posts: 4
Joined: Sat Nov 06, 2010 4:25 am

Linux Mint is funded by ads and donations.
 

Re: gvfs - no permission

Postby ukbrian on Sun Jan 02, 2011 7:46 pm

I don't know if this would help you but I run a file at startup to give me access to my public dir on my NAS drive called
nas.sh
Code: Select all
#!/bin/sh
gvfs-mount smb://neptune/public
ln -s /home/brian/.gvfs/'public on neptune' /home/brian/neptune
I installed gvfs-fuse and smbfs and made myself a member of the fuse group.
It automaticaly creates a folder called neptune in my home dir which contains the folders/files but you can point it anywhere I would think

PS did you make yourself a member of the fuse group?
ukbrian
User avatar
ukbrian
Level 4
Level 4
 
Posts: 276
Joined: Thu Jul 29, 2010 6:03 am
Location: Cheltenham, UK

Re: gvfs - no permission

Postby altair4 on Sun Jan 02, 2011 7:55 pm

I'm posting only because you referenced my post. My post said to do the following regarding gvfs:

sudo apt-get install gvfs-fuse
sudo gpasswd -a your-user-name fuse

Did you do the last step:
Then logoff and login again ( this is for the group changes to take affect ).


EDIT: What is the output of:
Code: Select all
ls -al /home/mip/.gvfs
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 16
Level 16
 
Posts: 6279
Joined: Tue Feb 03, 2009 10:27 am

Re: gvfs - no permission

Postby maulbongo on Mon Jan 03, 2011 2:21 am

@ukbrain:

Ok, for this I'll give it a try, but actually thats not the way it should work. And ok course I am a member of fuse group.

@altair4:

I did all the steps exactly, also the logoff and logon.

ls -al /home/mip/.gvfs

gives me:
Code: Select all
insgesamt 4
dr-x------  2 mip mip    0  3. Jan 08:11 .
drwxr-xr-x 50 mip mip 4096  3. Jan 08:11 ..


and on my ubuntu machine:
Code: Select all
insgesamt 4
dr-x------  5 mip mip    0 2010-12-20 12:17 .
drwxr-xr-x 53 mip mip 4096 2011-01-02 14:25 ..
maulbongo
Level 1
Level 1
 
Posts: 4
Joined: Sat Nov 06, 2010 4:25 am

Re: gvfs - no permission [SOLVED]

Postby maulbongo on Mon Jan 03, 2011 4:45 am

Hi Again,

Now I did a cross check, I got an lmde machine at work and there I checked it, too.
There everything works smooth, so I tried to setup the groupmembership on my home machine again (I removed user mip from group fuse, restartet the system, then I added user mip to group fuse again) and now it's working like a charme there (just like original ubuntu behavior).

@altair4 regarding your howto, it is not neccessary to install smbclient for using gvfs-mount, this is needed for cifs mounting, here an example:

Code: Select all
mount //russell/pub /mnt/russellmnt/pub -o iocharset=utf8,uid=1000,username=mip,password=*******
, this wouldnt work if smbclient is not installed, but gvfs-mount is doing it without the smbclient (perhaps you can update your thread).
maulbongo
Level 1
Level 1
 
Posts: 4
Joined: Sat Nov 06, 2010 4:25 am

Re: gvfs - no permission [SOLVED]

Postby altair4 on Mon Jan 03, 2011 8:15 am

maulbongo wrote:@altair4 regarding your howto, it is not neccessary to install smbclient for using gvfs-mount, this is needed for cifs mounting, here an example:

You didn't read the first sentence of my referenced post :wink:
This post is going to look scary but that's only because I'm suggesting you fix a few other things along the way. There are a number of things you need to change in order for Samba to play nice in a peer-to-peer environment in LMDE:

smbclient is used for many things, for example:

The command "smbtree" won't run without it.

If you try to access a remote Windows attached printer using the Printer utility in Mint then the "Windows Printer via Samba" will not be an available option without it.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 16
Level 16
 
Posts: 6279
Joined: Tue Feb 03, 2009 10:27 am

Re: gvfs - no permission [SOLVED]

Postby maulbongo on Mon Jan 03, 2011 8:57 am

Hi altair4,

Oh thats true, sorry for that missunderstanding.
maulbongo
Level 1
Level 1
 
Posts: 4
Joined: Sat Nov 06, 2010 4:25 am

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 6 guests