[Retired/Solved] symlink not working

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

[Retired/Solved] symlink not working

Postby zebedeeboss on Sat Jan 08, 2011 7:16 pm

Hi

I get the following error when I try and create a symlink

"This link cannot be used, because its target "/home/robert/.gvfs/smb://192.168.1.69/tvshowsv" doesn't exist"

I am auto mounting that share at startup using

Code: Select all
#!/bin/sh
gvfs-mount smb://Server/share_name


and that is working fine... however there are no files in .gvfs so the symlink is not working or I wrote it wrong

If you have an application that requires a known path and it can access a hidden directory then there is no problem. If however your application cannot access a hidden directory or if you prefer to have it mount somewhere other than the default location then one way to accomplish that is to use a symbolic link to a non-hidden directory. For example:
Code: Select all
CODE: SELECT ALL
sudo mkdir /media/Music
sudo ln -s /home/altiar/.gvfs/"music on seagate" /media/Music


Where "music on seagate" is the share on the remote machine and /media/Music is the place you would prefer to access it.


in place of "music on segate" I put smb://192.168.1.69/tvshowsv and I of course made my own directory diff to named above

Advise please

Thanks Zeb...
Last edited by zebedeeboss on Sat Jan 15, 2011 2:16 pm, edited 1 time in total.
Linux i5-mint16 3.11.0-12-generic #19-Ubuntu SMP Wed Oct 9 16:20:46 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
Intel i5-2320 @3.00 x 4 6Gb GeoForce GT 640 2Gb

Be Nice or Be Some Where Else
zebedeeboss
Level 1
Level 1
 
Posts: 46
Joined: Sun Oct 03, 2010 11:43 am

Linux Mint is funded by ads and donations.
 

Re: symlink not working

Postby altair4 on Sat Jan 08, 2011 7:28 pm

I thought I got rid of you :lol:
"/home/robert/.gvfs/smb://192.168.1.69/tvshowsv"

It should be:
/home/robert/.gvfs/tvshowsv on 192.168.1.69


Code: Select all
ln -s /home/robert/.gvfs/"tvshowsv on 192.168.1.69" /whatever-you-named-it.


Maybe I made a mistake in my HowTo.
Last edited by altair4 on Sat Jan 08, 2011 8:29 pm, edited 1 time in total.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 16
Level 16
 
Posts: 6216
Joined: Tue Feb 03, 2009 10:27 am

Re: symlink not working

Postby willie42 on Sat Jan 08, 2011 7:41 pm

Altair I think he likes your work :lol: :D :wink:
Comptia A+ Certified Technician
Comptia Network + Certified Technician
You can not have Success without Failures.
User avatar
willie42
Level 7
Level 7
 
Posts: 1977
Joined: Tue Jun 22, 2010 7:52 pm
Location: Oak Ridge, TN USA

Re: symlink not working

Postby zebedeeboss on Sun Jan 09, 2011 2:56 am

altair4 wrote:I thought I got rid of you :lol:

Hahaha - I am like that bad rash that won't go away... it just needs scratching :lol:

ok error message I now get is "This link cannot be used, because its target "/home/robert/.gvfs/tvshowsv on 192.168.1.69" doesn't exist"

confused as on my desktop is a link for tvshowsv and it takes me to my other machine and the files on there...

willie42 wrote:Altair I think he likes your work :lol: :D :wink:

You're right I do :D simple explanations in English - just what the Dr ordered
Linux i5-mint16 3.11.0-12-generic #19-Ubuntu SMP Wed Oct 9 16:20:46 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
Intel i5-2320 @3.00 x 4 6Gb GeoForce GT 640 2Gb

Be Nice or Be Some Where Else
zebedeeboss
Level 1
Level 1
 
Posts: 46
Joined: Sun Oct 03, 2010 11:43 am

Re: symlink not working

Postby altair4 on Sun Jan 09, 2011 8:55 am

Let's start from the beginning.

You created a script that contained among other things this command:
Code: Select all
gvfs-mount smb://192.168.1.69/tvshowsv

Now open Nautilus and go to /home/robert/.gvfs. If you cannot see the ".gvfs" folder you need to modify Nautilus' preferences:
Nautilus > Edit > Preferences > Default View > Show Hidden and Backup Files.

What you should see when opening up ".gvfs" is the following subfolder:
tvshowsv on 192.168.1.69

Now let's say you want to create a symbolic link from there to another folder in your home folder, for example: /home/robert/ServerTV
Code: Select all
mkdir /home/robert/ServerTV
ln -s /home/robert/.gvfs/"tvshowsv on 192.168.1.69" /home/robert/ServerTV

Perhaps the problem you're having is that you are not putting " " around the "tvshowsv on 192.168.1.69" part which is required in Linux because of the spaces in the name.

EDIT: You know it just occurred to me that you are using LMDE. LMDE doesn't install everything required to use gvfs-mount by default.
Do this first:
Code: Select all
sudo apt-get install gvfs-fuse

Add yourself to the fuse group:
Code: Select all
sudo gpasswd -a robert fuse

Then logoff and login again for the group membership to change. Now you should be able to see the subfolder in ".gvfs"
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 16
Level 16
 
Posts: 6216
Joined: Tue Feb 03, 2009 10:27 am

Re: symlink not working

Postby zebedeeboss on Sun Jan 09, 2011 10:27 am

Hi altair4

I am just messing in Windows at the moment... the share is fine from here and accessible...

Last time I looked the file was not in .gvfs so I will do the sudo apt-get bit again and the sudo gpasswd as well.

Thanks again for all your help :) You're a star and I am sure this tutorial will help other people as well.

Thanks Zeb :)
Linux i5-mint16 3.11.0-12-generic #19-Ubuntu SMP Wed Oct 9 16:20:46 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
Intel i5-2320 @3.00 x 4 6Gb GeoForce GT 640 2Gb

Be Nice or Be Some Where Else
zebedeeboss
Level 1
Level 1
 
Posts: 46
Joined: Sun Oct 03, 2010 11:43 am

Re: symlink not working

Postby zebedeeboss on Sat Jan 15, 2011 3:23 am

altair4 wrote:Let's start from the beginning.

You created a script that contained among other things this command:
Code: Select all
gvfs-mount smb://192.168.1.69/tvshowsv

Now open Nautilus and go to /home/robert/.gvfs. If you cannot see the ".gvfs" folder you need to modify Nautilus' preferences:
Nautilus > Edit > Preferences > Default View > Show Hidden and Backup Files.

What you should see when opening up ".gvfs" is the following subfolder:
tvshowsv on 192.168.1.69


Hi folks back for another weekend :D

the script only contains that one line and there is no reference in the .gvfs folder

there is a shortcut on my desktop that opens the share and the files are accessible and the files are also accessible within a windows environment... so really confused lol

Zeb...
Linux i5-mint16 3.11.0-12-generic #19-Ubuntu SMP Wed Oct 9 16:20:46 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
Intel i5-2320 @3.00 x 4 6Gb GeoForce GT 640 2Gb

Be Nice or Be Some Where Else
zebedeeboss
Level 1
Level 1
 
Posts: 46
Joined: Sun Oct 03, 2010 11:43 am

Re: symlink not working

Postby altair4 on Sat Jan 15, 2011 8:14 am

Did you do this:

Code: Select all
sudo apt-get install gvfs-fuse

Code: Select all
sudo gpasswd -a robert fuse

Then logoff and login again for the group membership to change.

Now see if your .gvfs folder holds "tvshowsv on 192.168.1.69"
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 16
Level 16
 
Posts: 6216
Joined: Tue Feb 03, 2009 10:27 am

Re: symlink not working

Postby zebedeeboss on Sat Jan 15, 2011 10:29 am

Hi altair4

thanks for picking the thread back up... followed instructions... rebooted and yet I still see no files in .gvfs

Zeb
Linux i5-mint16 3.11.0-12-generic #19-Ubuntu SMP Wed Oct 9 16:20:46 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
Intel i5-2320 @3.00 x 4 6Gb GeoForce GT 640 2Gb

Be Nice or Be Some Where Else
zebedeeboss
Level 1
Level 1
 
Posts: 46
Joined: Sun Oct 03, 2010 11:43 am

Re: symlink not working

Postby altair4 on Sat Jan 15, 2011 1:58 pm

There is something wrong with "fuse" on your install. I'm not smart enough to know what that could be and I cannot reproduce your problem on my own system. If you want to further this all I can recommend is that you make sure you have the following fuse related packages installed:
Code: Select all
fuse-utils
gvfs
gvfs-backends
gvfs-bin
gvfs-fuse
libfuse2

If that's all there then I'm at a loss.

If you don't want to peruse the fuse issue then mount the remote share the way your grampa did. To follow my earlier example add the following line to the end of /etc/fstab:
Code: Select all
//192.168.1.69/tvshowsv /home/robert/ServerTV cifs guest,uid=1000,_netdev 0 0

Save the file and issue the following command:
Code: Select all
sudo mount -a

If it mounts without error reboot your machine and pray. Ubuntu introduced a bug where in some cases fstab will execute before the network is up and the fstab method won't work either but there is a workaround for Ubuntu's lack of adult supervision.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 16
Level 16
 
Posts: 6216
Joined: Tue Feb 03, 2009 10:27 am

Re: [Retired/Solved] symlink not working

Postby zebedeeboss on Sat Jan 15, 2011 2:19 pm

Hi altair4

Thank you very much for all your efforts.

All of those dependencies are there and yet it still refuses to work...

I will leave it for now... wait until I learn more about linux and revisit it at a later date

Watch this space

Thanks again

Zeb...
Linux i5-mint16 3.11.0-12-generic #19-Ubuntu SMP Wed Oct 9 16:20:46 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
Intel i5-2320 @3.00 x 4 6Gb GeoForce GT 640 2Gb

Be Nice or Be Some Where Else
zebedeeboss
Level 1
Level 1
 
Posts: 46
Joined: Sun Oct 03, 2010 11:43 am

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 3 guests